aboutsummaryrefslogtreecommitdiff
path: root/japanese/today
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-08-07 08:26:25 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-08-07 08:26:25 +0000
commitaa2b64b1341b5c50a96de151e149fb1eed4eb3c4 (patch)
tree8de6c22d54278af0e2b0de7f635dfb421e22fc43 /japanese/today
parent8cc476fe761371db9828ddd05c6325e709830d21 (diff)
downloadports-aa2b64b1341b5c50a96de151e149fb1eed4eb3c4.tar.gz
ports-aa2b64b1341b5c50a96de151e149fb1eed4eb3c4.zip
- Update to version 2.12
- Update MASTER_SITES and WWW: line - Use DATADIR macro PR: ports/158477 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=279103
Diffstat (limited to 'japanese/today')
-rw-r--r--japanese/today/Makefile27
-rw-r--r--japanese/today/distinfo8
-rw-r--r--japanese/today/files/Makefile6
-rw-r--r--japanese/today/files/patch-ai18
-rw-r--r--japanese/today/files/patch-al31
-rw-r--r--japanese/today/pkg-descr2
-rw-r--r--japanese/today/pkg-plist78
7 files changed, 86 insertions, 84 deletions
diff --git a/japanese/today/Makefile b/japanese/today/Makefile
index c734db0fdd6d..ec0805a1a60b 100644
--- a/japanese/today/Makefile
+++ b/japanese/today/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= today
-PORTVERSION= 2.11a
+PORTVERSION= 2.12
CATEGORIES= japanese games
-MASTER_SITES= ftp://ftp.vector.co.jp/pack/dos/personal/calendar/today/
+MASTER_SITES= http://ftp.vector.co.jp/pack/dos/personal/calendar/today/
DISTNAME= ja-${PORTNAME}-${PORTVERSION}
DISTFILES= td${PORTVERSION:S/.//}s.lzh \
td${PORTVERSION:S/.//}m.lzh
@@ -16,9 +16,6 @@ DISTFILES= td${PORTVERSION:S/.//}s.lzh \
MAINTAINER= ports@FreeBSD.org
COMMENT= Tells you what day today is
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-08-01
-
EXTRACT_DEPENDS=lha:${PORTSDIR}/archivers/lha \
nkf:${PORTSDIR}/japanese/nkf
@@ -28,25 +25,29 @@ EXTRACT_AFTER_ARGS= # empty
NO_WRKSUBDIR= yes
+MAKEFILE= ${FILESDIR}/Makefile
+
post-extract:
+ @(cd ${WRKSRC}; lha xiqf utility.lzh src/dayinfo.c )
@${ECHO_MSG} "===> Extracting tbl file for ${DISTNAME}"
@(cd ${WRKSRC}; lha xqf tbl.lzh )
@${ECHO_MSG} "===> Converting Kanji code for ${DISTNAME}"
@(cd ${WRKSRC}; \
for i in *.c *.h *.doc *.cnf birthday.tbl event*.tbl flower.tbl \
- gengo.tbl hist??.tbl history.tbl holiday.tbl magazine.tbl \
- monthly.tbl schedule.tbl suffix.tbl week.tbl; \
+ gengo.tbl hist??.tbl history.tbl holiday.tbl magazine.tbl \
+ monthly.tbl schedule.tbl suffix.tbl week.tbl; \
do \
${SED} 's/.$$//' $$i | nkf -Se > $$i.tmp ;\
${MV} -f $$i.tmp $$i ; \
done)
- @(cd ${WRKSRC}; lha xiqf utility.lzh src/dayinfo.c )
-
-pre-patch:
- @${ECHO_MSG} "===> Installing custom Makefile for ${DISTNAME}"
- @(${CP} ${FILESDIR}/Makefile ${WRKSRC})
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/*.cnf
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' ${WRKSRC}/*.cnf
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/today.doc ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/japanese/today/distinfo b/japanese/today/distinfo
index 95f625fa03c2..570bcc32b96d 100644
--- a/japanese/today/distinfo
+++ b/japanese/today/distinfo
@@ -1,4 +1,4 @@
-SHA256 (td211as.lzh) = e597849a8f1f5ceb88aefe41b869fa0fa97083d6075a8efbffda1a9bce5d0be6
-SIZE (td211as.lzh) = 180925
-SHA256 (td211am.lzh) = c55a73d76eac8b03e21bbb2fc94f0a5cebcfe2482feefe2372e119b4367b627e
-SIZE (td211am.lzh) = 380771
+SHA256 (td212s.lzh) = 3dc22910825e9be0cb71957265a0d8cc8369c392f9f7c12923f4a863b38c8ed0
+SIZE (td212s.lzh) = 208034
+SHA256 (td212m.lzh) = f10908f2a15c45f6549173224626f478893f420aa64c30e90ac1b5b419b01f06
+SIZE (td212m.lzh) = 463411
diff --git a/japanese/today/files/Makefile b/japanese/today/files/Makefile
index d12615871388..7234d1aab5ea 100644
--- a/japanese/today/files/Makefile
+++ b/japanese/today/files/Makefile
@@ -4,7 +4,7 @@
# $FreeBSD$
CC ?= cc
-CFLAGS += -DTRANS -DMSG_STYLE -DINTERNAL_KYUREKI_TBL -D_T_SEARCH_CMDPATH=\"${PREFIX}/etc\" #-DUSE_TERMCAP
+CFLAGS += -DTRANS -DMSG_STYLE -DINTERNAL_KYUREKI_TBL -D_T_SEARCH_DEFPATHS=\"${PREFIX}/etc\" #-DUSE_TERMCAP
LDLIBS = -lm #-ltermcap
HFILES = cdefs.h chu68k.h cmsdos.h cunix.h cwin32.h extern.h
@@ -29,8 +29,8 @@ install: today calendar dayinfo
${BSD_INSTALL_DATA} today.cnf ${PREFIX}/etc
mkdir -p ${PREFIX}/share/today
${BSD_INSTALL_DATA} *.tbl ${PREFIX}/share/today
- mkdir -p ${PREFIX}/share/doc/ja/today
- ${BSD_INSTALL_DATA} today.doc ${PREFIX}/share/doc/ja/today
+# mkdir -p ${PREFIX}/share/doc/ja/today
+# ${BSD_INSTALL_DATA} today.doc ${PREFIX}/share/doc/ja/today
calendar: $(OBJS_CAL)
$(CC) $(OBJS_CAL) $(LDLIBS) -o $@
diff --git a/japanese/today/files/patch-ai b/japanese/today/files/patch-ai
index 617278792b7c..7e66b07ebe87 100644
--- a/japanese/today/files/patch-ai
+++ b/japanese/today/files/patch-ai
@@ -1,6 +1,6 @@
---- today.cnf.orig Sun Mar 14 00:00:00 1999
-+++ today.cnf Sun Feb 13 15:59:51 2000
-@@ -182,10 +182,10 @@
+--- today.cnf.orig 2011-04-16 21:23:23.000000000 +0900
++++ today.cnf 2011-04-16 21:25:05.000000000 +0900
+@@ -200,10 +200,10 @@
#
pager = # 外部ページャーの指定
# 指定しなければ、内蔵ページャー使用
@@ -12,13 +12,13 @@
+pause_last = no # 内蔵ページャー 表示終了後一時停止制御
# yes 一時停止
# *no 停止しない
- outputfile = %c%y%m%d.tdy # 出力ファイル名 (筑湊拂:%c%y%m%d.tdy/%p.tdy)
-@@ -369,7 +369,7 @@
+ outputfile = %c%y%m%d.tdy # 出力ファイル名 (デフォルト:%c%y%m%d.tdy/%p.tdy)
+@@ -404,7 +404,7 @@
#
$common # 以降 共通環境定義部
--#table_path = c:/bin/tbl # 各テーブルの検索パス名
-+table_path = %%PREFIX%%/share/today # 各テーブルの検索パス名
+-table_path = %ExecCmdPath%/tbl # 各テーブルの検索パス名
++table_path = %%DATADIR%% # 各テーブルの検索パス名
# ';' で区切り複数指定可能
- # 未定義の場合、環境変数 TODAYTBL の場所
-
+ # 未定義の場合、環境変数 TODAYTBL の場
+ #
diff --git a/japanese/today/files/patch-al b/japanese/today/files/patch-al
index 873186378f58..8bf40f51857a 100644
--- a/japanese/today/files/patch-al
+++ b/japanese/today/files/patch-al
@@ -1,22 +1,21 @@
---- cunix.h.orig Tue Feb 15 03:17:23 2000
-+++ cunix.h Sun Feb 13 16:38:34 2000
-@@ -38,7 +38,9 @@
- #define _T_FPBUFSIZE (64 * 1024) /* fopen バッファ長 */
- #define _T_TMPENV "temp" /* temporary 環境変数名 */
- #define _T_TMPDIR "/tmp" /* temporary directory */
--#define _T_SEARCH_CMDPATH "/usr/local/lib:/usr/lib"
-+#ifndef _T_SEARCH_CMDPATH
-+#define _T_SEARCH_CMDPATH "/usr/local/etc"
+--- cunix.h.orig 2011-04-16 21:25:44.000000000 +0900
++++ cunix.h 2011-04-16 21:27:40.000000000 +0900
+@@ -40,7 +40,9 @@
+ #define _T_TMPENV "TEMP" /* temporary 環境変数名 */
+ #define _T_TMPENV2 "TMPDIR" /* temporary 環境変数名 */
+ #define _T_TMPDIR "/tmp" /* temporary directory */
++#if 0
+ #define _T_SEARCH_DEFPATHS "/usr/local/lib/today:/opt/local/lib/today:/usr/local/share/today:/opt/local/share/today:/usr/lib/today:/opt/lib/today:/usr/share/today:/opt/share/today:/usr/local/lib:/opt/local/lib:/usr/lib:/opt/lib"
+#endif
- #define _T_HOMEENV "HOME" /* home 環境変数 */
- #define _T_PATHSEPARATOR ":" /* path list separator char */
- #define _T_PATHSEP_CHR ':' /* path list separator char */
-@@ -53,7 +55,7 @@
+ /* default search path list */
+ #define _T_HOMEENV "HOME" /* home 環境変数 */
+ #define _T_PATHENV "PATH" /* path 環境変数名 */
+@@ -60,7 +62,7 @@
#define _T_OUTFILE_DEFAULT "%c%y%m%d.today"
#define _T_OUTFILE_TMPNAME "%p.today"
-#if defined(linux)
+#if defined(linux) || defined(__FreeBSD__)
- #define _T_ACCESS_ROK R_OK
- #define strnicmp strncasecmp
- #else
+ #define _T_ACCESS_ROK R_OK
+ #define _T_HAVE_STRTOK_R
+ #define stricmp(a,b) strcasecmp(a,b)
diff --git a/japanese/today/pkg-descr b/japanese/today/pkg-descr
index 3458b676f30e..c90c046f2bda 100644
--- a/japanese/today/pkg-descr
+++ b/japanese/today/pkg-descr
@@ -7,3 +7,5 @@ This port "today" tells you what day today is.
Of course, it may not know about all the important dates. Also, it
will also display your birthday, assuming you registered it. This
version also has a simple scheduler.
+
+WWW: http://www.vector.co.jp/soft/dos/personal/se002657.html
diff --git a/japanese/today/pkg-plist b/japanese/today/pkg-plist
index d88cc157fc50..0386d8b3d02d 100644
--- a/japanese/today/pkg-plist
+++ b/japanese/today/pkg-plist
@@ -2,42 +2,42 @@ bin/today
bin/calendar-today
bin/dayinfo
etc/today.cnf
-share/doc/ja/today/today.doc
-share/today/birthday.tbl
-share/today/event01.tbl
-share/today/event02.tbl
-share/today/event03.tbl
-share/today/event04.tbl
-share/today/event05.tbl
-share/today/event06.tbl
-share/today/event07.tbl
-share/today/event08.tbl
-share/today/event09.tbl
-share/today/event10.tbl
-share/today/event11.tbl
-share/today/event12.tbl
-share/today/flower.tbl
-share/today/gengo.tbl
-share/today/hist01.tbl
-share/today/hist02.tbl
-share/today/hist03.tbl
-share/today/hist04.tbl
-share/today/hist05.tbl
-share/today/hist06.tbl
-share/today/hist07.tbl
-share/today/hist08.tbl
-share/today/hist09.tbl
-share/today/hist10.tbl
-share/today/hist11.tbl
-share/today/hist12.tbl
-share/today/history.tbl
-share/today/holiday.tbl
-share/today/kyureki.tbl
-share/today/magazine.tbl
-share/today/monthly.tbl
-share/today/schedule.tbl
-share/today/sekki.tbl
-share/today/suffix.tbl
-share/today/week.tbl
-@dirrm share/today
-@dirrm share/doc/ja/today
+%%PORTDOCS%%%%DOCSDIR%%/today.doc
+%%DATADIR%%/birthday.tbl
+%%DATADIR%%/event01.tbl
+%%DATADIR%%/event02.tbl
+%%DATADIR%%/event03.tbl
+%%DATADIR%%/event04.tbl
+%%DATADIR%%/event05.tbl
+%%DATADIR%%/event06.tbl
+%%DATADIR%%/event07.tbl
+%%DATADIR%%/event08.tbl
+%%DATADIR%%/event09.tbl
+%%DATADIR%%/event10.tbl
+%%DATADIR%%/event11.tbl
+%%DATADIR%%/event12.tbl
+%%DATADIR%%/flower.tbl
+%%DATADIR%%/gengo.tbl
+%%DATADIR%%/hist01.tbl
+%%DATADIR%%/hist02.tbl
+%%DATADIR%%/hist03.tbl
+%%DATADIR%%/hist04.tbl
+%%DATADIR%%/hist05.tbl
+%%DATADIR%%/hist06.tbl
+%%DATADIR%%/hist07.tbl
+%%DATADIR%%/hist08.tbl
+%%DATADIR%%/hist09.tbl
+%%DATADIR%%/hist10.tbl
+%%DATADIR%%/hist11.tbl
+%%DATADIR%%/hist12.tbl
+%%DATADIR%%/history.tbl
+%%DATADIR%%/holiday.tbl
+%%DATADIR%%/kyureki.tbl
+%%DATADIR%%/magazine.tbl
+%%DATADIR%%/monthly.tbl
+%%DATADIR%%/schedule.tbl
+%%DATADIR%%/sekki.tbl
+%%DATADIR%%/suffix.tbl
+%%DATADIR%%/week.tbl
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%