aboutsummaryrefslogtreecommitdiff
path: root/japanese/tomoe
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2007-01-20 15:30:54 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2007-01-20 15:30:54 +0000
commit2b004552012c4d8d36cb0a0c0ea38426d7bf2b75 (patch)
treefe8d80be820bb27aaea4a405493817854cc6da87 /japanese/tomoe
parentf74b96e30381cf65c574a914a5290bdaf4118e1f (diff)
downloadports-2b004552012c4d8d36cb0a0c0ea38426d7bf2b75.tar.gz
ports-2b004552012c4d8d36cb0a0c0ea38426d7bf2b75.zip
Try to fix build on sparc64 by disabling Unihan support.
Reported by: pointyhat via kris
Notes
Notes: svn path=/head/; revision=182862
Diffstat (limited to 'japanese/tomoe')
-rw-r--r--japanese/tomoe/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/japanese/tomoe/Makefile b/japanese/tomoe/Makefile
index 43d3c3c5a205..466d2a0561e0 100644
--- a/japanese/tomoe/Makefile
+++ b/japanese/tomoe/Makefile
@@ -25,10 +25,18 @@ USE_RUBY= yes
BUILD_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
+# We cannot use ${ARCH} nor ${UNAME} which are defined in bsd.port.mk, here.
+UNAME= /usr/bin/uname
+ARCH!= ${UNAME} -p
+
OPTIONS=DICT_RUBY "Enable Ruby based dictionary module" off \
EST "Enable Hyper Estraier dictionary module" off \
- MYSQL "Enable MySQL dictionary module" off \
- UNIHAN "Enable Unihan database dictionary module" on
+ MYSQL "Enable MySQL dictionary module" off
+.if ${ARCH} == "sparc64"
+OPTIONS+=UNIHAN "Enable Unihan database dictionary module" off
+.else
+OPTIONS+=UNIHAN "Enable Unihan database dictionary module" on
+.endif
.include <bsd.port.pre.mk>
@@ -55,6 +63,9 @@ PLIST_SUB+= MYSQL="@comment "
.endif
.if defined(WITH_UNIHAN)
+.if ${ARCH} == "sparc64"
+BROKEN= Not buildable with Unihan on sparc64
+.endif
MASTER_SITES+= ftp://ftp.unicode.org/Public/UNIDATA/:unihan
DISTFILES+= Unihan.zip:unihan
EXTRACT_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip