aboutsummaryrefslogtreecommitdiff
path: root/japanese/tomoe
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2013-10-12 20:10:42 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2013-10-12 20:10:42 +0000
commit53b6aaa1c3bb0bf07cc2c3158d53f349fb3a17ad (patch)
tree4f47f51c07d0c9f44982912dd87db4e893d8e001 /japanese/tomoe
parent524135b36a3bc6e8660f3b997cffd4f19ddeae3e (diff)
downloadports-53b6aaa1c3bb0bf07cc2c3158d53f349fb3a17ad.tar.gz
ports-53b6aaa1c3bb0bf07cc2c3158d53f349fb3a17ad.zip
- enable stage.
- use modern OPTIONS helper.
Notes
Notes: svn path=/head/; revision=330183
Diffstat (limited to 'japanese/tomoe')
-rw-r--r--japanese/tomoe/Makefile33
1 files changed, 6 insertions, 27 deletions
diff --git a/japanese/tomoe/Makefile b/japanese/tomoe/Makefile
index 975f68d696c7..270aabee5a3d 100644
--- a/japanese/tomoe/Makefile
+++ b/japanese/tomoe/Makefile
@@ -43,45 +43,28 @@ OPTIONS_DEFAULT= PYTHON
.if ${ARCH} != "sparc64" && ${OSVERSION} < 700042
OPTIONS_DEFAULT+= UNIHAN
.endif
+OPTIONS_SUB= yes
DICT_RUBY_DESC= Enable Ruby based dictionary module
+DICT_RUBY_CONFIGURE_ENABLE= dict-ruby
EST_DESC= Enable Hyper Estraier dictionary module
+EST_CONFIGURE_WITH= est
MYSQL_DESC= Enable MySQL dictionary module
+MYSQL_CONFIGURE_WITH= mysql
PYTHON_DESC= Enable Python module
+PYTHON_CONFIGURE_OFF= --with-python=no
UNIHAN_DESC= Enable Unihan database dictionary module
+UNIHAN_CONFIGURE_ENABLE= unihan
-NO_STAGE= yes
.include <bsd.port.pre.mk>
-.if ${PORT_OPTIONS:MDICT_RUBY}
-CONFIGURE_ARGS+=--enable-dict-ruby
-PLIST_SUB+= DICT_RUBY=""
-.else
-PLIST_SUB+= DICT_RUBY="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MEST}
-CONFIGURE_ARGS+=--with-est
-PLIST_SUB+= EST=""
-.else
-PLIST_SUB+= EST="@comment "
-.endif
-
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
-CONFIGURE_ARGS+=--with-mysql
-PLIST_SUB+= MYSQL=""
-.else
-PLIST_SUB+= MYSQL="@comment "
.endif
.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= yes
.include "${PORTSDIR}/Mk/bsd.python.mk"
USE_GNOME+= pygtk2
-PLIST_SUB+= PYTHON=""
-.else
-CONFIGURE_ARGS+=--with-python=no
-PLIST_SUB+= PYTHON="@comment "
.endif
.if ${PORT_OPTIONS:MUNIHAN}
@@ -97,10 +80,6 @@ EXTRACT_DEPENDS+= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
BUILD_DEPENDS+= \
${RUBY_SITEARCHLIBDIR}/uconv.so:${PORTSDIR}/japanese/ruby-uconv \
${RUBY_SITELIBDIR}/suikyo/suikyo.rb:${PORTSDIR}/japanese/suikyo
-PLIST_SUB+= UNIHAN=""
-.else
-CONFIGURE_ARGS+=--disable-unihan
-PLIST_SUB+= UNIHAN="@comment "
.endif
CONFIGURE_ENV+= PYTHON_VERSION=${PYTHON_VERSION:S;python;;} \