aboutsummaryrefslogtreecommitdiff
path: root/japanese/uim-anthy
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-07-10 02:06:29 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-07-10 02:06:29 +0000
commita25a39a9fa1e9c7ea07a08578930e3216a0f0b4d (patch)
tree554415409e51a32cce7a8ae6bfe0528b7e3163ed /japanese/uim-anthy
parent5301980440194d119d187371ae8a73c50e18b9b3 (diff)
downloadports-a25a39a9fa1e9c7ea07a08578930e3216a0f0b4d.tar.gz
ports-a25a39a9fa1e9c7ea07a08578930e3216a0f0b4d.zip
Add WITHOUT_X11 knob.
Notes
Notes: svn path=/head/; revision=167319
Diffstat (limited to 'japanese/uim-anthy')
-rw-r--r--japanese/uim-anthy/Makefile20
-rw-r--r--japanese/uim-anthy/pkg-plist2
2 files changed, 20 insertions, 2 deletions
diff --git a/japanese/uim-anthy/Makefile b/japanese/uim-anthy/Makefile
index 051f4c12f299..1fac63003bac 100644
--- a/japanese/uim-anthy/Makefile
+++ b/japanese/uim-anthy/Makefile
@@ -6,18 +6,28 @@
#
CATEGORIES= japanese
+.if defined(WITHOUT_X11)
+PKGNAMESUFFIX= -anthy-nox11
+.else
PKGNAMESUFFIX= -anthy
+.endif
COMMENT= Uim plugin using Anthy input method
+.if !defined(WITHOUT_X11)
USE_GNOME= gtk20
+.endif
LIB_DEPENDS= anthy.1:${PORTSDIR}/japanese/anthy \
uim.2:${PORTSDIR}/textproc/uim
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
-CONFIGURE_ARGS= --with-anthy --with-gtk2 --enable-dict
+CONFIGURE_ARGS= --with-anthy
+
+.if !defined(WITHOUT_X11)
+CONFIGURE_ARGS+= --with-gtk2 -enable-dict
+.endif
UIM_SLAVE= yes
@@ -26,14 +36,22 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-uim_Makefile.in \
do-build:
(cd ${WRKSRC}/uim && ${GMAKE} libuim-anthy.la)
+.if !defined(WITHOUT_X11)
(cd ${WRKSRC}/helper && ${GMAKE} LIBS="-luim" uim-dict-gtk)
+.endif
do-install:
(cd ${WRKSRC}/uim && \
${GMAKE} uim_plugin_LTLIBRARIES=libuim-anthy.la install-uim_pluginLTLIBRARIES)
+.if !defined(WITHOUT_X11)
(cd ${WRKSRC}/helper && ${GMAKE} bin_PROGRAMS=uim-dict-gtk install-binPROGRAMS)
+.endif
post-install:
+.if defined(WITHOUT_X11)
+ ${LOCALBASE}/bin/uim-module-manager --register anthy
+.else
${X11BASE}/bin/uim-module-manager --register anthy
+.endif
.include "${MASTERDIR}/Makefile"
diff --git a/japanese/uim-anthy/pkg-plist b/japanese/uim-anthy/pkg-plist
index c84f90800556..1cd2cccad83a 100644
--- a/japanese/uim-anthy/pkg-plist
+++ b/japanese/uim-anthy/pkg-plist
@@ -1,4 +1,4 @@
-bin/uim-dict-gtk
+%%X11%%bin/uim-dict-gtk
lib/uim/plugin/libuim-anthy.a
lib/uim/plugin/libuim-anthy.la
lib/uim/plugin/libuim-anthy.so