aboutsummaryrefslogtreecommitdiff
path: root/japanese/wordpress/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2011-10-16 05:24:10 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2011-10-16 05:24:10 +0000
commit17ae7067acfe2363c6ce8194dd95e08e06dd6692 (patch)
treea5504211752b3f7b254686a0b28daf723c01c878 /japanese/wordpress/Makefile
parentecb09b40d4187a2989a824e1609d9b73c8cf23b8 (diff)
downloadports-17ae7067acfe2363c6ce8194dd95e08e06dd6692.tar.gz
ports-17ae7067acfe2363c6ce8194dd95e08e06dd6692.zip
Notes
Diffstat (limited to 'japanese/wordpress/Makefile')
-rw-r--r--japanese/wordpress/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/japanese/wordpress/Makefile b/japanese/wordpress/Makefile
new file mode 100644
index 000000000000..0853542b5817
--- /dev/null
+++ b/japanese/wordpress/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: wordpress
+# Date created: 2011-09-20
+# Whom: Takefu
+#
+# $FreeBSD$
+#
+
+PORTNAME= wordpress
+PORTVERSION= 3.2.1
+CATEGORIES= japanese www
+MASTER_SITES= http://ja.wordpress.org/
+PKGNAMESUFFIX= -ja
+DISTNAME= ${PORTNAME}-${PORTVERSION}${PKGNAMESUFFIX}
+
+MAINTAINER= takefu@airport.fm
+COMMENT= A state-of-the-art semantic personal publishing platform
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+CONFLICTS_INSTALL= wordpress-3.* de-wordpress-de-3.*
+
+NO_BUILD= yes
+USE_PHP= gd mysql pcre tokenizer xml zip
+WANT_PHP_WEB= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+SUB_FILES= pkg-message
+PLIST= ${WRKDIR}/pkg-plist
+PORTDOCS= license.txt readme.html
+
+pre-everything::
+ @${ECHO_CMD} "If you want to upgrade, you must read upgrade document."
+ @${ECHO_CMD} ""
+ @sleep 1
+
+pre-install:
+ cd ${WRKSRC}/ && \
+ (${FIND} -s * -type f | ${SED} -e 's|^|%%WWWDIR%%/|'; \
+ ${FIND} -d . -type d | ${SED} -e 's|^\.|@dirrm %%WWWDIR%%|') > ${PLIST}
+ if [ ! -f ${WRKSRC}/wp-config-sample.php ]; then ${CP} \
+ ${WRKSRC}/wp-config.php.sample ${WRKSRC}/wp-config.php; fi
+
+do-install:
+ ${INSTALL} -d -g ${WWWGRP} -m 755 -o ${WWWOWN} ${WWWDIR}/
+ ${CP} -R ${WRKSRC}/ ${WWWDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>