aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2014-06-28 13:42:04 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2014-06-28 13:42:04 +0000
commit2eb4172d38b254baa6505a3e8df92b1b56af8ba9 (patch)
tree38895cebb9ffa2c89fc30f88853c12bedca91754 /japanese
parent990d366814f323c1b726d3320a88d8855a23f976 (diff)
downloadports-2eb4172d38b254baa6505a3e8df92b1b56af8ba9.tar.gz
ports-2eb4172d38b254baa6505a3e8df92b1b56af8ba9.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/jmode-skk/Makefile5
-rw-r--r--japanese/jmode/Makefile9
-rw-r--r--japanese/jmode/files/patch-src_dispatch.cpp10
-rw-r--r--japanese/jmode/files/patch-src_keyatom.cpp10
-rw-r--r--japanese/jmode/files/patch-src_kkconv.cpp10
-rw-r--r--japanese/jmode/files/patch-src_ximim.cpp10
-rw-r--r--japanese/jmode/files/patch-src_ximpacket.cpp10
-rw-r--r--japanese/jmode/files/patch-src_ximtrans.cpp10
-rw-r--r--japanese/jmode/pkg-plist6
9 files changed, 72 insertions, 8 deletions
diff --git a/japanese/jmode-skk/Makefile b/japanese/jmode-skk/Makefile
index 9fc7cb3ceb19..b8c87ef620b1 100644
--- a/japanese/jmode-skk/Makefile
+++ b/japanese/jmode-skk/Makefile
@@ -6,10 +6,12 @@ PKGNAMESUFFIX= -skk
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= XIM server for SKK input method
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
MASTERDIR= ${.CURDIR}/../../japanese/jmode
DESCR= ${.CURDIR}/pkg-descr
-LIB_DEPENDS= # empty
.if defined(WITH_DBSKKD) || exists(${LOCALBASE}/libexec/dbskkd-cdb)
RUN_DEPENDS= ${LOCALBASE}/libexec/dbskkd-cdb:${PORTSDIR}/japanese/dbskkd-cdb
.else
@@ -18,5 +20,4 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/skkserv:${PORTSDIR}/japanese/skkserv
CONFIGURE_ARGS= --with-skk
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/japanese/jmode/Makefile b/japanese/jmode/Makefile
index 075dcb24a026..022eaeee22ef 100644
--- a/japanese/jmode/Makefile
+++ b/japanese/jmode/Makefile
@@ -5,19 +5,22 @@ PORTNAME= jmode
PORTVERSION= 0.6.7
PORTREVISION= 7
CATEGORIES= japanese
-MASTER_SITES= http://downloads.sourceforge.jp/anthy/5467/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
+MASTER_SITE_SUBDIR= anthy/5467
MAINTAINER= nobutaka@FreeBSD.org
COMMENT?= XIM server for Anthy input method
-LIB_DEPENDS?= anthy.1:${PORTSDIR}/japanese/anthy
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libanthy.so:${PORTSDIR}/japanese/anthy
USE_GNOME= gtk12
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
diff --git a/japanese/jmode/files/patch-src_dispatch.cpp b/japanese/jmode/files/patch-src_dispatch.cpp
new file mode 100644
index 000000000000..7e7a246fb640
--- /dev/null
+++ b/japanese/jmode/files/patch-src_dispatch.cpp
@@ -0,0 +1,10 @@
+--- src/dispatch.cpp.orig 2014-06-28 22:10:26.000000000 +0900
++++ src/dispatch.cpp 2014-06-28 22:10:45.000000000 +0900
+@@ -16,6 +16,7 @@
+ #include <X11/Xatom.h>
+ #include <unistd.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <map>
+
+ #include "jmode.h"
diff --git a/japanese/jmode/files/patch-src_keyatom.cpp b/japanese/jmode/files/patch-src_keyatom.cpp
new file mode 100644
index 000000000000..5fec2467f0c6
--- /dev/null
+++ b/japanese/jmode/files/patch-src_keyatom.cpp
@@ -0,0 +1,10 @@
+--- src/keyatom.cpp.orig 2014-06-28 22:19:00.000000000 +0900
++++ src/keyatom.cpp 2014-06-28 22:19:19.000000000 +0900
+@@ -9,6 +9,7 @@
+ # include <alloca.h>
+ # endif
+ #endif
++#include <stdlib.h>
+
+ #include "jmode.h"
+
diff --git a/japanese/jmode/files/patch-src_kkconv.cpp b/japanese/jmode/files/patch-src_kkconv.cpp
new file mode 100644
index 000000000000..25a7ad9c357b
--- /dev/null
+++ b/japanese/jmode/files/patch-src_kkconv.cpp
@@ -0,0 +1,10 @@
+--- src/kkconv.cpp.orig 2014-06-28 22:15:17.000000000 +0900
++++ src/kkconv.cpp 2014-06-28 22:15:38.000000000 +0900
+@@ -18,6 +18,7 @@
+ # include <alloca.h>
+ # endif
+ #endif
++#include <stdlib.h>
+
+ // キャラクタコード32から、
+ //このソースはEUCで書かれている。
diff --git a/japanese/jmode/files/patch-src_ximim.cpp b/japanese/jmode/files/patch-src_ximim.cpp
new file mode 100644
index 000000000000..513a3f1b4669
--- /dev/null
+++ b/japanese/jmode/files/patch-src_ximim.cpp
@@ -0,0 +1,10 @@
+--- src/ximim.cpp.orig 2014-06-28 22:13:59.000000000 +0900
++++ src/ximim.cpp 2014-06-28 22:14:31.000000000 +0900
+@@ -15,6 +15,7 @@
+ # include <alloca.h>
+ # endif
+ #endif
++#include <stdlib.h>
+
+ static std::map<int,XimIM *> g_ims;
+
diff --git a/japanese/jmode/files/patch-src_ximpacket.cpp b/japanese/jmode/files/patch-src_ximpacket.cpp
new file mode 100644
index 000000000000..917dc5fdc93a
--- /dev/null
+++ b/japanese/jmode/files/patch-src_ximpacket.cpp
@@ -0,0 +1,10 @@
+--- src/ximpacket.cpp.orig 2014-06-28 22:17:36.000000000 +0900
++++ src/ximpacket.cpp 2014-06-28 22:18:08.000000000 +0900
+@@ -3,6 +3,7 @@
+ #endif
+
+ #include <list>
++#include <stdlib.h>
+ #include "xim.h"
+
+ //
diff --git a/japanese/jmode/files/patch-src_ximtrans.cpp b/japanese/jmode/files/patch-src_ximtrans.cpp
new file mode 100644
index 000000000000..27b81582bcd6
--- /dev/null
+++ b/japanese/jmode/files/patch-src_ximtrans.cpp
@@ -0,0 +1,10 @@
+--- src/ximtrans.cpp.orig 2014-06-28 22:11:37.000000000 +0900
++++ src/ximtrans.cpp 2014-06-28 22:11:54.000000000 +0900
+@@ -6,6 +6,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "xim.h"
+
+ #ifndef __GNUC__
diff --git a/japanese/jmode/pkg-plist b/japanese/jmode/pkg-plist
index ae16139182db..114cb4b65a89 100644
--- a/japanese/jmode/pkg-plist
+++ b/japanese/jmode/pkg-plist
@@ -1,4 +1,4 @@
bin/jmode
-share/jmode/jmode-default.conf
-share/jmode/jmode-kana.conf
-@dirrm share/jmode
+%%DATADIR%%/jmode-default.conf
+%%DATADIR%%/jmode-kana.conf
+@dirrm %%DATADIR%%