aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2021-01-10 11:08:56 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2021-01-10 11:08:56 +0000
commit53cb7a89548cd2a903c9e5e862858fc6cef6cf80 (patch)
tree015c2841450c938f0b42334a6ae66dcd1d7b7364 /japanese
parent663bbc58975c7cda3d2e7ea68ba40555fd99e093 (diff)
downloadports-53cb7a89548cd2a903c9e5e862858fc6cef6cf80.tar.gz
ports-53cb7a89548cd2a903c9e5e862858fc6cef6cf80.zip
- Fix build error with Clang 11.
- Add undeclared dependencies. PR: 252535 Submitted by: Tomoyuki Sakurai <trombik1973@gmail.com>
Notes
Notes: svn path=/head/; revision=561053
Diffstat (limited to 'japanese')
-rw-r--r--japanese/scim-anthy/Makefile7
-rw-r--r--japanese/scim-anthy/files/patch-src_scim__anthy__prefs.cpp11
2 files changed, 16 insertions, 2 deletions
diff --git a/japanese/scim-anthy/Makefile b/japanese/scim-anthy/Makefile
index 3ec320efb793..ca6a78730da9 100644
--- a/japanese/scim-anthy/Makefile
+++ b/japanese/scim-anthy/Makefile
@@ -14,11 +14,14 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= scim:textproc/scim
-LIB_DEPENDS= libanthy.so:japanese/anthy
+LIB_DEPENDS= libanthy.so:japanese/anthy \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
RUN_DEPENDS:= ${BUILD_DEPENDS} \
kasumi:japanese/kasumi
-USES= gmake iconv libtool:keepla pkgconfig
+USES= gettext-runtime gmake iconv libtool:keepla pkgconfig
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/japanese/scim-anthy/files/patch-src_scim__anthy__prefs.cpp b/japanese/scim-anthy/files/patch-src_scim__anthy__prefs.cpp
index 54a3ceef657a..35114038ff07 100644
--- a/japanese/scim-anthy/files/patch-src_scim__anthy__prefs.cpp
+++ b/japanese/scim-anthy/files/patch-src_scim__anthy__prefs.cpp
@@ -46,6 +46,17 @@ scim_anthy_prefs.cpp:98:9: error: cannot initialize a member subobject of type '
false,
},
{
+@@ -215,8 +220,8 @@ BoolConfigData config_bool_common [] =
+ },
+ {
+ NULL,
+- "",
+- "",
++ (bool)"",
++ (bool)"",
+ NULL,
+ NULL,
+ NULL,
@@ -269,6 +274,7 @@ IntConfigData config_int_common [] =
0,
0,