aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2009-06-14 05:51:34 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2009-06-14 05:51:34 +0000
commita6280e21fb22a05fe17d8e61488100ad5bbc4496 (patch)
tree4ba5ca5f9ee2b4c7199c2a4c7bc21c598324b2bb /japanese
parenta10da7c86956f8fefb42e4dd4dc8b1b53276ee89 (diff)
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/citrix_xenapp/Makefile59
-rw-r--r--japanese/citrix_xenapp/distinfo6
-rw-r--r--japanese/citrix_xenapp/files/patch-linuxx86__hinst132
-rw-r--r--japanese/citrix_xenapp/files/patch-setupwfc6
-rw-r--r--japanese/citrix_xenapp/pkg-descr25
-rw-r--r--japanese/citrix_xenapp/pkg-plist84
7 files changed, 168 insertions, 145 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index f6b98459128b..ba12501f959c 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -33,6 +33,7 @@
SUBDIR += chasen-base
SUBDIR += chimera
SUBDIR += citrix_ica
+ SUBDIR += citrix_xenapp
SUBDIR += csrd
SUBDIR += ctags
SUBDIR += dbskkd-cdb
diff --git a/japanese/citrix_xenapp/Makefile b/japanese/citrix_xenapp/Makefile
index 96f2b7c7037d..ee7970309456 100644
--- a/japanese/citrix_xenapp/Makefile
+++ b/japanese/citrix_xenapp/Makefile
@@ -5,43 +5,37 @@
# $FreeBSD$
#
-PORTNAME= citrix_ica
-PORTVERSION= 10.6
+PORTNAME= citrix_xenapp
+PORTVERSION= 11.0.140395
CATEGORIES= japanese net comms linux
MASTER_SITES=
-DISTNAME= ${PORTNAME}-linuxx86-ja-${PORTVERSION}
+DISTNAME= ${PORTNAME}-linuxx86-${PORTVERSION}
MAINTAINER= tabthorpe@FreeBSD.org
-COMMENT= Citrix(R) Presentation Server(TM) client
+COMMENT= Access virtual applications and desktops
ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= yes
-USE_LINUX_APPS= openmotif
+USE_LINUX= f8
+USE_LINUX_APPS= openmotif jpeg png
RESTRICTED= License prohibits redistribution
IS_INTERACTIVE= "Noisy license agreement ignores stdin"
-NO_WRKSUBDIR= Yes
-NO_BUILD= Yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
CDIR= ${PREFIX}/ICAClient
BINDIR= ${PREFIX}/bin
-
-NSCP= ${LOCALBASE}/libexec/netscape \
- ${LOCALBASE}/libexec/netscape-linux \
- ${LOCALBASE}/netscape \
- ${LOCALBASE}/netscape-linux \
- ${LOCALBASE}/lib/netscape \
- ${LOCALBASE}/lib/netscape-linux \
- ${MOZILLA_HOME}
+CERTDIR= ${CDIR}/keystore/cacerts
PLIST_SUB= MOZILLA_HOME=${MOZILLA_HOME}
+.if defined(ICA_CERTS)
+PLIST_SUB+= HAVE_ICA_CERTS="" ICA_CERTS="${ICA_CERTS}" CERTDIR="${CERTDIR}"
+.else
+PLIST_SUB+= HAVE_ICA_CERTS="@comment "
+.endif
.include <bsd.port.pre.mk>
-.if exists(${PREFIX}/bin/kde-config)
-HAVE_KDE= "\\ny"
-.endif
-
.if defined(BATCH) || defined(PACKAGE_BUILDING)
IGNORE='The distribution file for this port may not be automatically fetched due to licensing restrictions.'
.endif
@@ -51,14 +45,28 @@ do-fetch:
@${ECHO} ""
@${ECHO} "You have to fetch the file manually from"
@${ECHO} ""
- @${ECHO} "http://www.citrix.com/site/SS/downloads/details.asp?dID=2755&downloadID=3323"
+ @${ECHO} "http://www.citrix.com/English/SS/downloads/details.asp?downloadID=3323"
@${ECHO} ""
- @${ECHO} "Once ja.linuxx86.tar.gz has been downloaded move it to"
+ @${ECHO} "Once en.linuxx86.tar.gz has been downloaded move it to"
@${ECHO} "${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} and restart the build."
@${ECHO} ""
@${FALSE}
.endif
+.if defined(ICA_CERTS)
+pre-fetch:
+.for f in ${ICA_CERTS}
+ @echo "Checking ${f}"
+.if !exists(${DISTDIR}/${f})
+ @echo "Cert ${f} not found."
+ @exit 1
+.endif
+.endfor
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|DefaultInstallDir=/usr/lib/ICAClient|DefaultInstallDir=${PREFIX}/ICAClient|' ${WRKSRC}/linuxx86/hinst
+
do-install:
@if (test -d "${CDIR}") ; \
then \
@@ -77,6 +85,13 @@ do-install:
cd ${WRKSRC} && ${SH} -c './setupwfc'
${INSTALL_SCRIPT} ${WRKSRC}/wfcmgr.x ${PREFIX}/bin/wfcmgr
${INSTALL_SCRIPT} ${WRKSRC}/wfica.x ${PREFIX}/bin/wfica
+ ${MKDIR} ${LINUXBASE}/dev
# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
+.if defined(ICA_CERTS)
+.for f in ${ICA_CERTS}
+ ${INSTALL_DATA} ${DISTDIR}/${f} ${CERTDIR}
+.endfor
+.endif
+
.include <bsd.port.post.mk>
diff --git a/japanese/citrix_xenapp/distinfo b/japanese/citrix_xenapp/distinfo
index 9d0256424947..542a6ae77578 100644
--- a/japanese/citrix_xenapp/distinfo
+++ b/japanese/citrix_xenapp/distinfo
@@ -1,3 +1,3 @@
-MD5 (citrix_ica-linuxx86-ja-10.6.tar.gz) = abd7afd1f873879b28fdce76808f2040
-SHA256 (citrix_ica-linuxx86-ja-10.6.tar.gz) = cd342e7ae4037ae8bfe7f11c799b7e1ef56b1d23296561c40ea9e8d40e85050e
-SIZE (citrix_ica-linuxx86-ja-10.6.tar.gz) = 1890133
+MD5 (citrix_xenapp-linuxx86-11.0.140395.tar.gz) = 474182de909ebae07adc6f6ff35428d8
+SHA256 (citrix_xenapp-linuxx86-11.0.140395.tar.gz) = 641bf68e78b07768566207f7a7f7c4cc1345d5c08d875dafb133f7b5dd5a7301
+SIZE (citrix_xenapp-linuxx86-11.0.140395.tar.gz) = 2220688
diff --git a/japanese/citrix_xenapp/files/patch-linuxx86__hinst b/japanese/citrix_xenapp/files/patch-linuxx86__hinst
index 7681325b0ba4..43150b94d2e7 100644
--- a/japanese/citrix_xenapp/files/patch-linuxx86__hinst
+++ b/japanese/citrix_xenapp/files/patch-linuxx86__hinst
@@ -1,40 +1,39 @@
---- linuxx86/hinst.orig Thu Nov 2 08:55:48 2006
-+++ linuxx86/hinst Wed Apr 25 10:25:45 2007
-@@ -86,7 +86,7 @@
- fi
-
- # Install in here by default.
--DefaultInstallDir=/usr/lib/ICAClient
-+DefaultInstallDir=/usr/local/ICAClient
-
- # Default CDROM mount point
- DefaultCDSourceDir=/cdrom
-@@ -2221,7 +2221,7 @@
+--- linuxx86/hinst.orig 2009-02-26 04:22:26.000000000 -0500
++++ linuxx86/hinst 2009-06-14 00:56:20.000000000 -0400
+@@ -256,11 +256,9 @@
+ then
+ echo LANG=$LANG
+ fi
+- if [ -z "$LANG" ]
+- then
+- LANG="en"
+- # echo LANG missing, using en
+- fi
++
++ LANG="ja"
++
+ Lang=`echo $LANG | sed -n -e 's/[_\.].*//' -e 'p'`
+ Territory=`echo $LANG | sed -n -e 's/\(.*\)\..*/\1/' -e 's/.*_\(.*\)/\1/p'`
+ CodeSet=`echo $LANG | sed -n -e 's/.*\.\(.*\)/\1/p'`
+@@ -1965,7 +1963,7 @@
then
:
else
- /bin/false
-+ /usr/bin/false
++ false
return
fi
-@@ -2267,7 +2267,7 @@
+@@ -2090,7 +2088,7 @@
fi
fi
- /bin/true
-+ /usr/bin/true
++ true
}
- ###############################################################################
-@@ -2390,26 +2390,18 @@
-
- netscape_integrate()
- {
-- user_echo $integrate_netscape1
- if test -z "$SU_INSTALL"
- then
- set_npui_variables
+ #!/bin/sh
+@@ -2191,19 +2189,12 @@
found_netscape
else
search_ok=0
@@ -53,86 +52,19 @@
user_echo $integrate_netscape3
found_netscape
- else
-+ ;;
++ ;;
+ *)
- user_prompt $integrate_netscape2
+ user_prompt "$integrate_netscape2"
getyesno $INSTALLER_NO
if [ "$ANSWER" = "$INSTALLER_YES" ]
-@@ -2418,7 +2410,8 @@
+@@ -2212,8 +2203,9 @@
else
user_echo $integrate_netscape6
fi
-- fi
-+ ;;
-+ esac
- fi
-
- # Create utility script files in install root.
-@@ -3056,55 +3049,6 @@
- echo "$BINDIR"
- }
++ ;;
++ esac
+ fi
+- fi
--################################################################################
--#
--# find_browsers
--#
--# Returns a list of directories containing new-style mozilla-based browsers
--# that may be launched by files on the $PATH.
--#
--################################################################################
--find_browsers()
--{
-- PROGS="netscape mozilla firefox"
-- DIST_BIN_DIR=""
-- STANDARD_DIRS="/usr/local/netscape /usr/local/mozilla /usr/local/firefox /usr/lib/mozilla"
--
-- case $op_system in
-- SunOS) if
-- /usr/bin/pkginfo -q $SOLARIS_PACKAGE_NAME
-- then
-- relocation_base=`/usr/bin/pkginfo -r $SOLARIS_PACKAGE_NAME`
-- STANDARD_DIRS="$STANDARD_DIRS $relocation_base/$SOLARIS_PACKAGE_DIRECTORY"
--
-- # N.B. the Netscape 7 packages for SOLARIS 9 have an extended installation path built-in!
-- case `uname -r` in
-- 5.9) STANDARD_DIRS="$STANDARD_DIRS $relocation_base/dt/appconfig/$SOLARIS_PACKAGE_DIRECTORY"
-- ;;
-- *) ;;
-- esac
-- fi;;
-- *) ;;
-- esac
--
-- for d in `echo $PATH | sed "s/:/ /g"` $STANDARD_DIRS
-- do
-- echo $d
-- done | sort -u | while read d
-- do
-- for p in $PROGS
-- do
-- # Find the each instance of each named browser
-- PROG=$d/$p
-- if test -f $PROG
-- then
-- # Where is the installation and what version is it?
-- find_extra_bin_dirs $PROG
-- fi
-- done
-- done | sort -u
--}
--
- BROWSER_LIST_KEY="BROWSER_DIR"
- ################################################################################
- #
-@@ -3330,7 +3274,10 @@
- XDG_TARGET_DIR="/usr/share/applications"
- TL_MENU_DIR="Vendor_menus/Applications" # TurboLinux
- TL_TOP_DIR="/usr/share/applnk/"$TL_MENU_DIR
--DEFAULT_GNOME_TARGET_DIRS="/etc/opt/gnome/SuSE/Internet"
-+EFAULT_GNOME_TARGET_DIRS="/usr/share/applications \
-+ /usr/local/share/applnk/Internet \
-+ /usr/local/share/applnk/Networking \
-+ /etc/opt/gnome/SuSE/Internet"
- DEFAULT_KDE_TARGET_DIRS="/usr/share/applnk-redhat/Internet \
- /usr/share/applnk-mdk/Networking \
- $TL_TOP_DIR/Internet \
+ # Create utility script files in install root.
+ create_wfica_script
diff --git a/japanese/citrix_xenapp/files/patch-setupwfc b/japanese/citrix_xenapp/files/patch-setupwfc
index 02970987b83e..9b09f664e4b2 100644
--- a/japanese/citrix_xenapp/files/patch-setupwfc
+++ b/japanese/citrix_xenapp/files/patch-setupwfc
@@ -1,6 +1,6 @@
---- setupwfc.orig Tue Oct 31 07:48:46 2006
-+++ setupwfc Wed Apr 25 10:33:49 2007
-@@ -442,7 +442,7 @@
+--- setupwfc.orig Fri Apr 8 13:52:46 2005
++++ setupwfc Mon Jan 22 10:10:48 2007
+@@ -396,7 +396,7 @@
*BSD)
# Assume Free/Net/Open BSD on an X86 with Linux emulation.
diff --git a/japanese/citrix_xenapp/pkg-descr b/japanese/citrix_xenapp/pkg-descr
index 69deced9f262..dd930efc5d96 100644
--- a/japanese/citrix_xenapp/pkg-descr
+++ b/japanese/citrix_xenapp/pkg-descr
@@ -1,13 +1,16 @@
-Citrix(R) Presentation Server(TM) runs on Microsoft(R) Windows
-Server(TM) and UNIX(R) operating systems, and extends the base
-Windows Terminal Services platform by enhancing the end-user
-experience as well as increasing manageability, compatibility,
-security and scalability to address business-critical environments.
-Presentation Server expands the range of supported applications to
-include legacy software and Web-based, UNIX and Java solutions. It
-also enables any device or operating system including Macintosh and
-Linux to access virtualized applications. Other important capabilities
-are powerful management and configuration tools and faster, more
-flexible printing.
+Citrix XenApp (TM) is a Windows (R) application delivery system that manages
+applications in the datacenter and delivers them as an on-demand
+service to users anywhere using any device. XenApp reduces the cost
+of application management by up to 50 percent, delivers any application
+instantly to users anywhere and improves application and data
+security.
+
+you can copy the certificate to /usr/ports/distfiles and add the
+following line to your /etc/make.conf:
+
+ ICA_CERTS=mycert.crt
+
+It will then automatically be installed and removed with the normal
+FreeBSD package tools.
WWW: http://www.citrix.com/English/ps2/products/product.asp?contentID=186
diff --git a/japanese/citrix_xenapp/pkg-plist b/japanese/citrix_xenapp/pkg-plist
index 5ac93e3f6204..c5c36f5f1c6d 100644
--- a/japanese/citrix_xenapp/pkg-plist
+++ b/japanese/citrix_xenapp/pkg-plist
@@ -1,3 +1,6 @@
+@unexec for dir in /usr/local/libexec/netscape /usr/local/libexec/netscape-linux /usr/local/netscape /usr/local/netscape-linux /usr/local/lib/netscape /usr/local/lib/netscape-linux %%MOZILLA_HOME%% %D/lib/netscape-linux; do if [ -f ${dir}/mime.types ]; then (/bin/cat ${dir}/mime.types | /usr/bin/grep -v "application/x-ica" > ${dir}/mime.types.tmp; mv ${dir}/mime.types.tmp ${dir}/mime.types); fi ; done
+@unexec for dir in /usr/local/libexec/netscape /usr/local/libexec/netscape-linux /usr/local/netscape /usr/local/netscape-linux /usr/local/lib/netscape /usr/local/lib/netscape-linux %%MOZILLA_HOME%% %D/lib/netscape-linux; do if [ -f ${dir}/mailcap ]; then (/bin/cat ${dir}/mailcap | /usr/bin/grep -v "application/x-ica" > ${dir}/mailcap.tmp; /bin/mv ${dir}/mailcap.tmp ${dir}/mailcap); fi ; done
+@unexec for dir in /usr/local/libexec/netscape /usr/local/libexec/netscape-linux /usr/local/netscape /usr/local/netscape-linux /usr/local/lib/netscape /usr/local/lib/netscape-linux %%MOZILLA_HOME%% %D/lib/netscape-linux; do if [ -e ${dir}/plugins/npica.so ]; then (/bin/rm ${dir}/plugins/npica.so); fi ; done
ICAClient/CHARICONV.DLL
ICAClient/NDS.DLL
ICAClient/Npica
@@ -5,9 +8,10 @@ ICAClient/Npica.ad
ICAClient/PDCRYPT1.DLL
ICAClient/PDCRYPT2.DLL
ICAClient/TW1.DLL
-ICAClient/VDEUEM.DLL
+ICAClient/VDMM.DLL
ICAClient/VDSCARD.DLL
ICAClient/VDSPMIKE.DLL
+ICAClient/VDSSPI.DLL
ICAClient/config/.server
ICAClient/config/All_Regions.ini
ICAClient/config/Trusted_Region.ini
@@ -22,7 +26,6 @@ ICAClient/config/usertemplate/Trusted_Region.ini
ICAClient/config/usertemplate/Unknown_Region.ini
ICAClient/config/usertemplate/Untrusted_Region.ini
ICAClient/config/wfclient.ini
-ICAClient/desktop/Citrix_PNA.desktop
ICAClient/desktop/wfcmgr.desktop
ICAClient/eula.txt
ICAClient/help/index.htm
@@ -95,39 +98,106 @@ ICAClient/keystore/cacerts/Class4PCA_G2_v2.crt
ICAClient/keystore/cacerts/GTECTGlobalRoot.crt
ICAClient/keystore/cacerts/Pcs3ss_v4.crt
ICAClient/keystore/cacerts/SecureServer.crt
+ICAClient/wfica.sh
+ICAClient/wfica_assoc.sh
+%%HAVE_ICA_CERTS%%@unexec for f in %%ICA_CERTS%%; do rm %%CERTDIR%%/${f}; done
ICAClient/libctxssl.so
+ICAClient/libproxy.so
ICAClient/nls/C
+ICAClient/nls/de/Npica
+ICAClient/nls/de/Npica.ad
+ICAClient/nls/de/UTF-8/Wfcmgr
+ICAClient/nls/de/UTF-8/Wfica
+ICAClient/nls/de/UTF-8/XCapture
+ICAClient/nls/de/UTF-8/XCapture.ad
+ICAClient/nls/de/UTF-8/eula.txt
+ICAClient/nls/de/UTF-8/install.txt
+ICAClient/nls/de/UTF-8/pna.nls
+ICAClient/nls/de/UTF-8/readme.txt
+ICAClient/nls/de/UTF-8/setupwfc.msg
+ICAClient/nls/de/Wfcmgr
+ICAClient/nls/de/Wfica
+ICAClient/nls/de/XCapture
+ICAClient/nls/de/XCapture.ad
+ICAClient/nls/de/appsrv.ini
+ICAClient/nls/de/eula.txt
+ICAClient/nls/de/hinst.msg
+ICAClient/nls/de/index.htm
+ICAClient/nls/de/install.txt
+ICAClient/nls/de/module.ini
+ICAClient/nls/de/pna.nls
+ICAClient/nls/de/readme.txt
+ICAClient/nls/de/setupwfc.msg
+ICAClient/nls/de/wfclient.ini
+ICAClient/nls/en/Npica
+ICAClient/nls/en/Npica.ad
ICAClient/nls/en/UTF-8/Wfcmgr
ICAClient/nls/en/UTF-8/Wfica
+ICAClient/nls/en/UTF-8/XCapture
+ICAClient/nls/en/UTF-8/XCapture.ad
+ICAClient/nls/en/UTF-8/eula.txt
+ICAClient/nls/en/UTF-8/install.txt
ICAClient/nls/en/UTF-8/pna.nls
+ICAClient/nls/en/UTF-8/readme.txt
+ICAClient/nls/en/UTF-8/setupwfc.msg
ICAClient/nls/en/Wfcmgr
ICAClient/nls/en/Wfica
+ICAClient/nls/en/XCapture
+ICAClient/nls/en/XCapture.ad
+ICAClient/nls/en/appsrv.ini
+ICAClient/nls/en/eula.txt
+ICAClient/nls/en/hinst.msg
+ICAClient/nls/en/index.htm
+ICAClient/nls/en/install.txt
+ICAClient/nls/en/module.ini
ICAClient/nls/en/pna.nls
+ICAClient/nls/en/readme.txt
+ICAClient/nls/en/setupwfc.msg
+ICAClient/nls/en/wfclient.ini
+ICAClient/nls/ja/Npica
+ICAClient/nls/ja/Npica.ad
ICAClient/nls/ja/UTF-8/Wfcmgr
ICAClient/nls/ja/UTF-8/Wfica
+ICAClient/nls/ja/UTF-8/XCapture
+ICAClient/nls/ja/UTF-8/XCapture.ad
+ICAClient/nls/ja/UTF-8/eula.txt
+ICAClient/nls/ja/UTF-8/install.txt
ICAClient/nls/ja/UTF-8/pna.nls
+ICAClient/nls/ja/UTF-8/readme.txt
+ICAClient/nls/ja/UTF-8/setupwfc.msg
ICAClient/nls/ja/Wfcmgr
ICAClient/nls/ja/Wfica
+ICAClient/nls/ja/XCapture
+ICAClient/nls/ja/XCapture.ad
+ICAClient/nls/ja/appsrv.ini
+ICAClient/nls/ja/eula.txt
+ICAClient/nls/ja/hinst.msg
+ICAClient/nls/ja/index.htm
+ICAClient/nls/ja/install.txt
+ICAClient/nls/ja/module.ini
ICAClient/nls/ja/pna.nls
+ICAClient/nls/ja/readme.txt
+ICAClient/nls/ja/setupwfc.msg
+ICAClient/nls/ja/wfclient.ini
ICAClient/npica.so
ICAClient/pkginf/F.core.linuxx86
ICAClient/pkginf/Ver.core.linuxx86
ICAClient/pkginf/changeno.dat
ICAClient/readme.txt
ICAClient/setupwfc
-ICAClient/util/XCapture
-ICAClient/util/XCapture.ad
ICAClient/util/echo_cmd
+ICAClient/util/gst_play
ICAClient/util/hinst
ICAClient/util/icalicense.sh
+ICAClient/util/libgstflatstm.so
ICAClient/util/nslaunch
ICAClient/util/pac.js
ICAClient/util/pacexec
+ICAClient/util/sunraymac.sh
+ICAClient/util/what
ICAClient/util/xcapture
ICAClient/wfcmgr
ICAClient/wfica
-ICAClient/wfica.sh
-ICAClient/wfica_assoc.sh
bin/wfcmgr
bin/wfica
@dirrm ICAClient/util
@@ -136,6 +206,8 @@ bin/wfica
@dirrm ICAClient/nls/ja
@dirrm ICAClient/nls/en/UTF-8
@dirrm ICAClient/nls/en
+@dirrm ICAClient/nls/de/UTF-8
+@dirrm ICAClient/nls/de
@dirrm ICAClient/nls
@dirrm ICAClient/keystore/cacerts
@dirrm ICAClient/keystore