aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-10 03:34:52 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-10 03:34:52 +0000
commitd01fd14467a28b9fab75afe126fcc635e15b7491 (patch)
treecaf7f71c0be7df1c2c18094f7298194906898390 /japanese
parent9a2b3a197f375478f59a3ea577a189895d9a0be7 (diff)
downloadports-d01fd14467a28b9fab75afe126fcc635e15b7491.tar.gz
ports-d01fd14467a28b9fab75afe126fcc635e15b7491.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/kebook/Makefile56
-rw-r--r--japanese/kebook/distinfo1
-rw-r--r--japanese/kebook/pkg-comment1
-rw-r--r--japanese/kebook/pkg-descr6
-rw-r--r--japanese/kebook/pkg-plist52
6 files changed, 117 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index befe3a480dab..5e2580b4b6c9 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -99,6 +99,7 @@
SUBDIR += kappa20
SUBDIR += kbanner
SUBDIR += kcc
+ SUBDIR += kebook-i18n
SUBDIR += kinput2-canna
SUBDIR += kinput2-canna+sj3
SUBDIR += kinput2-canna+sj3+wnn4
diff --git a/japanese/kebook/Makefile b/japanese/kebook/Makefile
new file mode 100644
index 000000000000..624dde0269d6
--- /dev/null
+++ b/japanese/kebook/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: kebook-i18n
+# Date created: 13 Novenver 1999
+# Whom: SUZUKI, Mitsuhiro <hige@higesoft.rim.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kebook
+PORTVERSION= 0.3.4
+CATEGORIES= japanese kde
+MASTER_SITES= http://www.os.rim.or.jp/~s_mitu/library/kebook/ \
+ ftp://ftp.kde.gr.jp/pub/kde/unstable/contrib/
+PKGNAMEPREFIX= ja-
+PKGNAMESUFFIX= -i18n
+
+MAINTAINER= hige@higesoft.os.rim.or.jp
+
+LIB_DEPENDS= qti18n.3:${PORTSDIR}/x11-toolkits/qt-i18n \
+ kdecore.2:${PORTSDIR}/x11/kdelibs11-i18n \
+ kfm.2:${PORTSDIR}/x11/kdebase11-i18n \
+ eb.3:${PORTSDIR}/japanese/eb
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_NEWGCC= yes
+USE_LIBTOOL= yes
+
+CONFIGURE_ARGS= "--with-qt-includes=${QTDIR}/include/X11/qt" \
+ "--with-eb-includes=$(LOCALBASE)/include" \
+ "--with-eb-libraries=$(LOCALBASE)/lib" \
+ "--with-extra-includes=${LOCALBASE}/include" \
+ "--with-extra-libs=${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS=-I$(LOCALBASE)/include \
+ LDFLAGS=-L$(LOCALBASE)/lib \
+ X_EXTRA_LIBS="-lxpg4" \
+ QTDIR=${QTDIR}
+CXXFLAGS?= ${CFLAGS}
+
+DOCDIR= share/apps/kebook/doc
+PLIST_SUB= DOCDIR=${DOCDIR}
+
+.if defined(PREFIX)
+QTDIR?= ${PREFIX}
+.else
+QTDIR?= ${X11BASE}
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/${DOCDIR}
+ @for i in AUTHORS COPYING ChangeLog NEWS README README.euc-jp INSTALL INSTALL.euc-jp; do \
+ ${INSTALL_DATA} ${WRKSRC}/$${i} ${PREFIX}/${DOCDIR} ;\
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/japanese/kebook/distinfo b/japanese/kebook/distinfo
new file mode 100644
index 000000000000..1ee70e71437a
--- /dev/null
+++ b/japanese/kebook/distinfo
@@ -0,0 +1 @@
+MD5 (kebook-0.3.4.tar.bz2) = 9b19aeef4b392e356a1f65a186f86d47
diff --git a/japanese/kebook/pkg-comment b/japanese/kebook/pkg-comment
new file mode 100644
index 000000000000..d735550c5046
--- /dev/null
+++ b/japanese/kebook/pkg-comment
@@ -0,0 +1 @@
+A KDE application to look up words
diff --git a/japanese/kebook/pkg-descr b/japanese/kebook/pkg-descr
new file mode 100644
index 000000000000..136e68e4ecf0
--- /dev/null
+++ b/japanese/kebook/pkg-descr
@@ -0,0 +1,6 @@
+KEBook is a KDE application with which you look up words
+in your CD-ROM books of EB, EBG, EBXA, EBXA-C, S-EBXA and EPWING formats.
+
+WWW: http://www.os.rim.or.jp/~s_mitu/library/mysofts.html#kebook
+
+-SUZUKI, Mitsuhiro <hige@higesoft.rim.or.jp>
diff --git a/japanese/kebook/pkg-plist b/japanese/kebook/pkg-plist
new file mode 100644
index 000000000000..c66948f15621
--- /dev/null
+++ b/japanese/kebook/pkg-plist
@@ -0,0 +1,52 @@
+bin/kebook
+share/applnk/Utilities/kebook.kdelnk
+share/apps/kebook/pics/config-search.xpm
+share/apps/kebook/pics/copyright_btn.xpm
+share/apps/kebook/pics/dictionaries.xpm
+share/apps/kebook/pics/keyboard.xpm
+share/apps/kebook/pics/match-exactly.xpm
+share/apps/kebook/pics/match-head.xpm
+share/apps/kebook/pics/match-tail.xpm
+share/apps/kebook/pics/menu_btn.xpm
+share/doc/HTML/en/kebook/commands.html
+share/doc/HTML/en/kebook/common/logotp3.png
+share/doc/HTML/en/kebook/compilation.html
+share/doc/HTML/en/kebook/configuration.html
+share/doc/HTML/en/kebook/credits.html
+share/doc/HTML/en/kebook/faq.html
+share/doc/HTML/en/kebook/index.html
+share/doc/HTML/en/kebook/installation.html
+share/doc/HTML/en/kebook/introduction.html
+share/doc/HTML/en/kebook/kde.css
+share/doc/HTML/en/kebook/requirements.html
+share/doc/HTML/en/kebook/using-kebook.html
+share/doc/HTML/ja/kebook/commands.html
+share/doc/HTML/ja/kebook/common/logotp3.png
+share/doc/HTML/ja/kebook/compilation.html
+share/doc/HTML/ja/kebook/configuration.html
+share/doc/HTML/ja/kebook/credits.html
+share/doc/HTML/ja/kebook/faq.html
+share/doc/HTML/ja/kebook/index.html
+share/doc/HTML/ja/kebook/installation.html
+share/doc/HTML/ja/kebook/introduction.html
+share/doc/HTML/ja/kebook/kde.css
+share/doc/HTML/ja/kebook/requirements.html
+share/doc/HTML/ja/kebook/using-kebook.html
+share/icons/kebook.xpm
+share/icons/mini/kebook.xpm
+share/locale/ja/LC_MESSAGES/kebook.mo
+%%DOCDIR%%/AUTHORS
+%%DOCDIR%%/COPYING
+%%DOCDIR%%/ChangeLog
+%%DOCDIR%%/INSTALL
+%%DOCDIR%%/INSTALL.euc-jp
+%%DOCDIR%%/NEWS
+%%DOCDIR%%/README
+%%DOCDIR%%/README.euc-jp
+@dirrm %%DOCDIR%%
+@dirrm share/apps/kebook/pics
+@dirrm share/apps/kebook
+@dirrm share/doc/HTML/en/kebook/common
+@dirrm share/doc/HTML/en/kebook
+@dirrm share/doc/HTML/ja/kebook/common
+@dirrm share/doc/HTML/ja/kebook