aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2021-03-13 20:32:45 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-03-13 20:32:45 +0000
commitdb10b77bd44d5d68ed9abd84ff363d554ae5e7f3 (patch)
treea8ef37964dd7f71c13a186053c1b14d9d05a65b3 /japanese
parent6ecbcfeb703b855dc5dba5ae2ce3247d4d6e1987 (diff)
downloadports-db10b77bd44d5d68ed9abd84ff363d554ae5e7f3.tar.gz
ports-db10b77bd44d5d68ed9abd84ff363d554ae5e7f3.zip
japanese/mh: Fix build failure on 13 (with -fno-common)
PR: 249013 Submitted by: WATANABE Kazuhiro <CQG00620@nifty.ne.jp> (maintainer)
Notes
Notes: svn path=/head/; revision=568281
Diffstat (limited to 'japanese')
-rw-r--r--japanese/mh/Makefile2
-rw-r--r--japanese/mh/files/patch-h_formatsbr.h11
-rw-r--r--japanese/mh/files/patch-sbr_fmtcompile.c11
3 files changed, 23 insertions, 1 deletions
diff --git a/japanese/mh/Makefile b/japanese/mh/Makefile
index ca1f6d213a4b..e151d3119945 100644
--- a/japanese/mh/Makefile
+++ b/japanese/mh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mh
PORTVERSION= ${VERSION}.j${JP_VERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= japanese mail
MASTER_SITES= ftp://ftp.laic.u-hyogo.ac.jp/pub/net/mh/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/japanese/mh/files/patch-h_formatsbr.h b/japanese/mh/files/patch-h_formatsbr.h
new file mode 100644
index 000000000000..e1def6bbe4de
--- /dev/null
+++ b/japanese/mh/files/patch-h_formatsbr.h
@@ -0,0 +1,11 @@
+--- h/formatsbr.h.orig 1993-12-01 04:00:26 UTC
++++ h/formatsbr.h
+@@ -32,7 +32,7 @@ struct comp {
+
+ extern int fmt_norm;
+
+-struct comp *wantcomp[128]; /* hash table for deciding if a
++extern struct comp *wantcomp[128]; /* hash table for deciding if a
+ * component is "interesting" */
+
+ /*
diff --git a/japanese/mh/files/patch-sbr_fmtcompile.c b/japanese/mh/files/patch-sbr_fmtcompile.c
new file mode 100644
index 000000000000..675cb7e2ac26
--- /dev/null
+++ b/japanese/mh/files/patch-sbr_fmtcompile.c
@@ -0,0 +1,11 @@
+--- sbr/fmtcompile.c.orig 2001-04-02 16:06:09 UTC
++++ sbr/fmtcompile.c
+@@ -24,6 +24,8 @@ static int infunction; /* function nesting cnt */
+ extern char *getusr();
+ extern struct mailname fmt_mnull;
+
++struct comp *wantcomp[128];
++
+ struct ftable {
+ char *name; /* function name */
+ char type; /* argument type */