aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2020-12-04 12:41:08 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2020-12-04 12:41:08 +0000
commitdf9a2fa31cc785cc95ed8bf8c70a8d1167ff79cf (patch)
tree74be275c25359249a627e2473a89b9ffabdd19a9 /japanese
parent91c1e3911a4e43b92aaf47f17cc93767c0318ee7 (diff)
downloadports-df9a2fa31cc785cc95ed8bf8c70a8d1167ff79cf.tar.gz
ports-df9a2fa31cc785cc95ed8bf8c70a8d1167ff79cf.zip
japanese/yc.el: Adapt to newer emacs versions
The "process-kill-without-query" function was made obsolete in emacs 27.1 [1]. Therefore the function should be replaced in japanese/yc.el by "set-process-query-on-exit-flag" function. [1] http://git.savannah.gnu.org/cgit/emacs.git/commit/?id=f1c48b0 PR: 249873 Submitted by: Takayuki Nakao <t@nakao.org> (maintainer) Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D27473
Notes
Notes: svn path=/head/; revision=556979
Diffstat (limited to 'japanese')
-rw-r--r--japanese/yc.el/Makefile12
-rw-r--r--japanese/yc.el/files/patch-yc.el19
2 files changed, 21 insertions, 10 deletions
diff --git a/japanese/yc.el/Makefile b/japanese/yc.el/Makefile
index 02979b4bcf40..b7b12fde85b5 100644
--- a/japanese/yc.el/Makefile
+++ b/japanese/yc.el/Makefile
@@ -3,7 +3,7 @@
PORTNAME= yc.el
PORTVERSION= 5.2.1
-PORTREVISION= 16
+PORTREVISION= 17
PORTEPOCH= 1
CATEGORIES= japanese elisp
MASTER_SITES= http://www.ceres.dti.ne.jp/~knak/
@@ -14,16 +14,14 @@ EXTRACT_SUFX= .gz
MAINTAINER= t@nakao.org
COMMENT= Yet another Canna client for Emacs
+USES= emacs
+EMACS_FLAVORS_EXCLUDE= devel_full devel_nox # fail to build
+
EXTRACT_CMD= ${GZCAT}
EXTRACT_BEFORE_ARGS= #
EXTRACT_AFTER_ARGS= > yc.el
NO_WRKSUBDIR= yes
-USES= emacs
-EMACS_FLAVORS_EXCLUDE= devel_full devel_nox # fail to build
-
-YC_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/yc
-
PLIST_FILES= ${EMACS_VERSION_SITE_LISPDIR}/yc/yc.el \
${EMACS_VERSION_SITE_LISPDIR}/yc/yc.elc
@@ -31,6 +29,8 @@ OPTIONS_DEFINE= ICANNA
ICANNA_DESC= Enable icanna support
ICANNA_RUN_DEPENDS= icanna:japanese/icanna
+YC_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/yc
+
do-build:
@(cd ${WRKSRC} && \
${EMACS_CMD} -batch -f batch-byte-compile yc.el)
diff --git a/japanese/yc.el/files/patch-yc.el b/japanese/yc.el/files/patch-yc.el
index a1efd46737cb..4abaa48fdda0 100644
--- a/japanese/yc.el/files/patch-yc.el
+++ b/japanese/yc.el/files/patch-yc.el
@@ -1,6 +1,17 @@
---- yc.el.orig 2018-06-04 13:46:33.083915000 +0900
-+++ yc.el 2018-06-04 14:48:21.116298000 +0900
-@@ -1736,6 +1736,7 @@
+--- yc.el.orig 2020-09-25 04:51:12 UTC
++++ yc.el
+@@ -393,7 +393,9 @@ OBJ $B$rJV5Q$9$k!#(B"
+ (error nil)))))))
+ (when (processp yc-server)
+ (put 'yc-server 'init nil)
+- (process-kill-without-query yc-server)
++ (if (boundp 'process-kill-without-query)
++ (process-kill-without-query yc-server)
++ (set-process-query-on-exit-flag yc-server nil))
+ (when yc-debug
+ (unwind-protect
+ (progn
+@@ -1736,6 +1738,7 @@ OBJ $B$rJV5Q$9$k!#(B"
(error nil))))
(yc-eval-sexp (car expr)))))
(setq files (cdr files)))
@@ -8,7 +19,7 @@
(if romkana-table
(setq yc-rH-conv-dic (yc-search-file-first-in-path
romkana-table (list "." (getenv "HOME")
-@@ -2071,7 +2072,7 @@
+@@ -2071,7 +2074,7 @@ OBJ $B$rJV5Q$9$k!#(B"
;; $BJ8@a$r;XDj$7$J$$>l9g!"8=:_$NJ8@a$,BP>]$H$J$k(B
;; $BFI$_$r<hF@$7$?J8@a$O$=$NFI$_$r%-%c%C%7%e$9$k(B
;; cut $B$,(B $BHs(Bnil $B$N>l9g!";XDjJ8@a0J9_$NFI$_$r:o=|$9$k(B