aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-14 20:38:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-14 20:38:15 +0000
commite71f22c36dc5667188a537d36a06338957141060 (patch)
tree137266aed04ab01d05e751e223e266419d2df387 /japanese
parentf45a686f54cf804e7419736e66564640b4f4057a (diff)
downloadports-e71f22c36dc5667188a537d36a06338957141060.tar.gz
ports-e71f22c36dc5667188a537d36a06338957141060.zip
Notes
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile1
-rw-r--r--japanese/latex-japanese/Makefile72
-rw-r--r--japanese/latex-japanese/distinfo3
-rw-r--r--japanese/latex-japanese/pkg-descr4
-rw-r--r--japanese/latex-japanese/pkg-plist6
-rw-r--r--japanese/platex-japanese/Makefile72
-rw-r--r--japanese/platex-japanese/distinfo3
-rw-r--r--japanese/platex-japanese/pkg-descr4
-rw-r--r--japanese/platex-japanese/pkg-plist6
9 files changed, 171 insertions, 0 deletions
diff --git a/japanese/Makefile b/japanese/Makefile
index f2005ad41d49..966a63577061 100644
--- a/japanese/Makefile
+++ b/japanese/Makefile
@@ -168,6 +168,7 @@
SUBDIR += kterm
SUBDIR += kterm16c
SUBDIR += lambdamoo
+ SUBDIR += latex-japanese
SUBDIR += latex2html
SUBDIR += leafrogue
SUBDIR += less
diff --git a/japanese/latex-japanese/Makefile b/japanese/latex-japanese/Makefile
new file mode 100644
index 000000000000..adb241683ca6
--- /dev/null
+++ b/japanese/latex-japanese/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: latex-japanese
+# Date created: 2007-11-19
+# Whom: Koji Yokota <yokota@res.otaru-uc.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= japanese
+PORTVERSION= 1.3
+CATEGORIES= japanese print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= language/japanese
+PKGNAMEPREFIX= latex-
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= latex
+
+MAINTAINER= yokota@res.otaru-uc.ac.jp
+COMMENT= LaTeX package that literally provides japanese option to babel
+
+BUILD_DEPENDS= ${LOCALBASE}/share/texmf:${PORTSDIR}/print/teTeX-texmf \
+ ptex:${PORTSDIR}/japanese/ptex \
+ iconv:${PORTSDIR}/converters/libiconv
+
+USE_ZIP= yes
+
+TEXMFDIR= share/texmf
+STYDIR= tex/generic/babel
+DOCSDIR= doc/generic/babel/${PORTNAME}
+INSFILE= ${PORTNAME}.ins
+DTXFILE= ${PORTNAME}.dtx
+LDFFILE= ${PORTNAME}.ldf
+SAMPLEFILE= sample.tex
+PDFFILE= sample.pdf
+TEXTFILE= README
+ENCODING?= EUC-JP
+ICONV= ${LOCALBASE}/bin/iconv
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+
+.SILENT::
+pre-configure:
+ @${ECHO_MSG}
+ @${ECHO_MSG} Using ${ENCODING} to set locale of installing files.
+ @${ECHO_MSG} To change it, set the $$\{ENCODING\} variable to a desirable iconv\'s locale.
+ @${ECHO_MSG} See \'iconv -l\' for available values.
+ @${ECHO_MSG}
+
+post-configure:
+ ( cd ${WRKSRC} && ${MV} ${INSFILE} ${INSFILE:S/$/.orig/} && \
+ ${SED} -e 's/\(sample\.tex\)/j\1/g' ${INSFILE:S/$/.orig/} \
+ > ${INSFILE} && \
+ ${MV} ${DTXFILE} ${DTXFILE}.orig && \
+ ${ICONV} -f ISO-2022-JP -t ${ENCODING} ${DTXFILE}.orig > ${DTXFILE} )
+
+do-build:
+ ( cd ${WRKSRC} && platex ${INSFILE} && \
+ ${MV} j${SAMPLEFILE} ${SAMPLEFILE})
+
+do-install:
+ ( cd ${WRKSRC} && \
+ ${MKDIR} ${PREFIX}/${TEXMFDIR}/${STYDIR} && \
+ ${CP} -pv ${LDFFILE} ${PREFIX}/${TEXMFDIR}/${STYDIR} )
+.if !defined(NOPORTDOCS)
+ ( cd ${WRKSRC} && \
+ ${MKDIR} ${PREFIX}/${TEXMFDIR}/${DOCSDIR} && \
+ for _FILE in ${PDFFILE} ${TEXTFILE} ${SAMPLEFILE} ; do \
+ ${CP} -pv $${_FILE} ${PREFIX}/${TEXMFDIR}/${DOCSDIR} ; done )
+.endif
+
+post-install:
+ ${MKTEXLSR} ${PREFIX}/${TEXMFDIR}
+
+.include <bsd.port.mk>
diff --git a/japanese/latex-japanese/distinfo b/japanese/latex-japanese/distinfo
new file mode 100644
index 000000000000..8c5eff3f5e21
--- /dev/null
+++ b/japanese/latex-japanese/distinfo
@@ -0,0 +1,3 @@
+MD5 (latex/japanese.zip) = 8475593270897f261e8b010aa5529ecd
+SHA256 (latex/japanese.zip) = 96d6d0b625ff58dc10bb66ead14fb297ca9ce19e95f9f4686f775f67eddeea2d
+SIZE (latex/japanese.zip) = 49436
diff --git a/japanese/latex-japanese/pkg-descr b/japanese/latex-japanese/pkg-descr
new file mode 100644
index 000000000000..58f8cefd6991
--- /dev/null
+++ b/japanese/latex-japanese/pkg-descr
@@ -0,0 +1,4 @@
+The original babel package for LaTeX does not have an option Japanese.
+This port adds Japanese option to babel.
+
+WWW: http://www.ctan.org/tex-archive/language/japanese/japanese/
diff --git a/japanese/latex-japanese/pkg-plist b/japanese/latex-japanese/pkg-plist
new file mode 100644
index 000000000000..9e8ae2237c7d
--- /dev/null
+++ b/japanese/latex-japanese/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%PORTDOCS%%share/texmf/doc/generic/babel/japanese/README
+%%PORTDOCS%%share/texmf/doc/generic/babel/japanese/sample.pdf
+%%PORTDOCS%%share/texmf/doc/generic/babel/japanese/sample.tex
+share/texmf/tex/generic/babel/japanese.ldf
+%%PORTDOCS%%@dirrm share/texmf/doc/generic/babel/japanese
diff --git a/japanese/platex-japanese/Makefile b/japanese/platex-japanese/Makefile
new file mode 100644
index 000000000000..adb241683ca6
--- /dev/null
+++ b/japanese/platex-japanese/Makefile
@@ -0,0 +1,72 @@
+# New ports collection makefile for: latex-japanese
+# Date created: 2007-11-19
+# Whom: Koji Yokota <yokota@res.otaru-uc.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= japanese
+PORTVERSION= 1.3
+CATEGORIES= japanese print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= language/japanese
+PKGNAMEPREFIX= latex-
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= latex
+
+MAINTAINER= yokota@res.otaru-uc.ac.jp
+COMMENT= LaTeX package that literally provides japanese option to babel
+
+BUILD_DEPENDS= ${LOCALBASE}/share/texmf:${PORTSDIR}/print/teTeX-texmf \
+ ptex:${PORTSDIR}/japanese/ptex \
+ iconv:${PORTSDIR}/converters/libiconv
+
+USE_ZIP= yes
+
+TEXMFDIR= share/texmf
+STYDIR= tex/generic/babel
+DOCSDIR= doc/generic/babel/${PORTNAME}
+INSFILE= ${PORTNAME}.ins
+DTXFILE= ${PORTNAME}.dtx
+LDFFILE= ${PORTNAME}.ldf
+SAMPLEFILE= sample.tex
+PDFFILE= sample.pdf
+TEXTFILE= README
+ENCODING?= EUC-JP
+ICONV= ${LOCALBASE}/bin/iconv
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+
+.SILENT::
+pre-configure:
+ @${ECHO_MSG}
+ @${ECHO_MSG} Using ${ENCODING} to set locale of installing files.
+ @${ECHO_MSG} To change it, set the $$\{ENCODING\} variable to a desirable iconv\'s locale.
+ @${ECHO_MSG} See \'iconv -l\' for available values.
+ @${ECHO_MSG}
+
+post-configure:
+ ( cd ${WRKSRC} && ${MV} ${INSFILE} ${INSFILE:S/$/.orig/} && \
+ ${SED} -e 's/\(sample\.tex\)/j\1/g' ${INSFILE:S/$/.orig/} \
+ > ${INSFILE} && \
+ ${MV} ${DTXFILE} ${DTXFILE}.orig && \
+ ${ICONV} -f ISO-2022-JP -t ${ENCODING} ${DTXFILE}.orig > ${DTXFILE} )
+
+do-build:
+ ( cd ${WRKSRC} && platex ${INSFILE} && \
+ ${MV} j${SAMPLEFILE} ${SAMPLEFILE})
+
+do-install:
+ ( cd ${WRKSRC} && \
+ ${MKDIR} ${PREFIX}/${TEXMFDIR}/${STYDIR} && \
+ ${CP} -pv ${LDFFILE} ${PREFIX}/${TEXMFDIR}/${STYDIR} )
+.if !defined(NOPORTDOCS)
+ ( cd ${WRKSRC} && \
+ ${MKDIR} ${PREFIX}/${TEXMFDIR}/${DOCSDIR} && \
+ for _FILE in ${PDFFILE} ${TEXTFILE} ${SAMPLEFILE} ; do \
+ ${CP} -pv $${_FILE} ${PREFIX}/${TEXMFDIR}/${DOCSDIR} ; done )
+.endif
+
+post-install:
+ ${MKTEXLSR} ${PREFIX}/${TEXMFDIR}
+
+.include <bsd.port.mk>
diff --git a/japanese/platex-japanese/distinfo b/japanese/platex-japanese/distinfo
new file mode 100644
index 000000000000..8c5eff3f5e21
--- /dev/null
+++ b/japanese/platex-japanese/distinfo
@@ -0,0 +1,3 @@
+MD5 (latex/japanese.zip) = 8475593270897f261e8b010aa5529ecd
+SHA256 (latex/japanese.zip) = 96d6d0b625ff58dc10bb66ead14fb297ca9ce19e95f9f4686f775f67eddeea2d
+SIZE (latex/japanese.zip) = 49436
diff --git a/japanese/platex-japanese/pkg-descr b/japanese/platex-japanese/pkg-descr
new file mode 100644
index 000000000000..58f8cefd6991
--- /dev/null
+++ b/japanese/platex-japanese/pkg-descr
@@ -0,0 +1,4 @@
+The original babel package for LaTeX does not have an option Japanese.
+This port adds Japanese option to babel.
+
+WWW: http://www.ctan.org/tex-archive/language/japanese/japanese/
diff --git a/japanese/platex-japanese/pkg-plist b/japanese/platex-japanese/pkg-plist
new file mode 100644
index 000000000000..9e8ae2237c7d
--- /dev/null
+++ b/japanese/platex-japanese/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%PORTDOCS%%share/texmf/doc/generic/babel/japanese/README
+%%PORTDOCS%%share/texmf/doc/generic/babel/japanese/sample.pdf
+%%PORTDOCS%%share/texmf/doc/generic/babel/japanese/sample.tex
+share/texmf/tex/generic/babel/japanese.ldf
+%%PORTDOCS%%@dirrm share/texmf/doc/generic/babel/japanese