aboutsummaryrefslogtreecommitdiff
path: root/java/apache-commons-discovery
diff options
context:
space:
mode:
authorPedro F. Giffuni <pfg@FreeBSD.org>2020-01-29 23:00:31 +0000
committerPedro F. Giffuni <pfg@FreeBSD.org>2020-01-29 23:00:31 +0000
commitfa6c19803d242f5693ac227cef1991746888a387 (patch)
tree14ba2337af6658923e1b563cea9ef177cb2fcf07 /java/apache-commons-discovery
parentf514a3272f0aa49c37f975964e0f29aa3aa0ed71 (diff)
downloadports-fa6c19803d242f5693ac227cef1991746888a387.tar.gz
ports-fa6c19803d242f5693ac227cef1991746888a387.zip
Notes
Diffstat (limited to 'java/apache-commons-discovery')
-rw-r--r--java/apache-commons-discovery/Makefile31
-rw-r--r--java/apache-commons-discovery/distinfo2
-rw-r--r--java/apache-commons-discovery/pkg-descr18
3 files changed, 51 insertions, 0 deletions
diff --git a/java/apache-commons-discovery/Makefile b/java/apache-commons-discovery/Makefile
new file mode 100644
index 000000000000..9877fce009f7
--- /dev/null
+++ b/java/apache-commons-discovery/Makefile
@@ -0,0 +1,31 @@
+# Created by: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
+# $FreeBSD$
+
+PORTNAME= commons-discovery
+PORTVERSION= 0.5
+CATEGORIES= java devel
+MASTER_SITES= APACHE_COMMONS_BINARIES
+PKGNAMEPREFIX= apache-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Java library for locating resources (including classes)
+
+LICENSE= APACHE20
+
+USE_JAVA= YES
+NO_BUILD= YES
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+JARFILE= ${PORTNAME}.jar
+PLIST_FILES+= ${JAVAJARDIR}/${JARFILE}
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/${JARFILE}
+ cd ${WRKSRC}/apidocs && ${FIND} . -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/{} \;
+ cd ${WRKSRC}/apidocs && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
+
+.include <bsd.port.mk>
diff --git a/java/apache-commons-discovery/distinfo b/java/apache-commons-discovery/distinfo
new file mode 100644
index 000000000000..06a74984d3f4
--- /dev/null
+++ b/java/apache-commons-discovery/distinfo
@@ -0,0 +1,2 @@
+SHA256 (commons-discovery-0.5-bin.tar.gz) = 05637d67e5025ea37fb2de4ef4f5a5489bcca31555fadadfeb5e59f0481b0204
+SIZE (commons-discovery-0.5-bin.tar.gz) = 714772
diff --git a/java/apache-commons-discovery/pkg-descr b/java/apache-commons-discovery/pkg-descr
new file mode 100644
index 000000000000..4c678722321c
--- /dev/null
+++ b/java/apache-commons-discovery/pkg-descr
@@ -0,0 +1,18 @@
+Commons Discovery: Service Discovery component
+
+The Discovery Component is about discovering, or finding, implementations for
+pluggable interfaces. It provides facilities instantiating classes in general,
+and for lifecycle management of singleton (factory) classes.
+
+Fundamentally, Discovery locates classes that implement a given Java interface.
+The discovery pattern, though not necessarily this package, is used in many
+projects including JAXP (SaxParserFactory and others) and commons-logging
+(LogFactory). By extracting this pattern, other projects can (re)use it and
+take advantage of improvements to the pattern as Discovery evolves.
+
+Discovery improves over previous implementations by establishing facilities for
+working within managed environments. These allow configuration and property
+overrides without appealing to the global System properties (which are scoped
+across an entire JVM).
+
+WWW: http://commons.apache.org/discovery/