aboutsummaryrefslogtreecommitdiff
path: root/java/apache-commons-lang
diff options
context:
space:
mode:
authorPedro F. Giffuni <pfg@FreeBSD.org>2019-10-06 19:08:14 +0000
committerPedro F. Giffuni <pfg@FreeBSD.org>2019-10-06 19:08:14 +0000
commitc937a4ccc9f8c084344ae2b95fda9e50dfe7ab03 (patch)
treed1f15965fd21b7db5e3b21c1d8dc8442e6e2f50e /java/apache-commons-lang
parentbbc7901e66f498ae60a9b87b783813dc5fb0edf2 (diff)
downloadports-c937a4ccc9f8c084344ae2b95fda9e50dfe7ab03.tar.gz
ports-c937a4ccc9f8c084344ae2b95fda9e50dfe7ab03.zip
rename most cases of jakarta- to apache-
The Apache Softare Foundation used to maintain an umbrella project named Jakarta but it was retired on 2011. This name now conflicts with the new name for Java EE under the Eclipse Foundation. Rename most of the packages to be more consistent. Some other packages remain but they will require intervention by their corresponding maintainers. Approved by: thierry (mentor), makc Differential Revision: https://reviews.freebsd.org/D21902
Notes
Notes: svn path=/head/; revision=513899
Diffstat (limited to 'java/apache-commons-lang')
-rw-r--r--java/apache-commons-lang/Makefile48
-rw-r--r--java/apache-commons-lang/distinfo2
-rw-r--r--java/apache-commons-lang/pkg-descr13
3 files changed, 63 insertions, 0 deletions
diff --git a/java/apache-commons-lang/Makefile b/java/apache-commons-lang/Makefile
new file mode 100644
index 000000000000..1dc30a7a3b81
--- /dev/null
+++ b/java/apache-commons-lang/Makefile
@@ -0,0 +1,48 @@
+# Created by: Ernst de Haan <znerd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= commons-lang
+PORTVERSION= 2.6
+CATEGORIES= java devel
+MASTER_SITES= APACHE_COMMONS_SOURCE
+PKGNAMEPREFIX= apache-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Apache library with helper utilities for the java.lang API
+
+LICENSE= APACHE20
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+USE_ANT= yes
+ALL_TARGET= jar
+
+JARFILE= ${PORTNAME}-${PORTVERSION}.jar
+DESTJARFILE= ${PORTNAME}.jar
+PLIST_FILES= %%JAVAJARDIR%%/${DESTJARFILE}
+PORTDOCS= *
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+ALL_TARGET+= javadoc
+.endif
+
+JDK_API!= (${FIND} -s ${LOCALBASE}/share/doc/jdk1.? -maxdepth 1 -name api -type d 2>/dev/null || ${ECHO_CMD}) | ${TAIL} -n 1
+
+.if ${JDK_API} != ""
+MAKE_ARGS+= -Djdk.javadoc=${JDK_API}
+.endif
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/target/${JARFILE} \
+ ${STAGEDIR}${JAVAJARDIR}/${DESTJARFILE}
+.if ${PORT_OPTIONS:MDOCS}
+ (cd ${WRKSRC}/target/apidocs && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${DOCSDIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/java/apache-commons-lang/distinfo b/java/apache-commons-lang/distinfo
new file mode 100644
index 000000000000..7e9fabf47253
--- /dev/null
+++ b/java/apache-commons-lang/distinfo
@@ -0,0 +1,2 @@
+SHA256 (commons-lang-2.6-src.tar.gz) = 05479771851be0af057032fa26ad90aa0c91c10e1fc4439558a1ffa6f053bcd7
+SIZE (commons-lang-2.6-src.tar.gz) = 564032
diff --git a/java/apache-commons-lang/pkg-descr b/java/apache-commons-lang/pkg-descr
new file mode 100644
index 000000000000..a9e5b50b78ec
--- /dev/null
+++ b/java/apache-commons-lang/pkg-descr
@@ -0,0 +1,13 @@
+The standard Java libraries fail to provide enough methods for
+manipulation of its core classes. The Lang Component provides
+these extra methods.
+
+The Lang Component provides a host of helper utilities for the
+java.lang API, notably String manipulation methods, basic
+numerical methods, object reflection, creation and serialization,
+and System properties. Additionally it contains an inheritable
+enum type, an exception structure that supports multiple types of
+nested-Exceptions and a series of utlities dedicated to help with
+building methods, such as hashCode, toString and equals.
+
+WWW: http://commons.apache.org/proper/commons-lang/