aboutsummaryrefslogtreecommitdiff
path: root/java/apache-commons-logging
diff options
context:
space:
mode:
authorPedro F. Giffuni <pfg@FreeBSD.org>2019-10-06 19:08:14 +0000
committerPedro F. Giffuni <pfg@FreeBSD.org>2019-10-06 19:08:14 +0000
commitc937a4ccc9f8c084344ae2b95fda9e50dfe7ab03 (patch)
treed1f15965fd21b7db5e3b21c1d8dc8442e6e2f50e /java/apache-commons-logging
parentbbc7901e66f498ae60a9b87b783813dc5fb0edf2 (diff)
downloadports-c937a4ccc9f8c084344ae2b95fda9e50dfe7ab03.tar.gz
ports-c937a4ccc9f8c084344ae2b95fda9e50dfe7ab03.zip
rename most cases of jakarta- to apache-
The Apache Softare Foundation used to maintain an umbrella project named Jakarta but it was retired on 2011. This name now conflicts with the new name for Java EE under the Eclipse Foundation. Rename most of the packages to be more consistent. Some other packages remain but they will require intervention by their corresponding maintainers. Approved by: thierry (mentor), makc Differential Revision: https://reviews.freebsd.org/D21902
Notes
Notes: svn path=/head/; revision=513899
Diffstat (limited to 'java/apache-commons-logging')
-rw-r--r--java/apache-commons-logging/Makefile35
-rw-r--r--java/apache-commons-logging/distinfo3
-rw-r--r--java/apache-commons-logging/pkg-descr12
3 files changed, 50 insertions, 0 deletions
diff --git a/java/apache-commons-logging/Makefile b/java/apache-commons-logging/Makefile
new file mode 100644
index 000000000000..d11312f4134b
--- /dev/null
+++ b/java/apache-commons-logging/Makefile
@@ -0,0 +1,35 @@
+# Created by: Ernst de Haan <znerd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= commons-logging
+PORTVERSION= 1.2
+CATEGORIES= java devel
+MASTER_SITES= APACHE_COMMONS_BINARIES
+PKGNAMEPREFIX= apache-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Generic logging wrapper library
+
+LICENSE= APACHE20
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+OPTIONS_DEFINE= DOCS
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+NO_BUILD= yes
+
+JARFILE= ${PORTNAME}-${PORTVERSION}.jar
+
+PORTDOCS= *
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
+ %%JAVAJARDIR%%/${JARFILE}
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${JARFILE} ${STAGEDIR}${JAVAJARDIR}
+ ${LN} -sf ${JARFILE} ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
+ (cd ${WRKSRC}/apidocs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>
diff --git a/java/apache-commons-logging/distinfo b/java/apache-commons-logging/distinfo
new file mode 100644
index 000000000000..dbbab162e5d4
--- /dev/null
+++ b/java/apache-commons-logging/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1570207571
+SHA256 (commons-logging-1.2-bin.tar.gz) = 3f758805c7290d9c6d22d1451587c9f7232744aef4c984e88aa683cdea0587bd
+SIZE (commons-logging-1.2-bin.tar.gz) = 315429
diff --git a/java/apache-commons-logging/pkg-descr b/java/apache-commons-logging/pkg-descr
new file mode 100644
index 000000000000..02a93bf2c47d
--- /dev/null
+++ b/java/apache-commons-logging/pkg-descr
@@ -0,0 +1,12 @@
+Apache Commons Logging library.
+
+There is a great need for debugging and logging information inside of Commons
+components such as HTTPClient and DBCP. However, there are many logging APIs
+out there and it is difficult to choose among them.
+
+The Logging package is an ultra-thin bridge between different logging
+libraries. Commons components may use the Logging API to remove compile-time
+and run-time dependencies on any particular logging package, and contributors
+may write Log implementations for the library of their choice.
+
+WWW: http://commons.apache.org/proper/commons-logging/