aboutsummaryrefslogtreecommitdiff
path: root/java/bouncycastle15
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2017-07-11 05:38:31 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2017-07-11 05:38:31 +0000
commit72482226ac4a38e18863986f884614e5d67dceb7 (patch)
treefe182d55dbee7b27644cda314ccb5e4afb2d4ced /java/bouncycastle15
parent75c46d3631b105e2e206fbc46c76f23e76bf54f0 (diff)
downloadports-72482226ac4a38e18863986f884614e5d67dceb7.tar.gz
ports-72482226ac4a38e18863986f884614e5d67dceb7.zip
Fix build of java/bouncycastle15 on armv6:
remove fork="true" in javac and fork="yes" in junit tasks (ant/bc+-build.xml) Original report: If java/bouncycastle15 is build on armv6 with openjdk18, the build stops with This command is not for general use and should only be run as the result of a call to ProcessBuilder.start() or Runtime.exec() in a java application PR: 220612 Submitted by: Gerrit Beine <mail+freebsd@gerritbeine.de> (based on) Approved by: az (mentor)
Notes
Notes: svn path=/head/; revision=445468
Diffstat (limited to 'java/bouncycastle15')
-rw-r--r--java/bouncycastle15/Makefile5
-rw-r--r--java/bouncycastle15/files/armv6-patch-bc+-build.xml37
2 files changed, 42 insertions, 0 deletions
diff --git a/java/bouncycastle15/Makefile b/java/bouncycastle15/Makefile
index 3f517c7467e6..39d6b665c4d5 100644
--- a/java/bouncycastle15/Makefile
+++ b/java/bouncycastle15/Makefile
@@ -47,6 +47,11 @@ PORTDOCS= *
.include <bsd.port.options.mk>
+# PR 220612: remove fork="true" in javac and fork="yes" in junit tasks
+.if ${ARCH}=="armv6"
+EXTRA_PATCHES+= ${FILESDIR}/armv6-patch-bc+-build.xml
+.endif
+
do-install:
.for jar in ${JARS}
${INSTALL_DATA} ${WRKSRC}/build/artifacts/jdk${JDKMVERSION}/jars/${jar}-jdk${JDKNVERSION}on-${DVERSION}.jar \
diff --git a/java/bouncycastle15/files/armv6-patch-bc+-build.xml b/java/bouncycastle15/files/armv6-patch-bc+-build.xml
new file mode 100644
index 000000000000..65834ac9ee6b
--- /dev/null
+++ b/java/bouncycastle15/files/armv6-patch-bc+-build.xml
@@ -0,0 +1,37 @@
+--- ant/bc+-build.xml.orig 2017-05-03 05:05:26 UTC
++++ ant/bc+-build.xml
+@@ -107,7 +107,7 @@
+ srcdir="${artifacts.dir}/@{target}/src"
+ destdir="${build.dir}/@{target}/classes"
+ memoryMaximumSize="512m"
+- debug="${release.debug}" fork="true">
++ debug="${release.debug}">
+ <classpath>
+ <path refid="project.classpath" />
+ <fileset dir="${artifacts.jars.dir}">
+@@ -282,7 +282,6 @@
+ srcdir="${lcrypto.target.src.dir}"
+ destdir="${lcrypto.target.classes.dir}"
+ memoryMaximumSize="512m"
+- fork="true"
+ debug="${release.debug}">
+ <classpath>
+ <path refid="project.classpath" />
+@@ -762,7 +761,7 @@
+
+ <target name="test">
+ <mkdir dir="${basedir}/${build.dir}/${target.prefix}" />
+- <junit fork="yes" dir="${basedir}/${build.dir}/${target.prefix}" failureProperty="test.failed">
++ <junit dir="${basedir}/${build.dir}/${target.prefix}" failureProperty="test.failed">
+ <classpath>
+ <path refid="project.classpath" />
+ <fileset dir="${artifacts.jars.dir}">
+@@ -789,7 +788,7 @@
+ </target>
+
+ <target name="test-lw">
+- <junit fork="yes" dir="${basedir}/${build.dir}/${target.prefix}" failureProperty="test.failed">
++ <junit dir="${basedir}/${build.dir}/${target.prefix}" failureProperty="test.failed">
+ <classpath>
+ <fileset dir="${artifacts.jars.dir}">
+ <include name="**/*.jar" />