aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-cdt/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-03 03:28:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-03 03:28:05 +0000
commit257d46643508f582b41b39766dbc45982d8076a6 (patch)
treed44fcb0f8527201ab1f239369f6e04ad51428f0c /java/eclipse-cdt/Makefile
parent7c2240e3647877a13972eb68eb9c842ca87e98b8 (diff)
downloadports-257d46643508f582b41b39766dbc45982d8076a6.tar.gz
ports-257d46643508f582b41b39766dbc45982d8076a6.zip
Notes
Diffstat (limited to 'java/eclipse-cdt/Makefile')
-rw-r--r--java/eclipse-cdt/Makefile56
1 files changed, 46 insertions, 10 deletions
diff --git a/java/eclipse-cdt/Makefile b/java/eclipse-cdt/Makefile
index fbe5487fd197..91104aa02007 100644
--- a/java/eclipse-cdt/Makefile
+++ b/java/eclipse-cdt/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= cdt
-PORTVERSION= 3.0.0
+PORTVERSION= 3.0.1
CATEGORIES= java devel
MASTER_SITES= http://download.eclipse.org/tools/cdt/releases/eclipse3.1/dist/${PORTVERSION}/
PKGNAMEPREFIX= eclipse-
-DISTNAME= org.eclipse.cdt-${PORTVERSION}-linux.${ECLIPSE_ARCH}
+DISTNAME= org.eclipse.cdt.sdk-${PORTVERSION}-linux.${ECLIPSE_ARCH}
DIST_SUBDIR= eclipse
MAINTAINER= freebsd-eclipse@FreeBSD.org
@@ -19,19 +19,55 @@ COMMENT= C/C++ IDE for Eclipse
RUN_DEPENDS= ${LOCALBASE}/eclipse:${PORTSDIR}/java/eclipse
NO_WRKSUBDIR= yes
-NO_BUILD= yes
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_OS= native
+USE_GMAKE= yes
+.include <bsd.port.pre.mk>
+
+ECLIPSE_OS= freebsd
+.if (${ARCH} == "amd64")
+ECLIPSE_ARCH= amd64
+.else
ECLIPSE_ARCH= x86
+.endif
+
+MAKE_ENV+= ECLIPSE_ARCH=${ECLIPSE_ARCH} \
+ ECLIPSE_OS=${ECLIPSE_OS} \
+ PORTVERSION=${PORTVERSION} \
+ JAVA_HOME=${JAVA_HOME}
+
+do-build:
+ @${RM} ${WRKSRC}/eclipse/features/org.eclipse.cdt_${PORTVERSION}/*.orig
+ @${RM} ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_${PORTVERSION}/*.orig
+ @${RM} ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.core.freebsd_${PORTVERSION}/*.orig
+ @${RM} ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.core_${PORTVERSION}/*.orig
+ @${RM} ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.managedbuilder.gnu.ui_${PORTVERSION}/*.orig
+ @(cd ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.source.freebsd.gtk.x86_${PORTVERSION}/src/org.eclipse.cdt.core.freebsd_${PORTVERSION}/library; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE})
do-install:
@${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse -not -type d) >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d eclipse -type d) \
- | ${GREP} -vE 'eclipse$$|eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
-.include <bsd.port.mk>
+ @${MKDIR} ${PREFIX}/eclipse/features
+ @${MKDIR} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/features/org.eclipse.cdt_${PORTVERSION} ${PREFIX}/eclipse/features
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.core.freebsd_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.core_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.debug.core_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.debug.mi.core_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.debug.mi.ui_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.debug.ui_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.doc.user_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.launch_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.make.core_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.make.ui_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.managedbuilder.core_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.managedbuilder.gnu.ui_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.managedbuilder.ui_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.refactoring_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.ui_${PORTVERSION} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/eclipse/plugins/org.eclipse.cdt_${PORTVERSION} ${PREFIX}/eclipse/plugins
+
+.include <bsd.port.post.mk>