aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-cdt
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2006-02-02 22:02:01 +0000
committerGreg Lewis <glewis@FreeBSD.org>2006-02-02 22:02:01 +0000
commit3e03d77e1bff1b038e3d816ead3e05881fb143cc (patch)
treeca1b875b0504739bfa003bd65b728fa0c305fc62 /java/eclipse-cdt
parentfff644e06bb655ad949ee60c4ad262ac091fca8b (diff)
downloadports-3e03d77e1bff1b038e3d816ead3e05881fb143cc.tar.gz
ports-3e03d77e1bff1b038e3d816ead3e05881fb143cc.zip
. Fix the build on amd64 (although some native libraries are missing).
. Fix a crash when trying to execute a programme via the "Run" or "Debug" menu items. PR: 91825 Submitted by: Panagiotis Astithas <past@ebs.gr>
Notes
Notes: svn path=/head/; revision=155104
Diffstat (limited to 'java/eclipse-cdt')
-rw-r--r--java/eclipse-cdt/Makefile6
-rw-r--r--java/eclipse-cdt/files/patch-cdt.core-openpty.c13
-rw-r--r--java/eclipse-cdt/pkg-plist2
3 files changed, 16 insertions, 5 deletions
diff --git a/java/eclipse-cdt/Makefile b/java/eclipse-cdt/Makefile
index 91104aa02007..2a266a455fb5 100644
--- a/java/eclipse-cdt/Makefile
+++ b/java/eclipse-cdt/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 3.0.1
CATEGORIES= java devel
MASTER_SITES= http://download.eclipse.org/tools/cdt/releases/eclipse3.1/dist/${PORTVERSION}/
PKGNAMEPREFIX= eclipse-
-DISTNAME= org.eclipse.cdt.sdk-${PORTVERSION}-linux.${ECLIPSE_ARCH}
+DISTNAME= org.eclipse.cdt.sdk-${PORTVERSION}-linux.x86
DIST_SUBDIR= eclipse
MAINTAINER= freebsd-eclipse@FreeBSD.org
@@ -31,6 +31,8 @@ ECLIPSE_OS= freebsd
ECLIPSE_ARCH= amd64
.else
ECLIPSE_ARCH= x86
+PLIST_FILES+= eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_3.0.1/os/freebsd/x86/libpty.so \
+ eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_3.0.1/os/freebsd/x86/libspawner.so
.endif
MAKE_ENV+= ECLIPSE_ARCH=${ECLIPSE_ARCH} \
@@ -44,8 +46,10 @@ do-build:
@${RM} ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.core.freebsd_${PORTVERSION}/*.orig
@${RM} ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.core_${PORTVERSION}/*.orig
@${RM} ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.managedbuilder.gnu.ui_${PORTVERSION}/*.orig
+.if (${ARCH} == "i386")
@(cd ${WRKSRC}/eclipse/plugins/org.eclipse.cdt.source.freebsd.gtk.x86_${PORTVERSION}/src/org.eclipse.cdt.core.freebsd_${PORTVERSION}/library; \
${SETENV} ${MAKE_ENV} ${GMAKE})
+.endif
do-install:
@${MKDIR} ${PREFIX}/eclipse
diff --git a/java/eclipse-cdt/files/patch-cdt.core-openpty.c b/java/eclipse-cdt/files/patch-cdt.core-openpty.c
index c0daa2e8525f..430555064eee 100644
--- a/java/eclipse-cdt/files/patch-cdt.core-openpty.c
+++ b/java/eclipse-cdt/files/patch-cdt.core-openpty.c
@@ -1,5 +1,5 @@
---- eclipse/plugins/org.eclipse.cdt.source.freebsd.gtk.x86_3.0.1/src/org.eclipse.cdt.core.freebsd_3.0.1/library/openpty.c.orig Sat Dec 3 01:10:16 2005
-+++ eclipse/plugins/org.eclipse.cdt.source.freebsd.gtk.x86_3.0.1/src/org.eclipse.cdt.core.freebsd_3.0.1/library/openpty.c Sat Dec 3 01:13:46 2005
+--- eclipse/plugins/org.eclipse.cdt.source.freebsd.gtk.x86_3.0.1/src/org.eclipse.cdt.core.freebsd_3.0.1/library/openpty.c.orig Wed Jan 11 22:04:49 2006
++++ eclipse/plugins/org.eclipse.cdt.source.freebsd.gtk.x86_3.0.1/src/org.eclipse.cdt.core.freebsd_3.0.1/library/openpty.c Wed Jan 11 22:52:35 2006
@@ -20,7 +20,6 @@
#include <grp.h>
@@ -8,3 +8,12 @@
/**
* This is taken from R. W. Stevens book.
+@@ -84,7 +83,7 @@
+ char *ptr;
+
+ strcpy(pts_name, "/dev/ptmx");
+- fdm = getpt();
++ fdm = posix_openpt(O_RDWR);
+ if (fdm < 0)
+ return -1;
+ if (grantpt(fdm) < 0) { /* grant access to slave */
diff --git a/java/eclipse-cdt/pkg-plist b/java/eclipse-cdt/pkg-plist
index c369fb25d93f..69d8a5421268 100644
--- a/java/eclipse-cdt/pkg-plist
+++ b/java/eclipse-cdt/pkg-plist
@@ -531,8 +531,6 @@ eclipse/plugins/org.eclipse.cdt.core_3.0.1/cdtcore.jar
eclipse/plugins/org.eclipse.cdt.core_3.0.1/plugin.properties
eclipse/plugins/org.eclipse.cdt.core_3.0.1/about.html
eclipse/plugins/org.eclipse.cdt.core_3.0.1/plugin.xml
-eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_3.0.1/os/freebsd/x86/libspawner.so
-eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_3.0.1/os/freebsd/x86/libpty.so
eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_3.0.1/about.html
eclipse/plugins/org.eclipse.cdt.core.freebsd.x86_3.0.1/fragment.xml
eclipse/plugins/org.eclipse.cdt.core.freebsd_3.0.1/cdt_linux.jar