aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-pydev
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2012-07-19 21:43:28 +0000
committerNicola Vitale <nivit@FreeBSD.org>2012-07-19 21:43:28 +0000
commit1fa1fd91a8d3fbb67516ab035247349c5c54183c (patch)
treee3290372ba470e73fb52b57b06959707196bddde /java/eclipse-pydev
parentd7a8c5c1f93b73de759ae7f1ec74dfda326acc7f (diff)
downloadports-1fa1fd91a8d3fbb67516ab035247349c5c54183c.tar.gz
ports-1fa1fd91a8d3fbb67516ab035247349c5c54183c.zip
- Add files/pkg-install.in
- Add a note to pkg-message about the problem of not seeing the PyDev perspective - Bump PORTREVISION - Remove PLIST_SUB - Add SUB_LIST, SUB_FILES (for pkg-install) - Use a different (and ugly) way to update the bundles.info file of Eclipse, and make pointyhat happy(http://goo.gl/LVKpz ) (post-install target) [1] - Add an @unexec command to pkg-plist to remove any reference to PyDev in bundles.info when you uninstall the package (add-plist-post target) Buildlog: http://goo.gl/B18L5 Reported by: pointyhat (via erwin, and beat) [1]
Notes
Notes: svn path=/head/; revision=301192
Diffstat (limited to 'java/eclipse-pydev')
-rw-r--r--java/eclipse-pydev/Makefile28
-rw-r--r--java/eclipse-pydev/files/pkg-install.in28
-rw-r--r--java/eclipse-pydev/pkg-message7
3 files changed, 54 insertions, 9 deletions
diff --git a/java/eclipse-pydev/Makefile b/java/eclipse-pydev/Makefile
index 401e77a67cd0..a01be32821c5 100644
--- a/java/eclipse-pydev/Makefile
+++ b/java/eclipse-pydev/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pydev
PORTVERSION= 2.6.0
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= java devel python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/PyDev%20${PORTVERSION}/
PKGNAMEPREFIX= eclipse-
@@ -31,28 +31,40 @@ JYTHON_DESC= Use Jython as Python interpreter
RUN_DEPENDS+= jython:${PORTSDIR}/lang/jython
.endif
-PLIST_SUB= PORTVERSION=${PORTVERSION}.${DISTDATE}
-
USE_PYTHON= yes
USE_ZIP= yes
DISTDATE= 2012062818
+SUB_FILES= pkg-install
+SUB_LIST= BUNDLES_INFO=${BUNDLES_INFO} DISTDATE=${DISTDATE} \
+ PLUGINDIR=${PLUGINDIR} PORTVERSION=${PORTVERSION}
+
pre-install:
@# ignore javashell.py file, because there is a syntax error
@# see http://goo.gl/E4epH
${PYTHON_CMD} -m compileall -x javashell.py -f ${WRKSRC}/plugins
${PYTHON_CMD} -O -m compileall -x javashell.py -f ${WRKSRC}
+REVDOM= python.pydev
+PLUGINDIR= ../../share/eclipse/dropins/pydev/eclipse/plugins
+BUNDLES_INFO= ${PREFIX}/lib/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info
+COMPONENTS= com com.analysis com.codecompletion com.debug com.fastparser com.refactoring \
+ org org.ast org.core org.customizations org.debug org.django org.help org.jython org.parser org.red_core org.refactoring
post-install:
- @# Update the bundles.info...
- @${LOCALBASE}/bin/eclipse -consoleLog -initialize
- @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} "===> Updating ${BUNDLES_INFO}"
+.for d in com org
+. for c in ${COMPONENTS:M${d}*}
+ @${ECHO_CMD} "${d}.${REVDOM}${c:S,${d},,},${PORTVERSION}.${DISTDATE},${PLUGINDIR}/${d}.${REVDOM}${c:S,${d},,}_${PORTVERSION}.${DISTDATE}/,4,false" >> ${BUNDLES_INFO}
+. endfor
+.endfor
+ @(${SORT} ${BUNDLES_INFO} > ${BUNDLES_INFO}.sort) && \
+ ${MV} ${BUNDLES_INFO}.sort ${BUNDLES_INFO}
+ ${CAT} ${PKGMESSAGE}
add-plist-post:
@${ECHO_CMD} "@exec ${MKDIR} %D/share/eclipse/dropins/${PORTNAME}/eclipse/plugins/com.python.pydev.codecompletion_${PORTVERSION}.${DISTDATE}/icons" >> ${TMPPLIST}
- @${ECHO_CMD} "@exec ${LOCALBASE}/bin/eclipse -consoleLog -initialize" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ${LOCALBASE}/bin/eclipse -consoleLog -initialize" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ${SED} -i '' -E '/^((org)|(com))\.python\.pydev/d' %D/lib/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info" >> ${TMPPLIST}
.include "${PORTSDIR}/java/eclipse/Makefile.plugins"
diff --git a/java/eclipse-pydev/files/pkg-install.in b/java/eclipse-pydev/files/pkg-install.in
new file mode 100644
index 000000000000..a0f826dacdcf
--- /dev/null
+++ b/java/eclipse-pydev/files/pkg-install.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+if [ $# -ne 2 ]; then
+ echo "usage: $0 distname { POST-INSTALL }" >&2
+ exit 1
+fi
+
+PATH="/bin:/sbin:/usr/bin:/usr/sbin"
+
+BUNDLES_INFO=%%BUNDLES_INFO%%
+DISTDATE=%%DISTDATE%%
+PLUGINDIR=%%PLUGINDIR%%
+PORTVERSION=%%PORTVERSION%%
+REVDOM=python.pydev
+
+if [ "$2" = "POST-INSTALL" ]; then
+ echo "===> Updating ${BUNDLES_INFO}"
+ for c in '' '.analysis' '.codecompletion' '.debug' '.fastparser' '.refactoring'; do
+ echo "com.${REVDOM}${c},${PORTVERSION}.${DISTDATE},${PLUGINDIR}/com.${REVDOM}${c}_${PORTVERSION}.${DISTDATE}/,4,false" >> ${BUNDLES_INFO}
+ done
+ for c in '' '.ast' '.core' '.customizations' '.debug' '.django' '.help' '.jython' '.parser' '.red_core' '.refactoring'; do
+ echo "org.${REVDOM}${c},${PORTVERSION}.${DISTDATE},${PLUGINDIR}/org.${REVDOM}${c}_${PORTVERSION}.${DISTDATE}/,4,false" >> ${BUNDLES_INFO}
+ done
+ sort ${BUNDLES_INFO} > ${BUNDLES_INFO}.sort && \
+ mv ${BUNDLES_INFO}.sort ${BUNDLES_INFO}
+fi
+
+exit 0
diff --git a/java/eclipse-pydev/pkg-message b/java/eclipse-pydev/pkg-message
index af8812268c07..625bab898943 100644
--- a/java/eclipse-pydev/pkg-message
+++ b/java/eclipse-pydev/pkg-message
@@ -1,8 +1,13 @@
-
*********************************************************************
The first time, run Eclipse with the option -clean, and configure
a Python or Jython interpreter in Window -> Preferences -> PyDev
-> Interpreter before creating a new Pydev project
+ If you don't see the Pydev perspective in Eclipse, run the command
+
+ eclipse -consoleLog -initialize
+
+ as root or sudoer.
+
*********************************************************************