aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-pydev
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2008-01-23 10:33:41 +0000
committerNicola Vitale <nivit@FreeBSD.org>2008-01-23 10:33:41 +0000
commitf5fa428d52129fb3d50fe0b6757873ea1caad208 (patch)
treec4cb5073782a678cf03dd0c0610667f99d9f073e /java/eclipse-pydev
parentdefd4ca82fcdc14ecf7c25822865549c567c1140 (diff)
downloadports-f5fa428d52129fb3d50fe0b6757873ea1caad208.tar.gz
ports-f5fa428d52129fb3d50fe0b6757873ea1caad208.zip
PyDev is a plugin that enables users to use Eclipse for Python and Jython
development -- making Eclipse a first class Python IDE -- It comes with many goodies such as code completion, syntax highlighting, syntax analysis, refactor, debug and many others. WWW: http://pydev.sourceforge.net/
Notes
Notes: svn path=/head/; revision=206056
Diffstat (limited to 'java/eclipse-pydev')
-rw-r--r--java/eclipse-pydev/Makefile42
-rw-r--r--java/eclipse-pydev/distinfo3
-rw-r--r--java/eclipse-pydev/pkg-descr6
-rw-r--r--java/eclipse-pydev/pkg-message8
4 files changed, 59 insertions, 0 deletions
diff --git a/java/eclipse-pydev/Makefile b/java/eclipse-pydev/Makefile
new file mode 100644
index 000000000000..4146b524d69b
--- /dev/null
+++ b/java/eclipse-pydev/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: eclipse-pydev
+# Date created: 2007-11-16
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pydev
+PORTVERSION= 1.3.11
+#PORTREVISION= 0
+#PORTEPOCH= 0
+CATEGORIES= java devel python
+MASTER_SITES= SF
+PKGNAMEPREFIX= eclipse-
+DISTFILES= org.python.pydev.feature-${PORTVERSION:S,.,_,g}.zip
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Eclipse plugin for Python and Jython development
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+
+JAVA_OS= native
+JAVA_VENDOR= bsdjava
+JAVA_VERSION= 1.5+
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+USE_JAVA= yes
+USE_ZIP= yes
+
+do-install:
+ @cd ${WRKDIR} && ${CP} -R eclipse ${PREFIX}/;
+
+post-install:
+ @cd ${WRKDIR}; \
+ ${ECHO_CMD} "@comment pkg-plist automatically generated" >> ${TMPPLIST}; \
+ ${FIND} -s eclipse -type f -exec ${ECHO_CMD} {} ";" >> ${TMPPLIST}; \
+ ${FIND} -s eclipse -type d | ${SORT} -r | ${GREP} -vE '^eclipse$$|^eclipse/plugins$$|^eclipse/features$$' | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST};
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-pydev/distinfo b/java/eclipse-pydev/distinfo
new file mode 100644
index 000000000000..106fb1b6e2ea
--- /dev/null
+++ b/java/eclipse-pydev/distinfo
@@ -0,0 +1,3 @@
+MD5 (org.python.pydev.feature-1_3_11.zip) = 03355d71db4e4595571492fe62fc331e
+SHA256 (org.python.pydev.feature-1_3_11.zip) = dfc3403b8e0214e37f3fa47b6558ea74ccca10b4bb31451b8579531d36d8c2a0
+SIZE (org.python.pydev.feature-1_3_11.zip) = 3887928
diff --git a/java/eclipse-pydev/pkg-descr b/java/eclipse-pydev/pkg-descr
new file mode 100644
index 000000000000..c8eea650b4f8
--- /dev/null
+++ b/java/eclipse-pydev/pkg-descr
@@ -0,0 +1,6 @@
+PyDev is a plugin that enables users to use Eclipse for Python and Jython
+development -- making Eclipse a first class Python IDE -- It comes with
+many goodies such as code completion, syntax highlighting, syntax analysis,
+refactor, debug and many others.
+
+WWW: http://pydev.sourceforge.net/
diff --git a/java/eclipse-pydev/pkg-message b/java/eclipse-pydev/pkg-message
new file mode 100644
index 000000000000..5eef330c4e0e
--- /dev/null
+++ b/java/eclipse-pydev/pkg-message
@@ -0,0 +1,8 @@
+
+*********************************************************************
+
+ The first time, run Eclipse with the option -clean, and configure
+ a Python or Jython interpreter in Window -> Preferences -> PyDev
+ before creating a new Pydev project
+
+*********************************************************************