aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-shelled
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-17 09:22:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-17 09:22:03 +0000
commitedb0d29c16ebf08b9e9e4f5e16ce99c3f4d54bd8 (patch)
treed6f8911b173697efd9ee24a2fb196a8b6d7ecede /java/eclipse-shelled
parent276a8d49e09517f6bdd4f7e9029da32476713a05 (diff)
downloadports-edb0d29c16ebf08b9e9e4f5e16ce99c3f4d54bd8.tar.gz
ports-edb0d29c16ebf08b9e9e4f5e16ce99c3f4d54bd8.zip
ShellEd is a superb shell script editor for Eclipse. The great benefit of
this plugin is the integration of man page information for content assist and text hover. WWW: http://sourceforge.net/projects/shelled PR: ports/117174 Submitted by: Sutra Zhou <zhoushuqun at gmail.com>
Notes
Notes: svn path=/head/; revision=201602
Diffstat (limited to 'java/eclipse-shelled')
-rw-r--r--java/eclipse-shelled/Makefile44
-rw-r--r--java/eclipse-shelled/distinfo3
-rw-r--r--java/eclipse-shelled/pkg-descr5
3 files changed, 52 insertions, 0 deletions
diff --git a/java/eclipse-shelled/Makefile b/java/eclipse-shelled/Makefile
new file mode 100644
index 000000000000..66f41a4420e8
--- /dev/null
+++ b/java/eclipse-shelled/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: eclipse-shelled
+# Date created: 14 October 2007
+# Whom: Sutra Zhou <zhoushuqun@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ShellEd
+PORTVERSION= 1.0.2a
+CATEGORIES= java devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= shelled
+PKGNAMEPREFIX= eclipse-
+DISTNAME= shelled_${PORTVERSION}
+DIST_SUBDIR= eclipse
+
+MAINTAINER= zhoushuqun@gmail.com
+COMMENT= ShellEd is a superb shell script editor for Eclipse
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+
+do-install:
+ @${MKDIR} ${WRKSRC}/eclipse
+ @${MV} ${WRKSRC}/plugins ${WRKSRC}/eclipse/plugins
+ @${MV} ${WRKSRC}/features ${WRKSRC}/eclipse/features
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+ @${MV} ${WRKSRC}/eclipse/plugins ${WRKSRC}/plugins
+ @${MV} ${WRKSRC}/eclipse/features ${WRKSRC}/features
+ @${RM} -rf ${WRKSRC}/eclipse
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-shelled/distinfo b/java/eclipse-shelled/distinfo
new file mode 100644
index 000000000000..ad8cedbcd1b3
--- /dev/null
+++ b/java/eclipse-shelled/distinfo
@@ -0,0 +1,3 @@
+MD5 (eclipse/shelled_1.0.2a.zip) = c25058bc8aa1755b3fa84f62eaab2d7f
+SHA256 (eclipse/shelled_1.0.2a.zip) = 0da01fed1be9454dcef6c5b9afa5f592d1834bbaa8f1b911caeae191f3d3e0dc
+SIZE (eclipse/shelled_1.0.2a.zip) = 4447390
diff --git a/java/eclipse-shelled/pkg-descr b/java/eclipse-shelled/pkg-descr
new file mode 100644
index 000000000000..a6a367bfe38d
--- /dev/null
+++ b/java/eclipse-shelled/pkg-descr
@@ -0,0 +1,5 @@
+ShellEd is a superb shell script editor for Eclipse. The great benefit of
+this plugin is the integration of man page information for content assist
+and text hover.
+
+WWW: http://sourceforge.net/projects/shelled