aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-16 22:58:16 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-06-16 22:58:16 +0000
commit69a055bbed852297fc76d708ebb2d67e6d70a6bb (patch)
treed82701fc31e6e8da2131591bfff14841477b87f4 /java/eclipse
parentf8dfec2cb40622e4caae1f721599befeea0ea5c0 (diff)
downloadports-69a055bbed852297fc76d708ebb2d67e6d70a6bb.tar.gz
ports-69a055bbed852297fc76d708ebb2d67e6d70a6bb.zip
java/eclipse: fix build
Require new GCC to build this port on GCC architectures. PR: 238489 Approved by: jonc@chen.org.nz (maintainer), tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D20667
Notes
Notes: svn path=/head/; revision=504379
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile4
-rw-r--r--java/eclipse/files/patch-eclipse.platform.swt5
2 files changed, 3 insertions, 6 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 1f0b21cb2a0a..2cd9406742f2 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -54,7 +54,7 @@ BUILD_DEPENDS= git:devel/git-lite \
${LOCALBASE}/share/java/maven/bin/mvn:devel/maven
LIB_DEPENDS= libsecret-1.so:security/libsecret \
libwebkit2gtk-4.0.so:www/webkit2-gtk3
-USES= gmake pkgconfig gnome
+USES= compiler:c++11-lang gmake pkgconfig gnome
USE_GNOME= gtk30
USE_GITHUB= yes
@@ -74,7 +74,7 @@ DESKTOP_ENTRIES="Eclipse" \
SUB_FILES= ${PORTNAME}
-MAVEN_ENV= MAVEN_OPTS=-Xmx1024m
+MAVEN_ENV= MAVEN_OPTS=-Xmx1024m CC=${CC}
MAVEN_REPO= -Dmaven.repo.local=${WRKDIR}/${GH_PROJECT}-${PORTVERSION}
MAVEN_ECLIPSE= -Dnative=gtk.freebsd.${ARCH} -Dcomparator.repo=file://${WRKDIR}/${GH_PROJECT}-${PORTVERSION}/p2-stub -DforceContextQualifier=v${ECLIPSE_TSTAMP}
diff --git a/java/eclipse/files/patch-eclipse.platform.swt b/java/eclipse/files/patch-eclipse.platform.swt
index ae14686cb214..d02a24c7f451 100644
--- a/java/eclipse/files/patch-eclipse.platform.swt
+++ b/java/eclipse/files/patch-eclipse.platform.swt
@@ -74,14 +74,11 @@ diff -ru eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT PI/gtk/library
*)
SWT_ARCH=$MODEL
AWT_ARCH=$MODEL
-@@ -118,6 +116,16 @@
+@@ -118,6 +116,13 @@
esac
case $SWT_OS.$SWT_ARCH in
+ "freebsd.ppc64")
-+ if [ "${CC}" = "" ]; then
-+ export CC=gcc
-+ fi
+ if [ "${JAVA_HOME}" = "" ]; then
+ DYNAMIC_JAVA_HOME=`readlink -f /usr/local/bin/java | sed "s:jre/::" | sed "s:bin/java::"`
+ JAVA_HOME = $DYNAMIC_JAVA_HOME