aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-04-14 11:59:58 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-04-14 11:59:58 +0000
commit8b76c85ac4be40b598ba238683abceaf6f8bc71b (patch)
treed1d782f82ed2b4495aa4fa2f2701c337d0b48361 /java/eclipse
parent49848bd914531f80e998d3111ca4bfbbb8c5d4cb (diff)
downloadports-8b76c85ac4be40b598ba238683abceaf6f8bc71b.tar.gz
ports-8b76c85ac4be40b598ba238683abceaf6f8bc71b.zip
java/eclipse: re-add Makefile.plugins to restore build for some ports
PR: 237280 Submitted by: Jonathan Chen <jonc@chen.org.nz>
Notes
Notes: svn path=/head/; revision=498895
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile.plugins12
1 files changed, 12 insertions, 0 deletions
diff --git a/java/eclipse/Makefile.plugins b/java/eclipse/Makefile.plugins
new file mode 100644
index 000000000000..19a025d0551a
--- /dev/null
+++ b/java/eclipse/Makefile.plugins
@@ -0,0 +1,12 @@
+# $FreeBSD$
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.8+
+
+REPO_DIRS?= features plugins
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse
+ @(cd ${WRKSRC}; ${COPYTREE_SHARE} "${REPO_DIRS}" ${STAGEDIR}${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse/)
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} -s share/eclipse/dropins/${PORTNAME} -not -type d) >> ${TMPPLIST}
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} -s -d share/eclipse/dropins/${PORTNAME} -type d -empty) | ${SED} -ne 's,^,@dir ,p' >> ${TMPPLIST}