aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-09-08 07:27:31 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-09-08 07:27:31 +0000
commit9e13376faeeb76606be834230dcfbf498d8133db (patch)
tree7df67bc58abf6363b63cf4fbefb77714db5a748c /java/eclipse
parenta31ffd53c74b29aeec8b216ddd372e7d546f1c11 (diff)
downloadports-9e13376faeeb76606be834230dcfbf498d8133db.tar.gz
ports-9e13376faeeb76606be834230dcfbf498d8133db.zip
java/eclipse: usablity patch for webkit2-gtk3 issues
- usability patch for PR:238844 (not a fix, but keeps Eclipse usable) - use github.com servers in preference to git.eclipse.org for distfiles PR: 240383 Submitted by: Jonathan Chen <jonc@chen.org.nz> (maintainer)
Notes
Notes: svn path=/head/; revision=511553
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile5
-rw-r--r--java/eclipse/files/patch-eclipse.platform.swt12
2 files changed, 15 insertions, 2 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index e3b31cc82b93..6139e6eaada9 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -3,6 +3,7 @@
PORTNAME= eclipse
PORTVERSION= 4.12
+PORTREVISION= 1
CATEGORIES= java devel
# Update to git-tag on git.eclipse.org
@@ -37,8 +38,8 @@ ECLIPSE_MODULES=jdt/eclipse.jdt \
equinox/rt.equinox.p2
# Each Eclipse module has its own MASTER_SITE
.for M in ${ECLIPSE_MODULES}
-MASTER_SITES+= https://git.eclipse.org/c/${M}.git/snapshot/:${M:C/[\.\/]//g} \
- https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${PORTVERSION}/:${M:C/[\.\/]//g}
+MASTER_SITES+= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${PORTVERSION}/:${M:C/[\.\/]//g} \
+ https://git.eclipse.org/c/${M}.git/snapshot/:${M:C/[\.\/]//g}
DISTFILES+= ${M:C/.*\///}-${ECLIPSE_SUFX}:${M:C/[\.\/]//g}
.endfor
diff --git a/java/eclipse/files/patch-eclipse.platform.swt b/java/eclipse/files/patch-eclipse.platform.swt
index 8d57e331eed0..c71e4f916b59 100644
--- a/java/eclipse/files/patch-eclipse.platform.swt
+++ b/java/eclipse/files/patch-eclipse.platform.swt
@@ -159,6 +159,18 @@ diff -ru eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT PI/gtk/org/ecl
if (osName.startsWith("Windows")) isWin32 = true;
IsLinux = isLinux; IsWin32 = isWin32;
+diff -ru eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT WebKit/gtk/org/eclipse/swt/browser/WebKit.java eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT WebKit/gtk/org/eclipse/swt/browser/WebKit.java
+--- eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT WebKit/gtk/org/eclipse/swt/browser/WebKit.java 0000-00-00 00:00:00.000000000 +0000
++++ eclipse.platform.swt/bundles/org.eclipse.swt/Eclipse SWT WebKit/gtk/org/eclipse/swt/browser/WebKit.java 0000-00-00 00:00:00.000000000 +0000
+@@ -155,7 +155,7 @@
+ * https://www.nczonline.net/blog/2009/01/05/what-determines-that-a-script-is-long-running/
+ * https://stackoverflow.com/questions/3030024/maximum-execution-time-for-javascript
+ */
+- static final int ASYNC_EXEC_TIMEOUT_MS = 10000; // Webkit2.
++ static final int ASYNC_EXEC_TIMEOUT_MS = 100; // Dirty hack for webkit issues on FreeBSD
+
+ static boolean bug522733FirstInstanceCreated = false; //Webkit2 workaround for Bug 522733
+
diff -ru eclipse.platform.swt/bundles/org.eclipse.swt/META-INF/p2.inf eclipse.platform.swt/bundles/org.eclipse.swt/META-INF/p2.inf
--- eclipse.platform.swt/bundles/org.eclipse.swt/META-INF/p2.inf 0000-00-00 00:00:00.000000000 +0000
+++ eclipse.platform.swt/bundles/org.eclipse.swt/META-INF/p2.inf 0000-00-00 00:00:00.000000000 +0000