aboutsummaryrefslogtreecommitdiff
path: root/java/eclipseme/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-03-18 01:00:25 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-03-18 01:00:25 +0000
commite7ef8ac1e87f3c9e30799c44643007229d36fcc9 (patch)
tree21cb6b94c2368b6b8210d7dc0588e0636abd3d5a /java/eclipseme/Makefile
parentd42fb3f6d7cf2dd26640a692aa9971c39efe63aa (diff)
Notes
Diffstat (limited to 'java/eclipseme/Makefile')
-rw-r--r--java/eclipseme/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/java/eclipseme/Makefile b/java/eclipseme/Makefile
index 2e8c67b38261..4545e70c7304 100644
--- a/java/eclipseme/Makefile
+++ b/java/eclipseme/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= eclipseme
-PORTVERSION= 0.4.5
-PORTREVISION= 3
+PORTVERSION= 0.4.6
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= eclipse
@@ -31,11 +29,10 @@ RUN_DEPENDS+= ${LOCALBASE}/share/proguard/lib/proguard.jar:${PORTSDIR}/java/prog
.endif
do-install:
- @${CP} -r ${WRKSRC}/${PORTNAME}_${PORTVERSION} ${PREFIX}/eclipse/plugins/
+ @${MKDIR} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC}/${PORTNAME}_${PORTVERSION} ${PREFIX}/eclipse/plugins/
post-install:
- @${SED} -e 's,%%PREFIX%%,${APP_HOME},' \
- < ${.CURDIR}/pkg-message > ${PKGMESSAGE}
- @${CAT} ${PKGMESSAGE}
+ @${CAT} ./pkg-message | ${SED} -e 's|%%PREFIX%%|${APP_HOME}|'
.include <bsd.port.mk>