aboutsummaryrefslogtreecommitdiff
path: root/java/icedtea-web
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-07 11:15:43 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-07 11:15:43 +0000
commit1388dc54c94c6aa80065575a70fb648c8b9147d1 (patch)
tree73fca418fbb9b6084a472e874c978b3e45aedb45 /java/icedtea-web
parentc29c30e0face0b34b60c8908bc951ccfc143265e (diff)
downloadports-1388dc54c94c6aa80065575a70fb648c8b9147d1.tar.gz
ports-1388dc54c94c6aa80065575a70fb648c8b9147d1.zip
Attempt to unbreak java/icedtea-web
- Bring back the PLUGIN option. The build needs the 4 NPAPI headers. Extract them from libxul-45.9.0_12 to a separate distfile and point the build to them. PR: 229242 Approved by: java (maintainer timeout, 2 weeks)
Notes
Notes: svn path=/head/; revision=474073
Diffstat (limited to 'java/icedtea-web')
-rw-r--r--java/icedtea-web/Makefile20
-rw-r--r--java/icedtea-web/distinfo3
-rw-r--r--java/icedtea-web/pkg-plist2
3 files changed, 22 insertions, 3 deletions
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index 0850020d391c..a9f39513d234 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -2,17 +2,17 @@
PORTNAME= icedtea-web
PORTVERSION= 1.6.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= java www
MASTER_SITES= http://icedtea.wildebeest.org/download/source/ \
http://icedtea.classpath.org/download/source/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= java@FreeBSD.org
COMMENT= Free Java plug-in and Java Web Start for OpenJDK
LICENSE= GPLv2
-BROKEN= Does not configure: "Package 'mozilla-plugin', required by 'virtual:world', not found"
BUILD_DEPENDS= zip:archivers/zip \
bash:shells/bash \
gsed:textproc/gsed
@@ -43,9 +43,11 @@ CONFIGURE_SHELL= ${bash_CMD}
TEST_TARGET= check
-OPTIONS_DEFINE= DOCS RHINO TAGSOUP
+OPTIONS_DEFINE= DOCS PLUGIN RHINO TAGSOUP
+OPTIONS_DEFAULT=PLUGIN
OPTIONS_SUB= yes
+PLUGIN_DESC= Enable the browser plug-in
RHINO_DESC= Add support for Proxy Auto Config files
TAGSOUP_DESC= Enable cleaning up of malformed JNLP files
@@ -62,6 +64,18 @@ TAGSOUP_RUN_DEPENDS= ${TAGSOUP_BUILD_DEPENDS}
TAGSOUP_VARS= TAGSOUP_JAR="${JAVALIBDIR}/tagsoup.jar"
TAGSOUP_VARS_OFF= TAGSOUP_JAR=no
+PLUGIN_CONFIGURE_ENABLE=plugin
+PLUGIN_CONFIGURE_ENV= MOZILLA_CFLAGS="-I${WRKDIR}/npapi-headers -DXP_UNIX" \
+ MOZILLA_LIBS=" " # needs to be set and non-empty!
+PLUGIN_DISTFILES= npapi-headers${EXTRACT_SUFX}:npapi
+PLUGIN_MASTER_SITES= LOCAL/tobik:npapi
+PLUGIN_PORTDOCS= plugin
+PLUGIN_TEST_TARGET= plugin-tests
+PLUGIN_USE= GNOME=glib20
+PLUGIN_USES= webplugin:native
+PLUGIN_VARS= WEBPLUGIN_DIR=${PREFIX}/lib \
+ WEBPLUGIN_FILES=IcedTeaPlugin.so
+
HAMCREST_JAR= ${JAVALIBDIR}/hamcrest.jar
JUNIT_JAR= ${JAVALIBDIR}/junit.jar
diff --git a/java/icedtea-web/distinfo b/java/icedtea-web/distinfo
index 07cb438f8273..9cf7d78c62f5 100644
--- a/java/icedtea-web/distinfo
+++ b/java/icedtea-web/distinfo
@@ -1,2 +1,5 @@
+TIMESTAMP = 1529752635
SHA256 (icedtea-web-1.6.2.tar.gz) = ce67034096d6b960e2b6cfb5c41a7bd6b30eb2ec7f13bf3ecdb477ff6ce69300
SIZE (icedtea-web-1.6.2.tar.gz) = 1824557
+SHA256 (npapi-headers.tar.gz) = 625d86955aef95c7a0a4c192bb51a1e7833d30c2d53e390d07f97abd835744f8
+SIZE (npapi-headers.tar.gz) = 15637
diff --git a/java/icedtea-web/pkg-plist b/java/icedtea-web/pkg-plist
index 972cc445ebfa..7a8f05ab770a 100644
--- a/java/icedtea-web/pkg-plist
+++ b/java/icedtea-web/pkg-plist
@@ -1,6 +1,7 @@
bin/itweb-javaws
bin/itweb-policyeditor
bin/itweb-settings
+%%PLUGIN%%%%WEBPLUGIN_DIR%%/IcedTeaPlugin.so
man/cs/man1/icedtea-web-plugin.1.gz
man/cs/man1/icedtea-web.1.gz
man/cs/man1/itweb-javaws.1.gz
@@ -26,4 +27,5 @@ share/applications/itweb-policyeditor.desktop
share/applications/itweb-settings.desktop
%%DATADIR%%/javaws_splash.png
%%DATADIR%%/netx.jar
+%%PLUGIN%%%%DATADIR%%/plugin.jar
share/pixmaps/itweb-javaws.png