aboutsummaryrefslogtreecommitdiff
path: root/java/java3d
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-29 22:21:58 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-29 22:21:58 +0000
commit88686440b03559aa74f098849c09350572b62d8c (patch)
treea3e3b3db93c20d25d3c1be8f6c6f160827d475f4 /java/java3d
parente9284d20a8e55bbc15a4834963b26cec57fdcdb8 (diff)
downloadports-88686440b03559aa74f098849c09350572b62d8c.tar.gz
ports-88686440b03559aa74f098849c09350572b62d8c.zip
java/java3d: fix build on GCC architectures
Use C11 compiler: [exec] from /wrkdirs/usr/ports/java/java3d/work/java3d-1.5.2/j3d-core/src/native/ogl/Canvas3D.c:47: [exec] /usr/local/include/GL/glext.h:469: error: redefinition of typedef 'GLsizeiptr' [exec] /wrkdirs/usr/ports/java/java3d/work/java3d-1.5.2/j3d-core/src/native/ogl/gldefs.h:70: error: previous declaration of 'GLsizeiptr' was here
Notes
Notes: svn path=/head/; revision=553649
Diffstat (limited to 'java/java3d')
-rw-r--r--java/java3d/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/java/java3d/Makefile b/java/java3d/Makefile
index 2e73457a88f1..b3bf1a57bc68 100644
--- a/java/java3d/Makefile
+++ b/java/java3d/Makefile
@@ -17,7 +17,7 @@ BROKEN_aarch64= fails to compile: GVector.java:168: bad use of '>'
BROKEN_armv6= fails to compile: build.xml: Compile failed; see the compiler error output for details
BROKEN_armv7= fails to compile: build.xml: Compile failed; see the compiler error output for details
-USES= gl tar:bzip2 xorg
+USES= compiler:c11 gl tar:bzip2 xorg
USE_JAVA= 8
USE_GL= gl
USE_XORG= xt