aboutsummaryrefslogtreecommitdiff
path: root/java/javavmwrapper
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2011-07-21 05:03:02 +0000
committerMark Linimon <linimon@FreeBSD.org>2011-07-21 05:03:02 +0000
commit06e66777937202f04d646d24d24f524b13d79478 (patch)
tree85a44213b1929b12051c17091ea4ad53f819456b /java/javavmwrapper
parent63d4112e2e682002806fc4c52da2481ae7f045e7 (diff)
downloadports-06e66777937202f04d646d24d24f524b13d79478.tar.gz
ports-06e66777937202f04d646d24d24f524b13d79478.zip
Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,
remove support for them from bsd.java.mk. As Jikes is not available in Java 1.5 or higher, remove it from bsd.java.mk too (suggested by hq@) and from the ports which used it (only occurences were USE_JIKES=no). Support for the Blackdown VM is also removed, as it is not available in Java 1.5 and higher. Also remove the mapping from Java 1.1-1.4 to Java 1.5+ in bsd.java.mk to detect old, broken ports; therefore bump the minimal value of JAVA_VERSION to 1.5. While here, replace static values of JAVA_VERSION in files/*.in by %%JAVA_VERSION%% . PR: ports/158969 Submitted by: rene Tested on: pointyhat-west -exp
Notes
Notes: svn path=/head/; revision=278068
Diffstat (limited to 'java/javavmwrapper')
-rw-r--r--java/javavmwrapper/src/javavm.117
-rw-r--r--java/javavmwrapper/src/manvm.19
2 files changed, 4 insertions, 22 deletions
diff --git a/java/javavmwrapper/src/javavm.1 b/java/javavmwrapper/src/javavm.1
index d10f3ce8b4ab..d2095bc6ec41 100644
--- a/java/javavmwrapper/src/javavm.1
+++ b/java/javavmwrapper/src/javavm.1
@@ -99,7 +99,6 @@ A space delimited list of Java VM vendors.
The selected Java VM must have been released by one of the vendors in the list.
.Pp
Currently allowed vendors are
-.Ql blackdown ,
.Ql bsdjava ,
.Ql freebsd ,
.Ql ibm ,
@@ -114,14 +113,6 @@ to a version, any Java VM with a version greater than or
equal to the given version will be used.
.Pp
Currently allowed versions are
-.Ql 1.1 ,
-.Ql 1.1+ ,
-.Ql 1.2 ,
-.Ql 1.2+ ,
-.Ql 1.3 ,
-.Ql 1.3+ ,
-.Ql 1.4 ,
-.Ql 1.4+ ,
.Ql 1.5 ,
.Ql 1.5+ ,
.Ql 1.6 ,
@@ -178,16 +169,16 @@ Execute the most up to date and
.Dq native
Java VM registered with
.Nm .
-.It Ev JAVA_VERSION=1.4+ Pa %%LOCALBASE%%/bin/javac MyClass.java
+.It Ev JAVA_VERSION=1.5+ Pa %%LOCALBASE%%/bin/javac MyClass.java
Compile MyClass.java with a registered Java VM's javac that is at least
-version 1.4.
+version 1.5.
.It Ev JAVA_OS=native Pa %%LOCALBASE%%/bin/java Fl jar Pa MyApp.jar
Execute MyApp with the most up to date native Java VM that is registered
with
.Nm .
This is necessary if MyApp uses JNI, for instance.
-.It Ev JAVA_VERSION="1.2 1.4" Pa %%LOCALBASE%%/bin/java Fl jar Pa MyApp.jar
-Execute MyApp with either a Java VM that is either version 1.2 or version 1.4.
+.It Ev JAVA_VERSION="1.5 1.7" Pa %%LOCALBASE%%/bin/java Fl jar Pa MyApp.jar
+Execute MyApp with either a Java VM that is either version 1.5 or version 1.7.
.It Ev JAVAVM_DRYRUN=yes Pa %%LOCALBASE%%/bin/java
Don't invoke the Java VM, but print out information about what would have
been done.
diff --git a/java/javavmwrapper/src/manvm.1 b/java/javavmwrapper/src/manvm.1
index a288d0dc5286..f6781a1b5d25 100644
--- a/java/javavmwrapper/src/manvm.1
+++ b/java/javavmwrapper/src/manvm.1
@@ -86,7 +86,6 @@ The on-line manual pages to be displayed must come from a Java VM that has
been released by one of the vendors in the list.
.Pp
Currently allowed vendors are
-.Ql blackdown ,
.Ql bsdjava ,
.Ql freebsd ,
.Ql ibm ,
@@ -102,14 +101,6 @@ to a version, the on-line manual pages from any Java VM with a version
greater than or equal to the given version will be used.
.Pp
Currently allowed versions are
-.Ql 1.1 ,
-.Ql 1.1+ ,
-.Ql 1.2 ,
-.Ql 1.2+ ,
-.Ql 1.3 ,
-.Ql 1.3+ ,
-.Ql 1.4 ,
-.Ql 1.4+ ,
.Ql 1.5 ,
.Ql 1.5+ ,
.Ql 1.6 ,