aboutsummaryrefslogtreecommitdiff
path: root/java/javavmwrapper
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-04-12 16:07:21 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-04-12 16:07:21 +0000
commit3d485a44fb7bc9ddd23ccc6eccc25ef2598b735f (patch)
treef71d3ca17c39db348385bd0b4c08413955516a7c /java/javavmwrapper
parent76e33afbcb6c5b2cd8575e098fab5677b6a202a9 (diff)
downloadports-3d485a44fb7bc9ddd23ccc6eccc25ef2598b735f.tar.gz
ports-3d485a44fb7bc9ddd23ccc6eccc25ef2598b735f.zip
. Fix some sentence breaks.
. Add some more details on how javavmwrapper selects the VM. [2] Suggested by: hq [2]
Notes
Notes: svn path=/head/; revision=133155
Diffstat (limited to 'java/javavmwrapper')
-rw-r--r--java/javavmwrapper/Makefile1
-rw-r--r--java/javavmwrapper/src/javavm.134
2 files changed, 29 insertions, 6 deletions
diff --git a/java/javavmwrapper/Makefile b/java/javavmwrapper/Makefile
index bfe2f5112b76..fa5cf828819d 100644
--- a/java/javavmwrapper/Makefile
+++ b/java/javavmwrapper/Makefile
@@ -47,6 +47,7 @@ do-configure:
.for _man in checkvms.1 javavm.1 registervm.1 ${MAN5}
${SED} -e 's|%%PREFIX%%|${PREFIX}|;' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|;' \
+ -e 's|%%PORTSDIR%%|${PORTSDIR}|;' \
${SRC}/${_man} > ${WRKDIR}/${_man}
.endfor
diff --git a/java/javavmwrapper/src/javavm.1 b/java/javavmwrapper/src/javavm.1
index 1cab7f58e2c9..b41c371e7176 100644
--- a/java/javavmwrapper/src/javavm.1
+++ b/java/javavmwrapper/src/javavm.1
@@ -56,6 +56,13 @@ a given symbolic link is used, invoking and passing the arguments to the
matching executable within the chosen Java VM.
The choice of Java VM may also be influenced by using environment variables
to constrain the version, vendor and operating system of the Java VM.
+.Pp
+This selection process is usually achieved through the use of
+%%PORTSDIR%%/Mk/bsd.java.mk.
+However, if this is not present then
+.Nm
+will use its own internal selection process which is
+designed to behave almost identically.
.Sh ENVIRONMENT
.Bl -tag -width indent
.It JAVA_HOME
@@ -69,19 +76,20 @@ This variable is set by
when executing the actual Java VM and will be available to it and all of
its child processes.
.It JAVA_OS
-A space delimited list of operating systems. The selected Java VM must
-have been created for one of the operating systems in the list.
+A space delimited list of operating systems.
+The selected Java VM must have been created for one of the operating systems
+in the list.
.Pp
Currently allowed operating system values are "native" and "linux".
.It JAVA_VENDOR
-A space delimited list of Java VM vendors. The selected Java VM must
-have been released by one of the vendors in the list.
+A space delimited list of Java VM vendors.
+The selected Java VM must have been released by one of the vendors in the list.
.Pp
Currently allowed vendors are "bsdjava", "freebsd", "blackdown", "ibm"
and "sun".
.It JAVA_VERSION
-A space delimited list of versions of the Java VM that may be used. By
-appending a '+' to a version, any Java VM with a version greater than or
+A space delimited list of versions of the Java VM that may be used.
+By appending a '+' to a version, any Java VM with a version greater than or
equal to the given version will be used.
.Pp
Currently allowed versions are 1.1, 1.1+, 1.2, 1.2+, 1.3, 1.3+, 1.4, 1.4+,
@@ -91,6 +99,10 @@ Currently allowed versions are 1.1, 1.1+, 1.2, 1.2+, 1.3, 1.3+, 1.4, 1.4+,
.Bl -tag -width indent
.It %%PREFIX%%/etc/javavms
The location of the Java VM wrapper configuration file.
+.It %%PORTSDIR%%/Mk/bsd.java.mk
+The file usually used, along with
+.Nm make ,
+to select the Java VM to be used.
.El
.Sh EXAMPLES
.Bl -tag -width indent
@@ -110,6 +122,16 @@ Execute MyApp with either a Java VM that is either version 1.2 or version 1.4.
.El
.Sh SEE ALSO
.Xr checkvms 1 ,
+.Xr make 1 ,
.Xr registervm 1 ,
.Xr unregistervm 1 ,
.Xr javavms 5
+.Sh BUGS
+The internal selection procedure of
+.Nm
+is not fully identical to that of %%PORTSDIR%%/Mk/bsd.java.mk.
+In particular,
+.Nm
+does not respect environment variables such as
+.Ev JAVA_PREFERRED_PORT
+which is used by %%PORTSDIR%%/Mk/bsd.java.mk.