aboutsummaryrefslogtreecommitdiff
path: root/java/jc
diff options
context:
space:
mode:
authorArchie Cobbs <archie@FreeBSD.org>2005-04-25 20:44:19 +0000
committerArchie Cobbs <archie@FreeBSD.org>2005-04-25 20:44:19 +0000
commit29533ff55f0917f410a889825208a9f3bc54ad60 (patch)
tree1ee5c1dff51006d84ce955083bccfe171f92095f /java/jc
parent4f4cc9175ea0427c50c6c3ca525a0f34ecb4ff1f (diff)
downloadports-29533ff55f0917f410a889825208a9f3bc54ad60.tar.gz
ports-29533ff55f0917f410a889825208a9f3bc54ad60.zip
Notes
Diffstat (limited to 'java/jc')
-rw-r--r--java/jc/Makefile7
-rw-r--r--java/jc/distinfo4
-rw-r--r--java/jc/pkg-descr15
3 files changed, 19 insertions, 7 deletions
diff --git a/java/jc/Makefile b/java/jc/Makefile
index b5a665ec4c48..6e7ba78a7dc1 100644
--- a/java/jc/Makefile
+++ b/java/jc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= jc
-PORTVERSION= 1.4.2
+PORTVERSION= 1.4.3
CATEGORIES= java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=jcvm/
@@ -16,15 +16,14 @@ COMMENT= JVM that converts class files to C source and compiles them with GCC
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
${LOCALBASE}/share/classpath/glibj.zip:${PORTSDIR}/java/classpath
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- ffi.2:${PORTSDIR}/devel/libffi
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
MAN1= jc.1
USE_LIBTOOL_VER=15
USE_JAVA= yes
USE_GMAKE= yes
-JAVA_BUILD= yes
+JAVA_BUILD= jre
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-classpath=${LOCALBASE}
diff --git a/java/jc/distinfo b/java/jc/distinfo
index a8233409bea2..fa3d5fec4d4b 100644
--- a/java/jc/distinfo
+++ b/java/jc/distinfo
@@ -1,2 +1,2 @@
-MD5 (jc-1.4.2.tar.gz) = 17dd43da4803fe90949cf8dc99b0d7c8
-SIZE (jc-1.4.2.tar.gz) = 34246309
+MD5 (jc-1.4.3.tar.gz) = 51ba1380dbe62be42c34df19e416afab
+SIZE (jc-1.4.3.tar.gz) = 34245731
diff --git a/java/jc/pkg-descr b/java/jc/pkg-descr
index a5355caaacb1..edf6a3e73859 100644
--- a/java/jc/pkg-descr
+++ b/java/jc/pkg-descr
@@ -3,6 +3,19 @@ files into C source files using the Soot Java bytecode analysis
framework, compiles them with GCC, and loads them using a built-in
ELF object file loader. JC utilizes the GNU Classpath class library
and provides a fairly complete Java runtime including sophisticated
-optimizations to increase runtime performance.
+optimizations to increase runtime performance. JC also includes a
+bytecode interpreter, and supports execution in either or mix ed
+modes.
+
+Although JC has good interpreter performance, JC doesn't try to be
+fast in every situation. Instead, JC focuses on this question: how
+fast can we go if we know some or all of the class files ahead of
+time? The answer is: very fast! Optimizations that are just too
+complex and expensive to perform at runtime are instead performed
+at code generation time. JC's code generator is written in Java,
+using the powerful Soot bytecode analysis framework. When combined
+with the proven power of GCC's C optimizer the results are impressive.
+As an additional benefit, JC contains very little architecture-specific
+code and is highly portable.
WWW: http://jcvm.sourceforge.net/