aboutsummaryrefslogtreecommitdiff
path: root/java/jd-gui
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-02-19 07:25:14 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-02-19 07:25:14 +0000
commit4377efce9daa1b2e0991d999fae307e460bf49b2 (patch)
tree226dea6650bdcd5ba54016a2431a886acdf34428 /java/jd-gui
parentfa42fcd66fa842383f81e50ac780a0e32c630cd6 (diff)
downloadports-4377efce9daa1b2e0991d999fae307e460bf49b2.tar.gz
ports-4377efce9daa1b2e0991d999fae307e460bf49b2.zip
New port: java/jd-gui
The Java Decompiler project aims to develop tools in order to decompile and analyze Java 5 byte code and later versions. JD-GUI is a standalone graphical utility that displays Java source codes of .class files. You can browse the reconstructed source code with the JD-GUI for instant access to methods and fields. WWW: http://jd.benow.ca/ PR: 206488 Submitted by: Tobias Kortkamp <t@tobik.med>
Notes
Notes: svn path=/head/; revision=409155
Diffstat (limited to 'java/jd-gui')
-rw-r--r--java/jd-gui/Makefile42
-rw-r--r--java/jd-gui/distinfo4
-rw-r--r--java/jd-gui/files/jd-gui.in2
-rw-r--r--java/jd-gui/files/patch-src_linux_resources_jd-gui.desktop10
-rw-r--r--java/jd-gui/pkg-descr8
5 files changed, 66 insertions, 0 deletions
diff --git a/java/jd-gui/Makefile b/java/jd-gui/Makefile
new file mode 100644
index 000000000000..6ccf0bcb7d3c
--- /dev/null
+++ b/java/jd-gui/Makefile
@@ -0,0 +1,42 @@
+# Created by: Tobias Kortkamp <t@tobik.me>
+# $FreeBSD$
+
+PORTNAME= jd-gui
+PORTVERSION= 1.4.0
+DISTVERSIONPREFIX= v
+CATEGORIES= java devel
+MASTER_SITES= GH:src \
+ https://github.com/java-decompiler/jd-gui/releases/download/v${PORTVERSION}/:jar
+DISTFILES= ${DISTNAME}.tar.gz:src \
+ jd-gui-${PORTVERSION}.jar:jar
+EXTRACT_ONLY= ${DISTNAME}.tar.gz
+
+MAINTAINER= t@tobik.me
+COMMENT= Java Decompiler GUI
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= java-decompiler
+
+USE_JAVA= yes
+JAVA_VERSION= 1.7+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= bin/jd-gui \
+ %%JAVAJARDIR%%/jd-gui.jar \
+ share/applications/jd-gui.desktop \
+ share/pixmaps/jd-gui.png
+
+SUB_FILES= jd-gui
+SUB_LIST= JAVAJARDIR="${JAVAJARDIR}"
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/jd-gui ${STAGEDIR}${PREFIX}/bin/jd-gui
+ ${INSTALL_DATA} ${DISTDIR}/jd-gui-${PORTVERSION}.jar ${STAGEDIR}${JAVAJARDIR}/jd-gui.jar
+ ${INSTALL_DATA} ${WRKSRC}/src/linux/resources/jd-gui.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ ${INSTALL_DATA} ${WRKSRC}/src/linux/resources/jd_icon_128.png ${STAGEDIR}${PREFIX}/share/pixmaps/jd-gui.png
+
+.include <bsd.port.mk>
diff --git a/java/jd-gui/distinfo b/java/jd-gui/distinfo
new file mode 100644
index 000000000000..c0305bfa514b
--- /dev/null
+++ b/java/jd-gui/distinfo
@@ -0,0 +1,4 @@
+SHA256 (java-decompiler-jd-gui-v1.4.0_GH0.tar.gz) = 5dd1220e7426352d51fa9eadb8a7d9685a6d7d93646c3fabae6f964cbf3edf2a
+SIZE (java-decompiler-jd-gui-v1.4.0_GH0.tar.gz) = 307931
+SHA256 (jd-gui-1.4.0.jar) = bdd2f3dc8750910e0d69378482cff57f2ff29d23983d1e55d266390527bd6b67
+SIZE (jd-gui-1.4.0.jar) = 8764679
diff --git a/java/jd-gui/files/jd-gui.in b/java/jd-gui/files/jd-gui.in
new file mode 100644
index 000000000000..f1e2d1bd4280
--- /dev/null
+++ b/java/jd-gui/files/jd-gui.in
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec java -jar "%%JAVAJARDIR%%/jd-gui.jar" $@
diff --git a/java/jd-gui/files/patch-src_linux_resources_jd-gui.desktop b/java/jd-gui/files/patch-src_linux_resources_jd-gui.desktop
new file mode 100644
index 000000000000..8ce05743f9f6
--- /dev/null
+++ b/java/jd-gui/files/patch-src_linux_resources_jd-gui.desktop
@@ -0,0 +1,10 @@
+--- src/linux/resources/jd-gui.desktop.orig 2016-01-18 23:32:17 UTC
++++ src/linux/resources/jd-gui.desktop
+@@ -2,6 +2,6 @@
+ Comment=Java Decompiler JD-GUI
+ Terminal=false
+ Name=JD-GUI
+-Exec=java -jar /opt/jd-gui/jd-gui.jar
++Exec=jd-gui
+ Type=Application
+ Icon=jd-gui
diff --git a/java/jd-gui/pkg-descr b/java/jd-gui/pkg-descr
new file mode 100644
index 000000000000..df834e39d316
--- /dev/null
+++ b/java/jd-gui/pkg-descr
@@ -0,0 +1,8 @@
+The Java Decompiler project aims to develop tools in order to
+decompile and analyze Java 5 byte code and later versions.
+
+JD-GUI is a standalone graphical utility that displays Java source
+codes of .class files. You can browse the reconstructed source code
+with the JD-GUI for instant access to methods and fields.
+
+WWW: http://jd.benow.ca/