aboutsummaryrefslogtreecommitdiff
path: root/java/jdk11-doc
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-08-02 22:45:41 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-08-02 22:45:41 +0000
commit6d47ab8c2e56290413065d74b82626b31ff1b4fd (patch)
tree335d06e26e6a7045fcf3cc871924281d17dd2321 /java/jdk11-doc
parent06c626f00f26deeab81a2f2a2a6b0c7e96e94828 (diff)
downloadports-6d47ab8c2e56290413065d74b82626b31ff1b4fd.tar.gz
ports-6d47ab8c2e56290413065d74b82626b31ff1b4fd.zip
Add a workaround to chown the files if the person installing
the port is root. It was keeping the uid/gid of 10/143. There might be a better solution than this in the long run but it'll work for now. PR: 12897 Reported by: Jose Marques <jose@nobody.org> Also some minor non-functional changes, exit 0 -> ${FALSE}, PKGMESSAGE to use | ${SED} instead of creating a new file.
Notes
Notes: svn path=/head/; revision=20504
Diffstat (limited to 'java/jdk11-doc')
-rw-r--r--java/jdk11-doc/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/java/jdk11-doc/Makefile b/java/jdk11-doc/Makefile
index c755f6222909..158930620e62 100644
--- a/java/jdk11-doc/Makefile
+++ b/java/jdk11-doc/Makefile
@@ -3,7 +3,7 @@
# Date created: Mon Mar 8 10:10:42 EET 1999
# Whom: Martti Kuparinen <martti.kuparinen@ericsson.com>
#
-# $Id: Makefile,v 1.5 1999/06/21 02:56:36 cpiazza Exp $
+# $Id: Makefile,v 1.6 1999/06/28 02:22:02 billf Exp $
#
DISTNAME= jdk118-doc
@@ -17,7 +17,6 @@ IS_INTERACTIVE= "Requires manual fetch"
VERSION= 1.1.8
WRKSRC= ${WRKDIR}/jdk${VERSION}
NO_BUILD= yes
-PKGMESSAGE= ${WRKDIR}/MESSAGE
PLIST_SUB+= VERSION=${VERSION}
.include <bsd.port.pre.mk>
@@ -34,14 +33,18 @@ do-fetch:
@echo 'as described in'
@echo ' http://java.sun.com/feedback/faq/downloading.html'
@echo ''
- @exit 1
+ @${FALSE}
.endif
+pre-install:
+ @if [ !`id -u` ]; then \
+ /usr/sbin/chown -R root:wheel ${WRKDIR}/*; \
+ fi
+
do-install:
${MKDIR} ${PREFIX}/jdk${VERSION}
(cd ${WRKSRC} && ${TAR} -cf - docs) \
| (cd ${PREFIX}/jdk${VERSION} && ${TAR} -xf -)
- @${SED} s+!!PREFIX!!+${PREFIX}+g < ${PKGDIR}/MESSAGE > ${PKGMESSAGE}
- @${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE} | ${SED} s+!!PREFIX!!+${PREFIX}+g
.include <bsd.port.post.mk>