aboutsummaryrefslogtreecommitdiff
path: root/java/jdk12-doc
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2001-05-31 09:19:23 +0000
committerDoug Barton <dougb@FreeBSD.org>2001-05-31 09:19:23 +0000
commit89a9cc0306bf77872e8719f68b3d17bd93528537 (patch)
tree85260229f0ebf3e8e56a4dd7c7ae39a5ae017794 /java/jdk12-doc
parentd04b9f26733d3674f3624deeaeb5ffcdee2fa221 (diff)
downloadports-89a9cc0306bf77872e8719f68b3d17bd93528537.tar.gz
ports-89a9cc0306bf77872e8719f68b3d17bd93528537.zip
My modification of the submitter's update didn't go far enough,
thereby causing breakage that was not present in the original. Fix the test for distfile a different way, using fewer variables and less gymnastics.
Notes
Notes: svn path=/head/; revision=43341
Diffstat (limited to 'java/jdk12-doc')
-rw-r--r--java/jdk12-doc/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/java/jdk12-doc/Makefile b/java/jdk12-doc/Makefile
index f18463c022ee..ec8a09c78a12 100644
--- a/java/jdk12-doc/Makefile
+++ b/java/jdk12-doc/Makefile
@@ -17,7 +17,7 @@ NO_CDROM= "License does not allow distribution with fee."
RESTRICTED= "This software is under license and export control."
.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute packages"
+IGNORE= "You cannot legally distribute packages"
.endif
PLIST_SUB+= JDK_HOME=${JDK_HOME:S/^${PREFIX}\///}
@@ -29,11 +29,9 @@ NO_BUILD= yes
.include <bsd.port.pre.mk>
-.for file in ${DISTFILES}
-.if !exists(${DISTDIR}/${file})
-IGNORE=You must manually fetch ${file} from http://java.sun.com/jdk/1.1/docs.html, place it in ${DISTDIR} and then run make again.
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE=You must manually fetch ${DISTNAME}${EXTRACT_SUFX} from http://java.sun.com/jdk/1.1/docs.html, place it in ${DISTDIR} and then run make again
.endif
-.endfor
do-install:
${MKDIR} ${PREFIX}/jdk${PORTVERSION}