aboutsummaryrefslogtreecommitdiff
path: root/java/jflex/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-02-18 19:50:33 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-02-18 19:50:33 +0000
commita69622a594795a23ac050162811b398dbc705ce0 (patch)
treeab99cf690f034de0db8c105616e437d8cb19b54e /java/jflex/Makefile
parent498d5c10eb3fdc5666954d2926a428cc5a478a79 (diff)
downloadports-a69622a594795a23ac050162811b398dbc705ce0.tar.gz
ports-a69622a594795a23ac050162811b398dbc705ce0.zip
Add a port of jflex:
JFlex is a lexical analyzer generator for Java written in Java. It is also a rewrite of the very useful tool JLex which was developed by Elliot Berk at Princeton University. As Vern Paxon states for his C/C++ tool flex: They do not share any code though. WWW: http://www.jflex.de/ I've done some clean up to the submitted version of the port. PR: 62043 Submitted by: Conor McDermottroe <ports@mcdermottroe.com>
Notes
Notes: svn path=/head/; revision=101341
Diffstat (limited to 'java/jflex/Makefile')
-rw-r--r--java/jflex/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/java/jflex/Makefile b/java/jflex/Makefile
new file mode 100644
index 000000000000..d4e780412026
--- /dev/null
+++ b/java/jflex/Makefile
@@ -0,0 +1,46 @@
+# Ports collection Makefile for: JFlex
+# Date created: 27 January 2004
+# Whom: Conor McDermottroe <ports@mcdermottroe.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jflex
+PORTVERSION= 1.3.5
+CATEGORIES= java devel
+MASTER_SITES= http://www.jflex.de/
+
+MAINTAINER= ports@mcdermottroe.com
+COMMENT= The Fast Lexical Analyser Generator for Java[tm]
+
+USE_JAVA= 1.1+
+NEED_JAVAC= yes
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/JFlex
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKE_ENV+= JAVAC="${JAVAC}" JAR="${JAR}" JAVAJARDIR="${JAVAJARDIR}" \
+ JAVA_CLASSES="${JAVA_CLASSES}"
+
+PLIST_SUB= JAVAJARDIR=${JAVAJARDIR:S|^${PREFIX}/||}
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+do-configure:
+ @${REINPLACE_CMD} -e 's|%%JAVAJARDIR%%|${JAVAJARDIR}|' \
+ ${WRKSRC}/bin/jflex
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/bin/jflex ${PREFIX}/bin/jflex
+ @${INSTALL_DATA} ${WRKSRC}/lib/JFlex.jar ${JAVAJARDIR}/JFlex.jar
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+ ${MKDIR} ${EXAMPLESDIR}
+.for EXAMPLE in binary byaccj cup interpreter java simple standalone
+ ${MKDIR} ${EXAMPLESDIR}/${EXAMPLE}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${EXAMPLE}/* ${EXAMPLESDIR}/${EXAMPLE}
+.endfor
+
+.include <bsd.port.mk>