aboutsummaryrefslogtreecommitdiff
path: root/java/jgraph
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-09 04:04:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-09 04:04:03 +0000
commit4c11817b20f41b86615e14e96daacb3b5e8b67b7 (patch)
treea7765ca4c71ed8c5dc0245532ffe37f2c655d112 /java/jgraph
parent5c98e2233243d848299005cf730eb4e36394e91f (diff)
downloadports-4c11817b20f41b86615e14e96daacb3b5e8b67b7.tar.gz
ports-4c11817b20f41b86615e14e96daacb3b5e8b67b7.zip
add jgraph 4.0
The Java Graph Diagram Component
Notes
Notes: svn path=/head/; revision=113248
Diffstat (limited to 'java/jgraph')
-rw-r--r--java/jgraph/Makefile73
-rw-r--r--java/jgraph/distinfo2
-rw-r--r--java/jgraph/pkg-descr11
3 files changed, 86 insertions, 0 deletions
diff --git a/java/jgraph/Makefile b/java/jgraph/Makefile
new file mode 100644
index 000000000000..fe89f8c9d60e
--- /dev/null
+++ b/java/jgraph/Makefile
@@ -0,0 +1,73 @@
+# ex:ts=8
+# Ports collection makefile for: jgraph
+# Date created: Jul 9, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jgraph
+PORTVERSION= 4.0
+CATEGORIES= java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-java1.4-src
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The Java Graph Diagram Component
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_RUN= yes
+
+.if !defined(WITHOUT_COMPILE) || !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${ANT_CMD}:${PORTSDIR}/devel/apache-ant
+ANT_CMD?= ${LOCALBASE}/bin/ant
+ANT= ${SETENV} JAVA_HOME=${JAVA_HOME} ${ANT_CMD}
+.endif
+
+.if !defined(WITHOUT_COMPILE)
+JAVA_BUILD= yes
+ANT_TARGETS= jar
+.endif
+
+.if !defined(NOPORTDOCS)
+ANT_TARGETS+= doc
+PORTDOCS= *
+.endif
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_COMPILE=yes Install the pre-compiled .jar file"
+ @${ECHO_MSG} ""
+
+do-build:
+.if !defined(WITHOUT_COMPILE) || !defined(NOPORTDOCS)
+ @cd ${WRKSRC} && ${ANT} ${ANT_TARGETS}
+ @${MV} -f ${WRKSRC}/build/lib/${PORTNAME}.jar ${WRKSRC}/lib
+ @${RM} -fr ${WRKSRC}/doc && ${MV} -f ${WRKSRC}/build/doc/api ${WRKSRC}/doc
+.endif
+
+do-install: do-install-jar do-install-javadoc
+
+do-install-jar:
+ @${ECHO_CMD} -n ">> Installing .jar file..."
+ @${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_CMD} " [DONE]"
+
+do-install-javadoc:
+.if !defined(NOPORTDOCS)
+ @${ECHO_CMD} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc && ${FIND} . \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @${ECHO_CMD} " [DONE]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/java/jgraph/distinfo b/java/jgraph/distinfo
new file mode 100644
index 000000000000..9498585c1bd1
--- /dev/null
+++ b/java/jgraph/distinfo
@@ -0,0 +1,2 @@
+MD5 (jgraph-4.0-java1.4-src.zip) = a1e8a37f04176a81a79a4bb4699c1f1f
+SIZE (jgraph-4.0-java1.4-src.zip) = 1009982
diff --git a/java/jgraph/pkg-descr b/java/jgraph/pkg-descr
new file mode 100644
index 000000000000..52ec0da220ff
--- /dev/null
+++ b/java/jgraph/pkg-descr
@@ -0,0 +1,11 @@
+JGraph is the most powerful, lightweight, feature-rich, and thoroughly
+documented open-source graph component available for Java. It is accompanied
+by JGraphpad, the first free diagram editor for Java that offers XML, Drag and
+Drop and much more!
+
+With the JGraph zoomable component, you can display objects and relations
+(networks) in any Swing UI. JGraph can also be used on the server-side, for
+example to read a GXL graph, apply a custom layout algorithm, and return the
+result as a HTML image map.
+
+WWW: http://www.jgrpah.com/