aboutsummaryrefslogtreecommitdiff
path: root/java/jgraphx
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:00:35 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-08-25 10:00:35 +0000
commitc7efc316b9dbe566f4a56947b7cbc6a4190edb7c (patch)
treef2c1bf2ad67af79480dda747e65bce67865078d3 /java/jgraphx
parent596ee300ca09b2227d1804827e928d2aac9218ec (diff)
downloadports-c7efc316b9dbe566f4a56947b7cbc6a4190edb7c.tar.gz
ports-c7efc316b9dbe566f4a56947b7cbc6a4190edb7c.zip
java/jgraphx:
- Convert to new options helpers - Convert to USE_GITHUB - Fix license (it's BSD actually) and remove MANUAL_PACKAGE_BUILD
Notes
Notes: svn path=/head/; revision=395227
Diffstat (limited to 'java/jgraphx')
-rw-r--r--java/jgraphx/Makefile43
-rw-r--r--java/jgraphx/distinfo4
2 files changed, 16 insertions, 31 deletions
diff --git a/java/jgraphx/Makefile b/java/jgraphx/Makefile
index 57442843db21..ddab005643c4 100644
--- a/java/jgraphx/Makefile
+++ b/java/jgraphx/Makefile
@@ -3,53 +3,38 @@
PORTNAME= jgraphx
PORTVERSION= 2.5.1.0
CATEGORIES= java graphics
-MASTER_SITES= https://codeload.github.com/jgraph/jgraphx/tar.gz/v${PORTVERSION}?dummy=/
MAINTAINER= makc@FreeBSD.org
COMMENT= The Java Graph Diagram Component version X (jgraph v6+)
-LICENSE= jgraph
-LICENSE_PERMS= # none
-LICENSE_NAME= JGraph Ltd License
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/license.txt
-MANUAL_PACKAGE_BUILD= needs interactive license confirmation
-
-OPTIONS_DEFINE= COMPILE DOCS
-
-COMPILE_DESC= Compile from source instead of using provided binary
+USE_GITHUB= yes
+GH_ACCOUNT= jgraph
USE_JAVA= yes
-JAVA_RUN= yes
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCOMPILE} || ${PORT_OPTIONS:MDOCS}
-BUILD_DEPENDS+= ${ANT_CMD}:${PORTSDIR}/devel/apache-ant
-ANT_CMD?= ${LOCALBASE}/bin/ant
-ANT= ${SETENV} JAVA_HOME=${JAVA_HOME} ${ANT_CMD}
-. if ${PORT_OPTIONS:MCOMPILE}
-JAVA_BUILD= yes
-. endif
-.endif
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
PORTDOCS= *
+OPTIONS_DEFINE= COMPILE DOCS
+
+COMPILE_DESC= Compile from source instead of using provided binary
+COMPILE_USE= ANT=yes
+
do-build:
-.if ${PORT_OPTIONS:MCOMPILE} || ${PORT_OPTIONS:MDOCS}
- cd ${WRKSRC} && ${ANT} ${ANT_TARGETS}
-.endif
+ @${DO_NADA}
-do-install: do-install-jar do-install-javadoc
+do-build-COMPILE-on:
+ @(cd ${BUILD_WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${ANT} ${MAKE_ARGS} ${ALL_TARGET})
-do-install-jar:
+do-install:
${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}.jar \
${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
-do-install-javadoc:
-.if ${PORT_OPTIONS:MDOCS}
+do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/java/jgraphx/distinfo b/java/jgraphx/distinfo
index cb2e842367db..57ff1a5dad80 100644
--- a/java/jgraphx/distinfo
+++ b/java/jgraphx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jgraphx-2.5.1.0.tar.gz) = 6638e100af80c3885c4e87b3f951060fa6c5111d34fc17b44ba2da05963111b7
-SIZE (jgraphx-2.5.1.0.tar.gz) = 3181415
+SHA256 (jgraph-jgraphx-2.5.1.0_GH0.tar.gz) = 6638e100af80c3885c4e87b3f951060fa6c5111d34fc17b44ba2da05963111b7
+SIZE (jgraph-jgraphx-2.5.1.0_GH0.tar.gz) = 3181415