aboutsummaryrefslogtreecommitdiff
path: root/java/jta
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-11-11 15:36:18 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-11-11 15:36:18 +0000
commit52aab444593f23cdcb657b52bd32bc02693ac5a1 (patch)
tree29d09fdf0c6bf3c184f52e69e2c885d926606bd1 /java/jta
parent2effdbdab0c4f54adcd297607d0ef77d34bbcfaa (diff)
downloadports-52aab444593f23cdcb657b52bd32bc02693ac5a1.tar.gz
ports-52aab444593f23cdcb657b52bd32bc02693ac5a1.zip
Java Transaction API (JTA) specifies standard Java interfaces between a
transaction manager and the parties involved in a distributed transaction system: the resource manager, the application server, and the transactional applications. The JTA specification was developed by Sun Microsystems in cooperation with leading industry partners in the transaction processing and database system arena. See JSR 907. WWW: http://www.oracle.com/technetwork/java/javaee/tech/jta-138684.html
Notes
Notes: svn path=/head/; revision=264405
Diffstat (limited to 'java/jta')
-rw-r--r--java/jta/Makefile46
-rw-r--r--java/jta/distinfo2
-rw-r--r--java/jta/pkg-descr10
3 files changed, 58 insertions, 0 deletions
diff --git a/java/jta/Makefile b/java/jta/Makefile
new file mode 100644
index 000000000000..2590b75e40bb
--- /dev/null
+++ b/java/jta/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: JTA
+# Date created: 5 Nov 2010
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jta
+PORTVERSION= 1.0.1
+CATEGORIES= java devel
+MASTER_SITES= #
+DISTNAME= ${PORTNAME}-spec${PORTVERSION:S/./_/g}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Java Transaction API (JTA)
+
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+
+NO_BUILD= yes
+NO_CDROM= See the license
+DOWNLOAD_URL= https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=7286-jta-${PORTVERSION}-spec-oth-JSpec@CDS-CDS_Developer
+
+PORTDOCS= ${DISTNAME}.pdf javadocs
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+.include <bsd.port.pre.mk>
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+IGNORE= you must manually fetch the distribution from ${DOWNLOAD_URL} and place it in ${DISTDIR} then run make again
+.endif
+
+do-install:
+ @${ECHO_MSG} -n ">> Install JAR file as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/docs && ${FIND} ${PORTDOCS} \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/java/jta/distinfo b/java/jta/distinfo
new file mode 100644
index 000000000000..a0e2fb9c7ef4
--- /dev/null
+++ b/java/jta/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jta-spec1_0_1.zip) = a64752468f73559dba9b71e895df2c9556b9b5f78f487f04730a8764db94ecfe
+SIZE (jta-spec1_0_1.zip) = 616357
diff --git a/java/jta/pkg-descr b/java/jta/pkg-descr
new file mode 100644
index 000000000000..49a634ae71c0
--- /dev/null
+++ b/java/jta/pkg-descr
@@ -0,0 +1,10 @@
+Java Transaction API (JTA) specifies standard Java interfaces between a
+transaction manager and the parties involved in a distributed transaction
+system: the resource manager, the application server, and the
+transactional applications.
+
+The JTA specification was developed by Sun Microsystems in cooperation
+with leading industry partners in the transaction processing and database
+system arena. See JSR 907.
+
+WWW: http://www.oracle.com/technetwork/java/javaee/tech/jta-138684.html