aboutsummaryrefslogtreecommitdiff
path: root/java/jxgrabkey
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2016-07-03 05:17:23 +0000
committerMikhail Teterin <mi@FreeBSD.org>2016-07-03 05:17:23 +0000
commit8e8efec2617f8f4e880dfe31b0d6cd332958a2a3 (patch)
tree9e1758ade79152d27076f3ccb89b2dfaf5fda9eb /java/jxgrabkey
parent4a396b70723eda920672cfd36a83236818e34522 (diff)
downloadports-8e8efec2617f8f4e880dfe31b0d6cd332958a2a3.tar.gz
ports-8e8efec2617f8f4e880dfe31b0d6cd332958a2a3.zip
Add an explicit include of <unistd.h>, which is required on
some of our releases. Change to avoid building the useless static libJXGrabKey.a (we weren't installing). Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=417955
Diffstat (limited to 'java/jxgrabkey')
-rw-r--r--java/jxgrabkey/Makefile2
-rw-r--r--java/jxgrabkey/files/patch-warnings3
2 files changed, 3 insertions, 2 deletions
diff --git a/java/jxgrabkey/Makefile b/java/jxgrabkey/Makefile
index b7720f9067dd..624c2e21cac1 100644
--- a/java/jxgrabkey/Makefile
+++ b/java/jxgrabkey/Makefile
@@ -24,7 +24,7 @@ USE_LDCONFIG= yes
do-build:
${SETENV} ${MAKE_ENV} ${MAKE} -C ${WRKSRC}/JXGrabKey/C++ \
- -f ${FILESDIR}/Makefile.JXGrabKey
+ -f ${FILESDIR}/Makefile.JXGrabKey libJXGrabKey.so
cd ${WRKSRC}/JXGrabKey/Java && ${ANT} -verbose jar
do-install:
diff --git a/java/jxgrabkey/files/patch-warnings b/java/jxgrabkey/files/patch-warnings
index fed1556455b8..22d7691f6551 100644
--- a/java/jxgrabkey/files/patch-warnings
+++ b/java/jxgrabkey/files/patch-warnings
@@ -1,10 +1,11 @@
--- JXGrabKey/C++/src/JXGrabKey.cpp 2010-02-28 10:11:49.000000000 -0500
+++ JXGrabKey/C++/src/JXGrabKey.cpp 2016-06-30 03:15:41.718599000 -0400
-@@ -24,4 +24,5 @@
+@@ -24,4 +24,6 @@
#include <X11/Xlib.h>
#include <X11/keysym.h>
+#include <X11/XKBlib.h>
++#include <unistd.h>
#include <pthread.h>
@@ -319,5 +320,5 @@