aboutsummaryrefslogtreecommitdiff
path: root/java/netty
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-10-02 14:54:08 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-10-02 14:54:08 +0000
commit27e63078ca57130cc2f835008e072c4b767c2fcd (patch)
tree250b45d3d078e16b73a8f89263a4b5194aeb28fd /java/netty
parenta158d41a99f88ba0ceeff9f73da4e94bff4cbaa1 (diff)
downloadports-27e63078ca57130cc2f835008e072c4b767c2fcd.tar.gz
ports-27e63078ca57130cc2f835008e072c4b767c2fcd.zip
The Netty is an effort to provide an asynchronous
event-driven network application framework and tools for rapid development of maintainable high performance & high scalability protocol servers & clients. WWW: http://www.jboss.org/netty PR: ports/154285 Submitted by: Mikhail T. <michael@fun-box.ru> Approved by: miwi, wen (mentors implicit)
Notes
Notes: svn path=/head/; revision=282795
Diffstat (limited to 'java/netty')
-rw-r--r--java/netty/Makefile45
-rw-r--r--java/netty/distinfo2
-rw-r--r--java/netty/pkg-descr6
3 files changed, 53 insertions, 0 deletions
diff --git a/java/netty/Makefile b/java/netty/Makefile
new file mode 100644
index 000000000000..7720f4243085
--- /dev/null
+++ b/java/netty/Makefile
@@ -0,0 +1,45 @@
+# ports collection makefile for: netty
+# Date created: 2011-01-16
+# Whom: Mikhail T. <michael@fun-box.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= netty
+PORTVERSION= 3.2.3
+DISTVERSIONSUFFIX=.Final-dist
+CATEGORIES= java devel
+MASTER_SITES= SF/jboss/Netty%20Project/Netty%20${PORTVERSION}.Final/
+
+MAINTAINER= michael@fun-box.ru
+COMMENT= Java NIO client server framework
+
+LICENSE= ASL
+
+USE_JAVA= yes
+USE_BZIP2= yes
+JAVA_VERSION= 1.5+
+NO_BUILD= yes
+DATADIR= ${PREFIX}/share/${UNIQUENAME}
+DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.Final
+
+PLIST_FILES= %%JAVAJARDIR%%/netty-${PORTVERSION}.jar
+
+PORTDATA= *
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${JAVAJARDIR}
+ ${INSTALL_DATA} ${WRKSRC}/jar/netty-${PORTVERSION}.Final.jar ${JAVAJARDIR}/netty-${PORTVERSION}.jar
+ cd ${WRKSRC} && ${COPYTREE_SHARE} src ${DATADIR}
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/java/netty/distinfo b/java/netty/distinfo
new file mode 100644
index 000000000000..feba7f4ee40a
--- /dev/null
+++ b/java/netty/distinfo
@@ -0,0 +1,2 @@
+SHA256 (netty-3.2.3.Final-dist.tar.bz2) = 3625ae8735d0de1bf30b1c9504887deadeefa194c3c14d2f70d8d8dd1f9e49ff
+SIZE (netty-3.2.3.Final-dist.tar.bz2) = 6698379
diff --git a/java/netty/pkg-descr b/java/netty/pkg-descr
new file mode 100644
index 000000000000..f07ed1f8ccf1
--- /dev/null
+++ b/java/netty/pkg-descr
@@ -0,0 +1,6 @@
+The Netty is an effort to provide an asynchronous
+event-driven network application framework and tools
+for rapid development of maintainable high performance &
+high scalability protocol servers & clients.
+
+WWW: http://www.jboss.org/netty