aboutsummaryrefslogtreecommitdiff
path: root/java/netty
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2012-08-30 19:14:32 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2012-08-30 19:14:32 +0000
commit6d68817f7cdb7fd8d62501caad592ee7942063c0 (patch)
treeea586f2761455ea06c706287bfe9077330ba0f06 /java/netty
parentffe114117e3eaaf1e6066530240bf5457e319af6 (diff)
downloadports-6d68817f7cdb7fd8d62501caad592ee7942063c0.tar.gz
ports-6d68817f7cdb7fd8d62501caad592ee7942063c0.zip
Update port to 3.5.5
Create a link for a current version Update WWW and master sites PR: ports/171011 Submitted by: Mikhail Tsatsenko m.tsatsenko@gmail.com
Notes
Notes: svn path=/head/; revision=303388
Diffstat (limited to 'java/netty')
-rw-r--r--java/netty/Makefile10
-rw-r--r--java/netty/distinfo4
-rw-r--r--java/netty/pkg-descr2
3 files changed, 10 insertions, 6 deletions
diff --git a/java/netty/Makefile b/java/netty/Makefile
index ddfbba378185..42ecbfa0f207 100644
--- a/java/netty/Makefile
+++ b/java/netty/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME= netty
-PORTVERSION= 3.2.3
+PORTVERSION= 3.5.5
DISTVERSIONSUFFIX=.Final-dist
CATEGORIES= java devel
-MASTER_SITES= SF/jboss/Netty%20Project/Netty%20${PORTVERSION}.Final/
+MASTER_SITES= https://github.com/downloads/netty/netty/
MAINTAINER= m.tsatsenko@gmail.com
COMMENT= Java NIO client server framework
LICENSE= AL2
+FETCH_ARGS= -Fpr
+
USE_JAVA= yes
USE_BZIP2= yes
JAVA_VERSION= 1.5+
@@ -24,7 +26,8 @@ DATADIR= ${PREFIX}/share/${UNIQUENAME}
DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.Final
-PLIST_FILES= %%JAVAJARDIR%%/netty-${PORTVERSION}.jar
+PLIST_FILES= %%JAVAJARDIR%%/netty-${PORTVERSION}.jar \
+ %%JAVAJARDIR%%/netty.jar
PORTDATA= *
.if !defined(NOPORTDOCS)
@@ -37,6 +40,7 @@ do-install:
${MKDIR} ${JAVAJARDIR}
${INSTALL_DATA} ${WRKSRC}/jar/netty-${PORTVERSION}.Final.jar ${JAVAJARDIR}/netty-${PORTVERSION}.jar
cd ${WRKSRC} && ${COPYTREE_SHARE} src ${DATADIR}
+ ${LN} -nfs ${JAVAJARDIR}/netty-${PORTVERSION}.jar ${JAVAJARDIR}/netty.jar
.if !defined(NOPORTDOCS)
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
diff --git a/java/netty/distinfo b/java/netty/distinfo
index feba7f4ee40a..92dfa56a0282 100644
--- a/java/netty/distinfo
+++ b/java/netty/distinfo
@@ -1,2 +1,2 @@
-SHA256 (netty-3.2.3.Final-dist.tar.bz2) = 3625ae8735d0de1bf30b1c9504887deadeefa194c3c14d2f70d8d8dd1f9e49ff
-SIZE (netty-3.2.3.Final-dist.tar.bz2) = 6698379
+SHA256 (netty-3.5.5.Final-dist.tar.bz2) = 029107453c00aeae5667b9008754cd081909e43acd4d065e586b05a6def22cea
+SIZE (netty-3.5.5.Final-dist.tar.bz2) = 7926353
diff --git a/java/netty/pkg-descr b/java/netty/pkg-descr
index f07ed1f8ccf1..621b4254d89a 100644
--- a/java/netty/pkg-descr
+++ b/java/netty/pkg-descr
@@ -3,4 +3,4 @@ event-driven network application framework and tools
for rapid development of maintainable high performance &
high scalability protocol servers & clients.
-WWW: http://www.jboss.org/netty
+WWW: http://netty.io