aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk11
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2019-07-24 22:41:40 +0000
committerGreg Lewis <glewis@FreeBSD.org>2019-07-24 22:41:40 +0000
commit93dbf94b5ee825b57d6be116053a1bf3bb2c48d2 (patch)
tree9238fa9c6e3862550c52631dcface6ffe9f45d9a /java/openjdk11
parente73279ea108765a78895cecb364012be19c6a31f (diff)
downloadports-93dbf94b5ee825b57d6be116053a1bf3bb2c48d2.tar.gz
ports-93dbf94b5ee825b57d6be116053a1bf3bb2c48d2.zip
* Add a dependency on xrandr, since the latest version uses Xrandr.h
* Set NO_CCACHE to match configure being passed --disable-ccache Fixes the build in poudriere and for people trying to use ccache PR: 239387 Submitted by: Jonathan Chen <jonc@chen.org.nz>
Notes
Notes: svn path=/head/; revision=507303
Diffstat (limited to 'java/openjdk11')
-rw-r--r--java/openjdk11/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/java/openjdk11/Makefile b/java/openjdk11/Makefile
index d545e9912e87..3a32b4788455 100644
--- a/java/openjdk11/Makefile
+++ b/java/openjdk11/Makefile
@@ -25,12 +25,14 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libpng.so:graphics/png
USES= compiler:features gmake iconv jpeg pkgconfig
-USE_XORG= x11 xext xi xrender xt xtst
+USE_XORG= x11 xext xi xrandr xrender xt xtst
USE_GITHUB= yes
GH_ACCOUNT= battleblow
GH_PROJECT= openjdk-jdk11u
+NO_CCACHE= yes
+
_MAKE_JOBS= #
MAKE_ENV= LANG="C" \
LC_ALL="C" \