aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk11
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2020-10-24 04:17:02 +0000
committerGreg Lewis <glewis@FreeBSD.org>2020-10-24 04:17:02 +0000
commitdaaa2aa100078c0e4c880ec73a3b0ea79ed12cb6 (patch)
tree03007704906f951b89ffd2ef5b4f78cfc000fbeb /java/openjdk11
parent52e5f6e5cc4f5988aa263cd96cade35a9a4bdd9c (diff)
downloadports-daaa2aa100078c0e4c880ec73a3b0ea79ed12cb6.tar.gz
ports-daaa2aa100078c0e4c880ec73a3b0ea79ed12cb6.zip
Enable the Shenandoah GC
Notes
Notes: svn path=/head/; revision=553155
Diffstat (limited to 'java/openjdk11')
-rw-r--r--java/openjdk11/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/java/openjdk11/Makefile b/java/openjdk11/Makefile
index b9b462713825..1b2718d1f6c8 100644
--- a/java/openjdk11/Makefile
+++ b/java/openjdk11/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openjdk
DISTVERSIONPREFIX= jdk-
DISTVERSION= ${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_PATCH_VERSION}+${JDK_BUILD_NUMBER}-${BSD_JDK_VERSION}
+PORTREVISION= 1
CATEGORIES= java devel
PKGNAMESUFFIX?= ${JDK_MAJOR_VERSION}
@@ -75,6 +76,7 @@ CONFIGURE_ARGS= --with-boot-jdk=${BOOTSTRAPJDKDIR} \
--disable-ccache \
--disable-javac-server \
--disable-hotspot-gtest \
+ --with-jvm-features=shenandoahgc \
--with-alsa=${LOCALBASE} \
--with-cups=${LOCALBASE} \
--with-fontconfig=${LOCALBASE} \