aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk14
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2020-07-12 02:13:27 +0000
committerGreg Lewis <glewis@FreeBSD.org>2020-07-12 02:13:27 +0000
commit0e8769531d7ccc8c8a1ab30b31b1d53b4db538ca (patch)
treea06f72c509833acc8a2d76ddf16eac7c57f044c0 /java/openjdk14
parentd0c6e0e6f8e3181057088b89ae1a88c3707b94a0 (diff)
downloadports-0e8769531d7ccc8c8a1ab30b31b1d53b4db538ca.tar.gz
ports-0e8769531d7ccc8c8a1ab30b31b1d53b4db538ca.zip
More accurate vendor information
PR: 244634
Notes
Notes: svn path=/head/; revision=542063
Diffstat (limited to 'java/openjdk14')
-rw-r--r--java/openjdk14/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/java/openjdk14/Makefile b/java/openjdk14/Makefile
index 760e2e0cc4f5..64686addbfde 100644
--- a/java/openjdk14/Makefile
+++ b/java/openjdk14/Makefile
@@ -60,6 +60,8 @@ JDK_PATCH_VERSION= 1
JDK_BUILD_NUMBER= 7
BSD_JDK_VERSION= 1
+JDK_BUG_URL= https://bugs.freebsd.org/bugzilla/enter_bug.cgi?product=Ports%20%26%20Packages&component=Individual%20Port(s)&short_desc=java/${PORTNAME}${JDK_MAJOR_VERSION}%3A%20
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CC=${CC} \
CXX=${CXX} \
@@ -86,7 +88,11 @@ CONFIGURE_ARGS= --with-boot-jdk=${BOOTSTRAPJDKDIR} \
--with-cacerts-file=${FILESDIR}/cacerts \
--with-version-string=${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_PATCH_VERSION}+${JDK_BUILD_NUMBER}-${BSD_JDK_VERSION} \
--with-native-debug-symbols=none \
- --with-debug-level=release
+ --with-debug-level=release \
+ --with-vendor-name="OpenJDK BSD Porting Team" \
+ --with-vendor-url="https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/" \
+ --with-vendor-bug-url="${JDK_BUG_URL}" \
+ --with-vendor-vm-bug-url="${JDK_BUG_URL}"
JAVAVMS_COMMENT= OpenJDK${JDK_MAJOR_VERSION}