aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk14
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2021-02-05 04:06:54 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2021-02-05 04:06:54 +0000
commit31ae652e5ff58a4158ac30f1edc43345bdd50833 (patch)
treeabeb12e0fd86d8807521abb7605e78e505c8d139 /java/openjdk14
parentd9f4cebe4485ae50ef878b84324d66f234a4ceb3 (diff)
downloadports-31ae652e5ff58a4158ac30f1edc43345bdd50833.tar.gz
ports-31ae652e5ff58a4158ac30f1edc43345bdd50833.zip
Fix build with Clang 11.
Notes
Notes: svn path=/head/; revision=564085
Diffstat (limited to 'java/openjdk14')
-rw-r--r--java/openjdk14/Makefile1
-rw-r--r--java/openjdk14/files/patch-changeset-5793244
-rw-r--r--java/openjdk14/files/patch-changeset-5799443
-rw-r--r--java/openjdk14/files/patch-src_java.desktop_unix_classes_sun_awt_X11_XlibWrapper.java11
-rw-r--r--java/openjdk14/files/patch-src_java.desktop_unix_native_libawt__xawt_xawt_XlibWrapper.c15
5 files changed, 114 insertions, 0 deletions
diff --git a/java/openjdk14/Makefile b/java/openjdk14/Makefile
index 711006f7de16..6dd86c28535b 100644
--- a/java/openjdk14/Makefile
+++ b/java/openjdk14/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openjdk
DISTVERSIONPREFIX= jdk-
DISTVERSION= ${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_PATCH_VERSION}+${JDK_BUILD_NUMBER}-${BSD_JDK_VERSION}
+PORTREVISION= 1
CATEGORIES= java devel
PKGNAMESUFFIX?= ${JDK_MAJOR_VERSION}
diff --git a/java/openjdk14/files/patch-changeset-57932 b/java/openjdk14/files/patch-changeset-57932
new file mode 100644
index 000000000000..fe176aaa0135
--- /dev/null
+++ b/java/openjdk14/files/patch-changeset-57932
@@ -0,0 +1,44 @@
+changeset: 57932:9e54ea7d9cd9
+user: qpzhang
+date: Wed Feb 05 20:31:09 2020 +0800
+summary: 8238388: libj2gss/NativeFunc.o "multiple definition" link errors with GCC10
+
+diff -r 932418820c80 -r 9e54ea7d9cd9 src/java.security.jgss/share/native/libj2gss/NativeFunc.c
+--- src/java.security.jgss/share/native/libj2gss/NativeFunc.c Wed Feb 05 10:45:39 2020 +0100
++++ src/java.security.jgss/share/native/libj2gss/NativeFunc.c Wed Feb 05 20:31:09 2020 +0800
+@@ -1,5 +1,5 @@
+ /*
+- * Copyright (c) 2005, 2018, Oracle and/or its affiliates. All rights reserved.
++ * Copyright (c) 2005, 2020, Oracle and/or its affiliates. All rights reserved.
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+ *
+ * This code is free software; you can redistribute it and/or modify it
+@@ -27,6 +27,9 @@
+ #include <stdlib.h>
+ #include "NativeFunc.h"
+
++/* global GSS function table */
++GSS_FUNCTION_TABLE_PTR ftab;
++
+ /* standard GSS method names (ordering is from mapfile) */
+ static const char RELEASE_NAME[] = "gss_release_name";
+ static const char IMPORT_NAME[] = "gss_import_name";
+diff -r 932418820c80 -r 9e54ea7d9cd9 src/java.security.jgss/share/native/libj2gss/NativeFunc.h
+--- src/java.security.jgss/share/native/libj2gss/NativeFunc.h Wed Feb 05 10:45:39 2020 +0100
++++ src/java.security.jgss/share/native/libj2gss/NativeFunc.h Wed Feb 05 20:31:09 2020 +0800
+@@ -1,5 +1,5 @@
+ /*
+- * Copyright (c) 2005, 2019, Oracle and/or its affiliates. All rights reserved.
++ * Copyright (c) 2005, 2020, Oracle and/or its affiliates. All rights reserved.
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+ *
+ * This code is free software; you can redistribute it and/or modify it
+@@ -277,6 +277,6 @@
+ typedef GSS_FUNCTION_TABLE *GSS_FUNCTION_TABLE_PTR;
+
+ /* global GSS function table */
+-GSS_FUNCTION_TABLE_PTR ftab;
++extern GSS_FUNCTION_TABLE_PTR ftab;
+
+ #endif
+
diff --git a/java/openjdk14/files/patch-changeset-57994 b/java/openjdk14/files/patch-changeset-57994
new file mode 100644
index 000000000000..94ce2e99756b
--- /dev/null
+++ b/java/openjdk14/files/patch-changeset-57994
@@ -0,0 +1,43 @@
+changeset: 57994:6925fca95959
+user: qpzhang
+date: Tue Feb 04 21:27:10 2020 +0800
+summary: 8238380: java.base/unix/native/libjava/childproc.c "multiple definition" link errors with GCC10
+
+diff -r 8f6ffa575f63 -r 6925fca95959 src/java.base/unix/native/libjava/childproc.c
+--- src/java.base/unix/native/libjava/childproc.c Tue Feb 11 11:17:37 2020 +0800
++++ src/java.base/unix/native/libjava/childproc.c Tue Feb 04 21:27:10 2020 +0800
+@@ -1,5 +1,5 @@
+ /*
+- * Copyright (c) 2013, 2019, Oracle and/or its affiliates. All rights reserved.
++ * Copyright (c) 2013, 2020, Oracle and/or its affiliates. All rights reserved.
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+ *
+ * This code is free software; you can redistribute it and/or modify it
+@@ -34,6 +34,7 @@
+
+ #include "childproc.h"
+
++const char * const *parentPathv;
+
+ ssize_t
+ restartableWrite(int fd, const void *buf, size_t count)
+diff -r 8f6ffa575f63 -r 6925fca95959 src/java.base/unix/native/libjava/childproc.h
+--- src/java.base/unix/native/libjava/childproc.h Tue Feb 11 11:17:37 2020 +0800
++++ src/java.base/unix/native/libjava/childproc.h Tue Feb 04 21:27:10 2020 +0800
+@@ -1,5 +1,5 @@
+ /*
+- * Copyright (c) 2013, 2015, Oracle and/or its affiliates. All rights reserved.
++ * Copyright (c) 2013, 2020, Oracle and/or its affiliates. All rights reserved.
+ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
+ *
+ * This code is free software; you can redistribute it and/or modify it
+@@ -126,7 +126,7 @@
+ * The cached and split version of the JDK's effective PATH.
+ * (We don't support putenv("PATH=...") in native code)
+ */
+-const char * const *parentPathv;
++extern const char * const *parentPathv;
+
+ ssize_t restartableWrite(int fd, const void *buf, size_t count);
+ int restartableDup2(int fd_from, int fd_to);
+
diff --git a/java/openjdk14/files/patch-src_java.desktop_unix_classes_sun_awt_X11_XlibWrapper.java b/java/openjdk14/files/patch-src_java.desktop_unix_classes_sun_awt_X11_XlibWrapper.java
new file mode 100644
index 000000000000..4f3913a95410
--- /dev/null
+++ b/java/openjdk14/files/patch-src_java.desktop_unix_classes_sun_awt_X11_XlibWrapper.java
@@ -0,0 +1,11 @@
+--- src/java.desktop/unix/classes/sun/awt/X11/XlibWrapper.java.orig 2020-04-17 22:35:42 UTC
++++ src/java.desktop/unix/classes/sun/awt/X11/XlibWrapper.java
+@@ -529,7 +529,7 @@ static native String XSetLocaleModifiers(String modifi
+ display Specifies the connection to the X server.
+ onoff Specifies a Boolean value that indicates whether to enable or disable synchronization.
+ */
+- static native int XSynchronize(long display, boolean onoff);
++ static native long XSynchronize(long display, boolean onoff);
+
+ /**
+ * Extracts an X event that can be processed in a secondary loop.
diff --git a/java/openjdk14/files/patch-src_java.desktop_unix_native_libawt__xawt_xawt_XlibWrapper.c b/java/openjdk14/files/patch-src_java.desktop_unix_native_libawt__xawt_xawt_XlibWrapper.c
new file mode 100644
index 000000000000..b4d602993ab9
--- /dev/null
+++ b/java/openjdk14/files/patch-src_java.desktop_unix_native_libawt__xawt_xawt_XlibWrapper.c
@@ -0,0 +1,15 @@
+--- src/java.desktop/unix/native/libawt_xawt/xawt/XlibWrapper.c.orig 2020-04-17 22:35:42 UTC
++++ src/java.desktop/unix/native/libawt_xawt/xawt/XlibWrapper.c
+@@ -2180,10 +2180,10 @@ Java_sun_awt_X11_XlibWrapper_copyLongArray(JNIEnv *env
+ }
+ }
+
+-JNIEXPORT jint JNICALL
++JNIEXPORT jlong JNICALL
+ Java_sun_awt_X11_XlibWrapper_XSynchronize(JNIEnv *env, jclass clazz, jlong display, jboolean onoff)
+ {
+- return (jint) XSynchronize((Display*)jlong_to_ptr(display), (onoff == JNI_TRUE ? True : False));
++ return ptr_to_jlong(XSynchronize((Display*)jlong_to_ptr(display), (onoff == JNI_TRUE ? True : False)));
+ }
+
+ JNIEXPORT jboolean JNICALL