aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk22
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2024-07-28 06:07:40 +0000
committerGreg Lewis <glewis@FreeBSD.org>2024-07-28 06:08:33 +0000
commit274bbd72a971381b75e46e682ca3fea7a7b8fc0d (patch)
treeccb67f717f6aaed48e94e41553572466fcb2f2ae /java/openjdk22
parent9a42aed9ee48c21edbd1580c7dd696c549ca0ef2 (diff)
Diffstat (limited to 'java/openjdk22')
-rw-r--r--java/openjdk22/Makefile8
-rw-r--r--java/openjdk22/distinfo6
-rw-r--r--java/openjdk22/files/patch-src_hotspot_os__cpu_bsd__ppc_os__bsd__ppc.cpp44
3 files changed, 7 insertions, 51 deletions
diff --git a/java/openjdk22/Makefile b/java/openjdk22/Makefile
index cd6505fee645..9456a355bb6a 100644
--- a/java/openjdk22/Makefile
+++ b/java/openjdk22/Makefile
@@ -1,6 +1,6 @@
PORTNAME= openjdk
DISTVERSIONPREFIX= jdk-
-DISTVERSION= ${JDK_MAJOR_VERSION}+${JDK_BUILD_NUMBER}-${BSD_JDK_VERSION}
+DISTVERSION= ${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_PATCH_VERSION}+${JDK_BUILD_NUMBER}-${BSD_JDK_VERSION}
CATEGORIES= java devel
PKGNAMESUFFIX?= ${JDK_MAJOR_VERSION}
@@ -34,7 +34,7 @@ CPE_VENDOR= oracle
USE_GITHUB= yes
GH_ACCOUNT= battleblow
-GH_PROJECT= jdk22
+GH_PROJECT= jdk22u
NO_CCACHE= yes
@@ -62,8 +62,8 @@ NOPRECIOUSMAKEVARS= yes
JDK_MAJOR_VERSION= 22
JDK_MINOR_VERSION= 0
-JDK_PATCH_VERSION= 0
-JDK_BUILD_NUMBER= 36
+JDK_PATCH_VERSION= 2
+JDK_BUILD_NUMBER= 9
BSD_JDK_VERSION= 1
JDK_BUG_URL= https://bugs.freebsd.org/bugzilla/enter_bug.cgi?product=Ports%20%26%20Packages&component=Individual%20Port(s)&short_desc=java/${PORTNAME}${JDK_MAJOR_VERSION}%3A%20
diff --git a/java/openjdk22/distinfo b/java/openjdk22/distinfo
index b9846af000e1..fb2c92e36e3a 100644
--- a/java/openjdk22/distinfo
+++ b/java/openjdk22/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1709401903
-SHA256 (battleblow-jdk22-jdk-22+36-1_GH0.tar.gz) = 5defdd386289a0ac4c898642216f45bf71f58dddae66d67df113ca63847d65c9
-SIZE (battleblow-jdk22-jdk-22+36-1_GH0.tar.gz) = 112090664
+TIMESTAMP = 1722138875
+SHA256 (battleblow-jdk22u-jdk-22.0.2+9-1_GH0.tar.gz) = 5e2731b979cab49d5004cf0aca58c642c94c1808c48278bff6c440945874f24c
+SIZE (battleblow-jdk22u-jdk-22.0.2+9-1_GH0.tar.gz) = 112154344
diff --git a/java/openjdk22/files/patch-src_hotspot_os__cpu_bsd__ppc_os__bsd__ppc.cpp b/java/openjdk22/files/patch-src_hotspot_os__cpu_bsd__ppc_os__bsd__ppc.cpp
deleted file mode 100644
index dda6fd26cce0..000000000000
--- a/java/openjdk22/files/patch-src_hotspot_os__cpu_bsd__ppc_os__bsd__ppc.cpp
+++ /dev/null
@@ -1,44 +0,0 @@
---- src/hotspot/os_cpu/bsd_ppc/os_bsd_ppc.cpp.orig 2024-04-11 22:23:08 UTC
-+++ src/hotspot/os_cpu/bsd_ppc/os_bsd_ppc.cpp
-@@ -61,6 +61,7 @@
- # include <sys/types.h>
- # include <sys/mman.h>
- # include <pthread.h>
-+# include <pthread_np.h>
- # include <signal.h>
- # include <errno.h>
- # include <dlfcn.h>
-@@ -432,6 +433,33 @@ size_t os::Posix::default_stack_size(os::ThreadType th
- // Default stack size (compiler thread needs larger stack).
- size_t s = (thr_type == os::compiler_thread ? 4 * M : 1024 * K);
- return s;
-+}
-+
-+void os::current_stack_base_and_size(address* base, size_t* size) {
-+ address bottom;
-+ pthread_attr_t attr;
-+
-+ int rslt = pthread_attr_init(&attr);
-+
-+ // JVM needs to know exact stack location, abort if it fails
-+ if (rslt != 0)
-+ fatal("pthread_attr_init failed with error = %d", rslt);
-+
-+ rslt = pthread_attr_get_np(pthread_self(), &attr);
-+
-+ if (rslt != 0)
-+ fatal("pthread_attr_get_np failed with error = %d", rslt);
-+
-+ if (pthread_attr_getstackaddr(&attr, (void **)&bottom) != 0 ||
-+ pthread_attr_getstacksize(&attr, size) != 0) {
-+ fatal("Can not locate current stack attributes!");
-+ }
-+
-+ *base = bottom + *size;
-+
-+ pthread_attr_destroy(&attr);
-+ assert(os::current_stack_pointer() >= bottom &&
-+ os::current_stack_pointer() < *base, "just checking");
- }
-
- /////////////////////////////////////////////////////////////////////////////