aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk6
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2014-04-17 18:24:47 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2014-04-17 18:24:47 +0000
commitec9037822d8ac6b32b8a8ccb6fe688c033ef4b8f (patch)
tree1a8a21cdcdcc6487c9185a68267f3e8ea53813bd /java/openjdk6
parent22787557f366b09907d796e24795a073980b85d2 (diff)
downloadports-ec9037822d8ac6b32b8a8ccb6fe688c033ef4b8f.tar.gz
ports-ec9037822d8ac6b32b8a8ccb6fe688c033ef4b8f.zip
Notes
Diffstat (limited to 'java/openjdk6')
-rw-r--r--java/openjdk6/Makefile2
-rw-r--r--java/openjdk6/files/patch-set29
2 files changed, 21 insertions, 10 deletions
diff --git a/java/openjdk6/Makefile b/java/openjdk6/Makefile
index dc690fa4233c..308a77baaece 100644
--- a/java/openjdk6/Makefile
+++ b/java/openjdk6/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openjdk6
PORTVERSION= b31
-PORTREVISION?= 1
+PORTREVISION?= 2
PORTEPOCH= 1
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_APACHE:S,%SUBDIR%/,ant/binaries/:ant,} \
diff --git a/java/openjdk6/files/patch-set b/java/openjdk6/files/patch-set
index 8659693b2d46..4a9ef9e14efb 100644
--- a/java/openjdk6/files/patch-set
+++ b/java/openjdk6/files/patch-set
@@ -13628,7 +13628,15 @@
#include <string.h>
#endif /* __linux__ */
#include <stdio.h>
-@@ -59,10 +59,24 @@
+@@ -40,6 +40,7 @@
+
+ #include <jni.h>
+ #include <jni_util.h>
++#include <jvm_md.h>
+ #include <sizecalc.h>
+ #include <sun_font_FontManager.h>
+ #ifndef HEADLESS
+@@ -59,10 +60,24 @@
extern Display *awt_display;
#endif /* !HEADLESS */
@@ -13654,7 +13662,7 @@
/*
* This can be set in the makefile to "/usr/X11" if so desired.
*/
-@@ -112,24 +126,40 @@
+@@ -112,24 +127,40 @@
NULL, /* terminates the list */
};
@@ -13707,7 +13715,7 @@
NULL, /* terminates the list */
};
#endif
-@@ -357,7 +387,7 @@
+@@ -357,7 +388,7 @@
#endif /* !HEADLESS */
@@ -13716,7 +13724,7 @@
/* from awt_LoadLibrary.c */
JNIEXPORT jboolean JNICALL AWTIsHeadless();
#endif
-@@ -482,8 +512,10 @@
+@@ -482,8 +513,10 @@
*/
fcdirs = getFontConfigLocations();
@@ -13728,7 +13736,7 @@
#else /* IF SOLARIS */
knowndirs = fullSolarisFontPath;
#endif
-@@ -494,7 +526,8 @@
+@@ -494,7 +527,8 @@
* be initialised.
*/
#ifndef HEADLESS
@@ -13738,7 +13746,7 @@
if (!AWTIsHeadless()) { /* .. so need to call a function to check */
#endif
AWT_LOCK();
-@@ -502,7 +535,7 @@
+@@ -502,7 +536,7 @@
x11dirs = getX11FontPath();
}
AWT_UNLOCK();
@@ -13747,7 +13755,7 @@
}
#endif
#endif /* !HEADLESS */
-@@ -614,7 +647,7 @@
+@@ -614,7 +648,7 @@
}
#include <dlfcn.h>
@@ -13756,7 +13764,7 @@
#include <link.h>
#endif
-@@ -660,9 +693,9 @@
+@@ -660,9 +694,9 @@
* certain symbols - and functionality - to be available.
* Also add explicit search for .so.1 in case .so symlink doesn't exist.
*/
@@ -13770,8 +13778,11 @@
}
--- jdk/src/solaris/native/sun/awt/gtk2_interface.c
+++ jdk/src/solaris/native/sun/awt/gtk2_interface.c
-@@ -32,7 +32,7 @@
+@@ -30,9 +30,10 @@
+ #include <string.h>
+ #include "gtk2_interface.h"
#include "java_awt_Transparency.h"
++#include "jvm_md.h"
#include "sizecalc.h"
-#define GTK2_LIB "libgtk-x11-2.0.so.0"