aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk7
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2018-02-08 06:29:02 +0000
committerGreg Lewis <glewis@FreeBSD.org>2018-02-08 06:29:02 +0000
commit7effcd49b2c34a53de1c0f67a87fa4aa33b59019 (patch)
tree06be364940e9e9fe1872caf392a06d109ba848d9 /java/openjdk7
parenteef0418ce07f5fc26184634d7bf9922799cfc2c8 (diff)
downloadports-7effcd49b2c34a53de1c0f67a87fa4aa33b59019.tar.gz
ports-7effcd49b2c34a53de1c0f67a87fa4aa33b59019.zip
. Fix the build for i386 when WITH_LLD_IS_LD is set.
PR: 225741 Submitted by: dim@
Notes
Notes: svn path=/head/; revision=461197
Diffstat (limited to 'java/openjdk7')
-rw-r--r--java/openjdk7/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index 59fcbeb5060e..0be6c4baed2b 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -162,6 +162,12 @@ BUILD_DEPENDS+= ${BOOTSTRAPJDKDIR}/bin/javac:java/bootstrap-openjdk6
.include <bsd.port.pre.mk>
+.if ${ARCH} == i386
+# Fix the build for i386 when WITH_LLD_IS_LD is set
+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=225741
+MAKE_ENV+= LFLAGS="-Wl,-z,notext"
+.endif
+
# GCC is broken with PCH: https://lists.freebsd.org/pipermail/svn-src-all/2015-March/101722.html
.if ${COMPILER_TYPE} == gcc
MAKE_ENV+= USE_PRECOMPILED_HEADER=0