aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk8/Makefile
diff options
context:
space:
mode:
authorRonald Klop <ronald@FreeBSD.org>2024-08-31 18:51:41 +0000
committerRonald Klop <ronald@FreeBSD.org>2024-09-03 06:52:35 +0000
commit762006dfa091ef3725f813aa92db772f2e901482 (patch)
tree71018a25aef856c826c28185e35fe8b8032bd751 /java/openjdk8/Makefile
parent67a1d31a9cdc5f67cc5b9c28bce323f74d0bf33d (diff)
Diffstat (limited to 'java/openjdk8/Makefile')
-rw-r--r--java/openjdk8/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index f7140a94d001..a90b1c831754 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -1,5 +1,6 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${JDK_UPDATE_VERSION}.${JDK_BUILD_NUMBER}.${BSD_JDK_VERSION}
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= LOCAL/jkim:jtreg
PKGNAMESUFFIX?= ${JDK_MAJOR_VERSION}
@@ -204,16 +205,6 @@ LIB_DEPENDS+= libffi.so:devel/libffi
.if ${COMPILER_TYPE} == clang
MAKE_ENV+= COMPILER_WARNINGS_FATAL=false USE_CLANG=true
CONFIGURE_ENV+= LIBCXX="-lc++"
-.if ${ARCH} == aarch64
-# PR258954: see <https://bugs.openjdk.org/browse/JDK-8247766>. Even though the
-# upstream fix has been applied to this version of the JDK, users still report
-# the assertion "guarantee(val < (1U << nbits)) failed: Field too big for insn"
-# occurring, when it is built with recent versions of clang.
-LLVM_VER= 12
-BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
-CC= ${LOCALBASE}/bin/clang${LLVM_VER}
-CXX= ${LOCALBASE}/bin/clang++${LLVM_VER}
-.endif
# clang 16 defaults to C++17, which no longer allows the 'register' keyword.
# There is an upstream commit that removes all the individual 'register'
# keywords, but it has not yet been backported to OpenJDK 8.