aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk8
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2020-10-25 23:42:38 +0000
committerGreg Lewis <glewis@FreeBSD.org>2020-10-25 23:42:38 +0000
commit03258c05c7888a978e95a75b923592a793c18186 (patch)
tree1e52ca6a057ccb6451c28134ba2390b5c22a831e /java/openjdk8
parent7581ab8fffd1891df8ecaf5b4097ca71d394fdd6 (diff)
downloadports-03258c05c7888a978e95a75b923592a793c18186.tar.gz
ports-03258c05c7888a978e95a75b923592a793c18186.zip
Fix the build for i386
* Disable jfr (at least for the moment) * Bump PORTREVISION so the port will get rebuilt on the package builders
Notes
Notes: svn path=/head/; revision=553301
Diffstat (limited to 'java/openjdk8')
-rw-r--r--java/openjdk8/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index d166779a33c2..da683fadbcbf 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -2,6 +2,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${JDK_UPDATE_VERSION}.${JDK_BUILD_NUMBER}.${BSD_JDK_VERSION}
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= LOCAL/jkim:jtreg
PKGNAMESUFFIX?= ${JDK_MAJOR_VERSION}
@@ -187,6 +188,7 @@ MAKE_ENV+= JAVADOC_CMD_MEM="-Xmx768m"
.endif
.if ${ARCH} == i386
+CONFIGURE_ARGS+= --disable-jfr
# Fix the build for i386 when WITH_LLD_IS_LD is set
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=225741
MAKE_ENV+= LFLAGS="-Wl,-z,notext"