aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk8
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2020-07-12 01:03:36 +0000
committerGreg Lewis <glewis@FreeBSD.org>2020-07-12 01:03:36 +0000
commitf6ccbefdc643d5fae360becb648634eb2754f9bc (patch)
tree989f41aa6efb42998b2d2cc73711af541cd9f731 /java/openjdk8
parent4159d8f6884c4dfed1db3d28700d8d9c84fa4491 (diff)
downloadports-f6ccbefdc643d5fae360becb648634eb2754f9bc.tar.gz
ports-f6ccbefdc643d5fae360becb648634eb2754f9bc.zip
More accurate vendor information
I've tweaked the values suggested in the PR patch. PR: 244634 Submitted by: Michael Osipov <michael.osipov@siemens.com>
Notes
Notes: svn path=/head/; revision=542061
Diffstat (limited to 'java/openjdk8')
-rw-r--r--java/openjdk8/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index 5c8625b9153a..5d116d114c5f 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -58,12 +58,18 @@ BSD_JDK_VERSION= 1
JTREG_VERSION= 4.1
JTREG_BUILD_NUMBER= b08
+JDK_BUG_URL= https://bugs.freebsd.org/bugzilla/enter_bug.cgi?product=Ports%20%26%20Packages&component=Individual%20Port(s)&short_desc=java/${PORTNAME}${JDK_MAJOR_VERSION}%3A%20
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-boot-jdk=${BOOTSTRAPJDKDIR}
CONFIGURE_ARGS+= --with-build-number="b${JDK_BUILD_NUMBER}"
.if ${JDK_UPDATE_VERSION} > 0
CONFIGURE_ARGS+= --with-update-version=${JDK_UPDATE_VERSION}
.endif
+CONFIGURE_ARGS+= --with-vendor-name="OpenJDK BSD Porting Team" \
+ --with-vendor-url="https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/" \
+ --with-vendor-bug-url="${JDK_BUG_URL}" \
+ --with-vendor-vm-bug-url="${JDK_BUG_URL}"
.if defined(NO_CCACHE)
CONFIGURE_ARGS+= --disable-ccache
.endif